Showing results for 
Search instead for 
Did you mean: 


Ryzen Threadripper 1950x dropping clock speed

Hi guys, recently I discovered a problem with my build. I'm using it mainly for rendering and when I put something to render, clock speed is slowly dropping and through some time it drops significantly, sometimes below 3.0GHz. I just don't understand why this is happening. Load temperature is stable 68 degrees Celsius. Any help or hint would be highly appreciated because I'm starting to go mad here. Thanks.

AMD Threadripper 1950x @3.4Ghz

Gigabyte x399 Aorus Gaming 7

Enermax LIQTECH TR4 360 (water cooled)

Corsair Vengeance CMK16GX4M1B3000C15, 2x16GB @3000MHz (XMP turned ON)

Gigabyte Aorus GeForce GTX 1080 Ti

Samsung 960 PRO M2

PSU: Corsair HX1000i (1000W)

Windows 10 Pro

29 Replies
Adept III

68° for threadripper it's a high temp: according to AMD it's max temp recommended.

Ryzen™ Threadripper™ 1950X Processor | AMD

i'm using a Noctua UH14S and temp rarely reach 60°, except when i launch stress test...

some questions: which software are you using to read CPU temp? which software are you using to render?

It seems that CPU is throttling...that's why clocks drops significantly..

Is the cpu cooler installed correctly? what are your idle temps?


Hi, I've read something about the temperatures and there are quite a few different explanations, some say that's normal others don't think so.

I'm using both HW Monitor Pro and AMD Ryzen Master. They both show the same temperature on load - 68°C. Idle temp is between 45-50°C.

I'm using 3Ds Max and Corona for rendering. I would say that the cooler is installed correctly but you never know, something might have gone wrong during installation.

I have Corsair 570x Crystal series mid-tower case and the fans from Enermax are positioned on the front panel and the other stock fans are positioned in the rest available space inside the case.

Any ideas? Should I take off the cooling and re-apply the thermal paste?


Another question: Windows power setting is on High Performance? Or Ryzen balanced?

regarding temperature, i have the same CPU (1950X) but my idle temps are really slower: 25-30°..... for example, i have downloaded Hwmonitor and now  my cpu is idling at 27°. very strange that you are idling at 45 - 50°...Celsius right?

i suggest you to verify your cooler installation...

Your motherboard temps are high too? i ask you to be sure that it's not a problem related to the case...if hot air remains in the case everything it's hotter, motherboard too..


Thank you for your answer

Windows power plan is set to Balanced. I'm posting a screenshot of HW monitor to see for yourself as I'm not sure which temperature should I look at.

Also, processor idle temp is now around 41°C but I'm running only Google Chrome, HW monitor, and Ryzen Master...



set power plan to high performance....

download hwmonitor non pro, so you don't have trial values..

this is what i you see i'm idling at  25/27°



Will do tomorrow since I'm at home already. One more question, could it be the case that the stock fans are turned the wrong way? I mean, I have 3 fans, two on the top blowing the air inwards and one on the back blowing the air outwards? As I already mentioned the Enermax radiator with 3 fans are situated on the front...


perhaps it's better that the two fans on top should blow air outwards, not inwards. hot air goes up...

the 3 fans of the enermax blow air inside to cool the radiator/water?

check if the enermax water pump is working correctly.....

and re-check that the cooler is properly installed....t.i.m. should cover all the IHS.

I flipped the two fans this morning and the results are better, but still not as good as yours :-/ perhaps the room temperature in my office is a bit high, I don't have a thermometer but I would say between 25-27°C.

Anyway, the temperature on load is around 62°C which is good considering the conditions and the great thing about that is I'm no longer experiencing clock speed drops. Temp in idle is around 39°C. I maybe still need to check the paste and the cooler seating.

Also, I've noticed that your "watts" are way lower than mine, I don't know if that has to do with the temperature? I'd say yes since it's directly connected with power consumption thus increasing workload and affecting temperature, am I wrong?



you are right: more watts means more power consumption that means more workload with finally temp are absolutely right.

Regarding differences between me and you about watts or power consumption it's because i don't have anything in's possible that you have some processes running, process or processes that raise up CPU utilization than power consumption. You should look at the Windows task manager...

Regarding AIO cooler i'm not a fan of this type of cooler for these reasons:

1) if pump fails CPU temp raise up till thermal shutdown....very risky, according to me; on youtube there are a lot of videos showing this problem. With a CPU that costs 1000€ i don't want to run these risks.

2) If temp water raise because of CPU heat, cooler will not be able to remove the same amount of heat...i think that is what arnesaknussemm was spoking about.

for this reason i prefer 100% and i use with optimal results air cooler.....and for threadripper there are some very good choices


I want to ask you a thing: i've read that you have ddr4 XMP enabled at 3.0ghz right? Could you tell me the vsoc voltage value applied automatically by the mainboard? or did you set it manually? Looking at your print screen it seems VIN5. Is this?

I want to use XMP me too and i wanted to know which voltages are automatically supplied by the mainboard to the SOC


So you're suggesting that I should switch to air cooling instead of water cooling? I already said I'm not much of a tech guy but that's what my friends that are quite into PC hardware told me I should buy.

Regarding processes, I will look a bit more into to see if something is consuming more power because it's strange.

Regarding XMP, I really don't know, I haven't touched anything, I just turned on "Profile 1" in BIOS. I can post you a screenshot of the settings if you'd like?


Regarding XMP you've just answered me... no need to post more screenshot. Thank you. I suppose that vsoc is VIN5.

Regarding CPU cooling i've just only told you my personal opinion. I know that there are a lot of people that prefer AIO cooler rather than air cooler. I'm not one of them My 1950X (no overclock)  is cooled by an optimal air cooler...and with a full CPU load i have max temp of 55 - 60° and for me it's a very good and satisfying result. And fans are very silent...for me silence is a plus. i don't like having an elicopter in my case .

If you are using an enermax AIO no need to switch to an air cooler. But next time you will build a PC consider an air cooler  .  


I still need to figure out why is the temperature still fairly high comparing to others and try and fix that.

I'm really glad you helped me out, so thank you! Flipping the fans did the trick for now and finally, I can use full Threadripper's power for rendering


just verify only a thing: in my previous experience with an asus p9x79pro and i7 3930k when i was enabling XMP in bios, my board AUTOMATICALLY was doing a sort of cpu overclock: stock settings for i7 3930k was: 3.5ghz full load and 3.8ghz full load on a single core. With XMP enabled clock was automatically raised up to 3.8GHZ for ALL the six cores...this means more power consumption and obviously more heat.

After i discovered that, i decided to set manually ram timings and ram clock without using XMP..  so no overclock was done , but my ram was at full speed.

I don''t know if your board do the same...really i don't know. But if you are not afraid entering and modyfing bios, you could load default settings and see if something changes about temperature...and if you use threadripper use 4 ram not only 2...if you use only two sticks of ram you are missing quad channel.

(Corsair Vengeance CMK16GX4M1B3000C15, 2x16GB @3000MHz (XMP turned ON).

I looked into BIOS and everything is on default settings regarding the processor clock speed.

Also, I "killed" every unnecessary process in Task Manager but the consumption only dropped to about 43W so I'm not sure what is causing that kind of power consumption since nothing relevant was running in the background.

I'm aware of Quad Channel but since I ran out of money when I bought the computer I decided to buy two more sticks of RAM later. Also, I think I made a mistake in choosing the RAM since I later found out that particular model number wasn't on Gigabyte's QVL nor Corsair's web page of supported RAM for Threadripper. Odd, but It's working...


I'm a bit late to the party, but  I had bought a cooler with thermal paste already applied to it and I found that the temperatures were not as cool as I would have liked (even when not under load). I didn't even think to re-apply it until I read this post about buying thermal paste. I actually tried both options on two different PCs and couldn't see any discernible difference between the two. I also swapped the paste on both machines to the other and again, no difference. Both are great imo. However, after trying both, the temperatures dropped down dramatically (in the region of 10-15 degress C) when both under and not under load.

Journeyman III

Can you look in CPU-Z if the Bus Speed is dropping?

I am actually having the problem that the Bus Speed on my 1600x drops which results the clock speed to drop as well.


I'm not sure what the value of the Bus Speed should be (I'm assuming 100Mhz)? I'm rendering something at the moment and will finish in half an hour or so, but I'm posting a screenshot from CPU-Z. (It's currently rendering so pay attention to the Core Speed)



Yes 100 Mhz so yours seems normal.


Idk, I'm assuming that the temperature could be the problem, but it's not like it's really hot in my office I don't have a thermometer but I would say around 24-25°C max! Or it could be that RAM is somehow throttling the processor because I just recently discovered that I bought two sticks of RAM that are neither on Gigabyte's QVL or Corsair's list. I'm not much of a tech guy so I'm not sure if the RAM could be the cause of the problem. Any ideas?


If you are maintaining a constant 68 degrees, it may simply be that the cooling solution is saturating. If you start off rendering on a "cold" loop then the processor may well be able to max out performance...but as the loop warms up it is no longer able to remove the same amount of heat. It will eventually reach an equilibrium that might mean 68 degrees is maintained at  lower clocks than starting out. The SenseMI working I guess.

While the enermax is undoubtedly a good AIO cooler it is still AIO and has it's limitations...

Journeyman III

Hello Guys,

I had something similar or related. I discovered it was a "simple" BIOS issue.

At first I thought it was a Windows update issue.

My rig:

Gigabyte X399 Aorus Gaming 7

AMD 1950X

Noctua NF 12

Windows 10 64 bit

After a corrupt BIOS crash (second time, I assume it has something to do with the use of the white USB connector that is also used for the Qflash rescue)  and a Qflash recovery (pff) I noticed my base clock was not 3.4 but 3,7 and did not go down when idle. Also the voltages were higher than ever before and the mainboard always ended with a post code a5 (something about a scsi boot reset issue).

Note: I had set everything to default within my BIOS and I cleared the CMOS.

After booting into W10x64 the clocks go up and are not going down to 2.2 when it's idle as it did before. Also the CPU voltage stays high at 1.3-1.4V as before it dropped in idle to 0.9-1,1V.

As you can influence the base clockspeed with Windows power options reducing the max. processor state I tried this but no luck: the voltages stay way too high resulting in high IDLE temps ramping up my CPU fan all the time. Below screenshots of the change of processor state. The first one you see is at 80%, than at 90% and at 100% processor state.



Then I realized I did a BIOS recovery with the latest BIOS version F10. So what if I go back to the old F3G BIOS?

Voila, everything is ok again. Look at the speeds and VOLTAGES! Also tested in stress, than the speeds go up nicely to 3,7!

Everything as it should be. Also the A5 BIOS post code disappeared and the nice AA code appeared again.


So NO BIOS updates for me for the time being. Need to know what causes this!

Hope Gigabyte will take notice and do a BIOS revision.

Adept I

i'm getting this, too, however my temps aren't maxed out. another thing is that i'm undervolted by 0.1V

it works ok the first 6-18 hours at least at 3.7GHz (at 100% cpu; i do distributed computing), then it starts to slowly drop, even under 3.4GHz

i also tried rebooting, but it immediately started at these speeds



Did you change anything recently?

If you did update the BIOS try to restore to the earlier BIOS.


not that i recall. i DID do some tests on RAM and when i was done ended up restoring Optimized Defaults (and restoring the undervolt). this time, it had fallen in speed (to around 35x) in less than 24 hours

Big Boss

Forum just lost my reply.  Short version:  Use Ryzen Master (RM) as the only Valid reporter of Ryzen parameters.  Please drag-n-drop an RM screenshot if you have a problem.  If any of PPT, TDC, EDC or CPU temperature reach a limit the CPU voltages and clocks are lowered to protect the processor.  You can choose, you can increase the limits to allow more headroom.  Here is my Cinebench RM Profile where I have increased PPT and TDC:


I needed to use BIOS to get my limits that high.

Thanks and enjoy, John.

EDIT: I should have stated that Threadripper 1 does not have PPT, TDC and EDC in RM.  Since I am not an OCer I do not know how TR1 handles this but suspect that there are similar controls in the BIOS.  I hope someone with experience with TR1 will comment.

Journeyman III

I have the same issue. During rendering with 3ds Max and Corona, CPU drops to 2.72 Ghz or less and it's not using 100% of CPU. I've tried everything..such as BIOS reset..Changed power plan to high performance etc..Nothing is working out. Any help would be appreciated. 10-03-2020 02-06-25.jpgThanks!


I found out that my Enermax CPU Cooler had a flaw and wasn't cooling the CPU properly. After I switched to Noctua everything is more-or-less ok.

I have to warn you that I still haven't found the right cooling solution for this processor since nothing on the market is near perfect (maybe BeQuiet! Dark Rock Pro TR4 has somewhat better performance). Simply said, this processor isn't built for rendering since it has no adequate cooling solution. Eventually, the temperature will go up to 68°C and it will throttle.

Another option is to put the computer in a room where the temperature isn't above 18°C (Server room conditions) but I guess that's not an option for you so you'll have to learn to live with that until someone makes a proper cooling solution. 

Good luck! 


Thanks for your reply. I am using Noctua air cooler for the system. What's interesting is I have 2 more 1950X workstations with more or less same configuration(same cooler, same processor and RAM) but different motherboards.

However, on those 2 workstations, during rendering, temperature exceeds above 79 C..Sometimes as high as even 81 C..but they never throttle..CPU clock speed remain consistent at 3.5 GHz+ and, they always use 100% of CPU.

I am wondering if it's a simple windows issue or do i need to update motherboard BIOS as Coen99 suggested in above post?