Showing results for 
Search instead for 
Did you mean: 



ryzen master killed my cpu

so i built this beautiful machine TR 1900x gigabyte mobo x399 aorus gaming , 64 gb of ram gskill rippjaw 3200 mhz cl 16

built was fairly easy posted from the first power on and was working for 4 days until i downloaded the ryzen master and decided to use the creator mode to see the difference in rendering

i hit apply and the system went to a reboot ans stayed there in an endless reboot loop , mobo displaying D0 error code

tried it all to revert but the machine wont even go to bios , reset cmos remove ram remove gpu remove cmos battery remove cpu and install again , same THING

machine is turning on and off on and off , i had to RMA the BOTH , MOBO AND CPU BECAUSE I DONT KNOW WHICH ONE OF THEM IS DEAD .....

am not even an over clocker didnt play with preset i just hit apply , now i have to wait for the parts to come and lose money on shipping and stuff,

system was totaly stable i ran AIDA 64 on it for 8 hours the  thing seened to be solid until the ryzen master MESSED IT UP


6 Replies
Adept III

i see that gigabyte mobo x399 aorus gaming is a dual bios motherboard. Have you tried using second/recovery bios?

According to what you are saying, it seems that ryzen master "wrote" bios or some part of it, corrupting it.

I think that the problem is ryzen master+gigabyte x399+that specific bios version.

I'm telling you this because, one year ago a specific version of ubuntu bricked my first AM4 motherboard Asus B350 plus...writing directly into the bios.

i had this problem...after installing ubuntu i was no more able to boot or to enter in eufi.....motherboard bricked


Dear Randa

I’ve tried it all, what’s listed in the books and what seemed right to me at that specific moment , nothing worked . Am never going to use the Ryzen Master again when my new CPU amd MOBO comes, if I want to tweak the performance I’ll do it straight from BIOS, I should’ve not trusted any Windows based software to talk directly with the BIOS I know better than that , but like they said curiosity killed the CAT,

On the other Hand I’ve seen on some other Forums that AMD advised not to use creator mode on 1900x and stick to the Game mode, but saw that too late apparently there is some glitch some where .

Sent from my iPhone


and yes curiosity killed the cat and the mainboard too .

I suppose that CPU is OK. I think  that the problem is with bios mainboard...

Generally speaking, according to me, it's not correct that some software should be able to modify or write in bios...only bios should modify or write in bios....

Otherwise these are the results.....


Well , i RMA ed both the board and the cpu to be on the safe side

Sent from my iPhone


on another note, this Ryzen master seem to go back to default when we reboot. Here anyway.  I don't trust that Ryzen master neither, my computer has frozen tight once with not that much of an OC.    Anyway no more OC for me.

I've seen some benchmark about the Thread Ripper, it seem to be quite a powerful cpu. One has to wonder why someone would attempt to OC this chip.

I know it's an X série but it's already so fast that for the price it cost  I would treat it with respect... only slightly OCed or just standard.


Well I made a mistake not buying the 1950 x and I got the 1900x since it has a higher base clock, and 16 cores seems to be too much for me , and spent the money difference on the GPU and PSU

My set up is

1900x cooled with enermax liquitech 240

64 GB RAM G.Skill Ripjaws V CL 16

X399 gigabyte aorus gaming 7

3x M.2 512 one drive for apps and OS and the other two are RAID0 scratch

disks for after effect and adobe premiere and 1 TB Samsung 950 evo for storage and BKP

2x 980 TI hybrid in SLI

To be honest am a bit disappointed as I expected a higher performance , don’t get me wrong the set up is good but I was expecting more .

Sent from my iPhone