Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen Master Driver - not installed properly

Raising a new ticket on this, as my workaround did not fix the issue. 


Hey, I've just upgraded my system from 3700x to a 5950x and AMD Ryzen Master is acting weird. There is only one registry in regedit as I wanted a fresh Windows install with the upgrade. 

Reinstalling doesn't fix it. Reinstalling chipset support didn't make a difference. Bios changes won't make it flick either. Anyone got any suggestions? 

I'm on Adenaline 21.8.1,Ryzen Master, but does this really matter?

I am using an Asus x570 Prime Pro, Bios Version 4021.


I tried renaming the regedit folder and it allowed me to load Ryzen Master, however, when I chose Precision Boost Overdrive, it asked for a Restart and when it booted back up, the same message of the driver not being installed properly popped up, and the folder that I renamed initially dissapeared. 

8 Replies

Not sure how closely AMD staff watches this forum, haven't seen too many replies from them.

What were you renaming before?  Were you renaming the install folder to match your registry entry, or were you renaming the registry entry to match where Ryzen Master is actually installed (should be pointing to c:\program files\amd\ryzenmaster\bin\amdryzenmasterdriver.sys)?


Hey mate, thanks for pitching in again. I basically renamed the folder entry in regedit to match your (added v19). This is the action that allowed me to open Ryzen Master. However, after trying to enable Precision Boost, a restart was required and we're back to square one. The folder that I initially renamed AMDRyzenMasterDriverv19 in regedit also disappered and now I just have the AMDRyzenMasterDriver one.

In the meantime I will raise a ticket via the Adrenaline platform and hope for the best


Really strange issue....have you tried changing the path in the registry to point to the file, but not adding the V19 to the end of the service name?  IOW, just leave the service name as-is, and only change the path.


Yeah, no change whatsoever Though I noticed that I have 2 AMDRyzenMasterDryiver.sys files. One in C:\Program Files\AMD\Performance Profile Client and the other in C:\Program Files\AMD\RyzenMaster\bin.

I've submitted the issue using the Reporting Tool, and I've noticed they took the install logs from Ryzen Master. 

MSI (s) (B0:50) [16:35:49:066]: Windows Installer installed the product. Product Name: RyzenMasterSDK. Product Version: Product Language: 1033. Manufacturer: Advanced Micro Devices, Inc.. Installation success or error status: 0.

I don't think I can upload the logs here. There are some errors, but nothing stands out in particular.  The installation seems to be fine. 


It sounds like some sort of conflict.  I also have two AMDryzenmasterDriver.sys files, one is in the Ryzen Master bin folder, and the other is in my Asus AI Suite III folder.  The two versions are different, the one in the Ryzen Master folder is version and the one in the AI Suite folder is version  But I'm not having issues with Ryzen Master since my service is pointing to the correct version of the driver.  I'm using Nvidia graphics so didn't need to install any other AMD software (except chipset).

Check the version of the driver in your Performance Profile Client (that's part of the Adrenaline software I guess?) folder, I'd bet it's not  So I'm guessing what's happening is that it's probably an older version of the driver that is being loaded by the service, and when you run the actual Ryzen Master application, it won't work because the driver's not version

So try this - rename the driver in the Performance Profile Client folder to something else (I usually just put .bak at the end), and then copy the driver file from the Ryzen Master bin folder to the Performance Profile Client folder.  Basically to trick the system into loading the correct driver, without needing to modify the registry.  Then reboot and see if Ryzen Master works.

Don't know if this will break something else though.  I'm not familiar with the Adrenaline software.




It's the same versionon both same size and allAMDRyzenMasterDriver.jpg

Though you made me curious with what you said about the existence of the AMDryzenmasterDriver.sys in the Asus AI Suite III folder. Why is that? I'm also using Asus AI Suite III for fan control, but I don't have a Ryzen file in its folder. 


Coulda swore I posted a reply a week ago....

Anyways, I would guess AI Suite has its own copy of the RM driver to be able to low level monitor the CPU.

What I would try is instead of modifying the existing registry key, to instead add a new AMDRyzenMasterDriverV19 key alongside it, as that's the key that the RM app expects to see (I tested this myself, I renamed mine to remove the V19 and then Ryzen Master stopped working with the same error message you got).  And then have the value point to the Ryzen Master driver in Program Files\AMD\RyzenMaster\bin.



Right. I'll give it a go. If this fails, I'll reformat Windows once again and not even attempt to install anything ASUS related. I will controll the case fans from the Bios and the rest via iCUE. 

Thanks mate.