Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen CPU and Outlook 201x s/mime encryption and digital signature not possible

Dear AMD Community,

with a brand new Windows 10 System with a Ryzen CPU it was not possible to use a digital signature with Outlook 2016/2019. The Problem is described in detail here: Signatur mit S/Mime-Zertifikat in Outlook 2016 schlägt fehl - Microsoft Community 

Microsoft found the issue in cooperation with the users which have the issue. Solution is to delete the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Cryptography\Providers\AMD Providerkey in the registry. 

Reason for that is the missing amdumcsp.dll which should be located in C:\Windows\system32.

Can someone from the AMD Stuff confirm this and provide the amdumcsp.dll for Windows 10? Just with this DLL S/MIME will work on Windows 10 with Ryzen CPU / AMD Chipset out of the box. 

Thank you very much

Kindly Regards


14 Replies
Adept I


maybe it is possible that an AMD Software Engineer can have a look into this problem? That would be very nice. Sure, the problem is solved now with the workaround i described, but the reason for this issue is still present. On every fresh installed Windows 10 machine with a AMD Ryzen CPU and Office 2016/2019 with S/MIME configuration the error occurs.

So please take a look into this. I think this is a small thing for AMD to provide the missing DLL.

Thank you

Kind Regards


Big Boss

ronald, please open a support ticket here.  This is a user forum (almost no one works for AMD) and I think you need to talk to AMD directly.  Good luck and enjoy, John.

Hello John misterj,

thanks for the information. My fault! But maybe another user have the same issue so they have now a topic here. 

I will open now a support ticket. Thanks for the link.




Thanks, ronaldb, you are welcome.  Yours is the first inquiry on this subject I have seen.  Please let us hear what you learn.  Enjoy, John.


Of course John, I keep you (and all the others) in touch. 



Hi all,


i also ran into this problem - but with the latest Outlook version 2021.

I deleted the AMD CSP registry entry and restarted my PC but still the same error message.

Does anyone have news for this issue?





Deleted answer since it isn't what Duffy6 was looking for.


Thanks for the replyI already used that tool, too!

but still running into the same error

again deleted my reply since it isn't what duffy6 was looking for.


Dear elstaci,


please read first what the problem is about!

this problem isn‘t about signatures at the end of emails!

it‘s about signing and encrypting mails!!!!


deleted  answer since it wasn't what duffy6 was looking for.

Maybe Duffy6 will be clearer in exactly what is his issue with Outlook 2021 instead of just saying it is the same as the original OP post from a long time ago.




Dear Elstaci,


I would prefer if you would READ my posts before answering! I am not NOT talking of OWA, but of the Outlook desktop application.


So AGAIN push this thread since it is a AMD problem!


And PLEASE read and look into this problem before posting again! Thank you!


I deleted all my previous answers directly to you since you seem keep saying they weren't relevant to Outlook and the only information you mentioned  I HAVE THE SAME PROBLEM WITH OUTLOOK 2021.

Without going into details about the "same" problem you are having. It probably isn't the same problem since it didn't work for you..

how is a Outlook issue a problem with AMD?

Maybe you can explain your hypothesis on this. Because I don't see any connection between an email program and AMD Drivers.

If a AMD driver/program Registry entry is affecting Outlook then it is Outlook issue to make sure another program's registry entries doesn't affect it.

So please go to Microsoft who are the creators of Outlook and ask them for help.

So I won't reply anyone since I can't seem to read your mind or determine exactly what your issue is with a email program and AMD Driver/program.


Dear Elstaci,

once I again I beg you to read my links before posting.

May I use to translate this article from Europe's greatest IT-magzine:

translated with

AMD Ryzen blocks signature

I recently changed computers and now I can't sign emails in Outlook with my digital certificate. Using a different profile didn't help, nor did reinstalling Office.

If your new computer uses an AMD Ryzen, it may be that the chipset driver is indirectly responsible. When installing the chipset driver, AMD may create a new signature algorithm (SHA224) and the corresponding Crypto Service Provider (CSP) in the registry. It happens that this goes wrong, the corresponding DLL is not created and the CSP is therefore not functional.

Office checks all installed algorithms during signing and tries to load the necessary CSP. The missing DLL leads to an abort and to the unspecific error message "Error during this operation. The message interfaces have returned an unknown error. If the problem persists, restart Outlook". This happens even if SHA224 and the AMD provider are not needed for the signature at all.

You should make sure that the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Cryptography\Providers\AMD Provider is present on your system, but the associated DLL in C:\Windows\system32\amdumcsp.dll is missing. In this case, you can try to delete the "AMD Provider" key. After a restart, Outlook should sign emails again. As always, it is advisable to make a backup of the system beforehand. (

Translated with (free version)



As you can see this is obvious that IT IS an AMD-proble due to the install bug of the chipset drivers.

Probably there is a solution: an Intel-CPU