cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Highlighted
Journeyman III
Journeyman III

Ryzen Balanced power plan does not allow standby

Hi all,

Although it's not a major issue, I'd like to point out that my system does not go into standby when I activate the Ryzen Balanced power profile.

This issue has been present since the power plan first came out. I've already reinstalled Windows 10 once and the issue remains.

Here's my system configuration (built in early April):

AMD Ryzen 7 1800X - with Cryorig R1 Ultimate

Asus Crosshair VI Hero with 1602 BIOS

G.Skill FlareX 16GB DDR4 3200

EVGA GTX 1050 Ti FTW (temporary graphics card )

EVGA 850 P2 Platinum PSU

Samsung 960 Pro 512GB w/ Alphacool HDX M.2 cooler - latest firmware

Seagate Firecuda 2TB HDD

NZXT Noctua 450

Windows 10 Pro 1703 latest updates

Razer Diamondback Chroma

Roccat ISKU+ Force FX

LG BE16NU50 BD Writer

Samsung CFG70 24" Monitor

I'm willing to try out suggestions if anyone wants to help solve this issue.

0 Kudos
20 Replies
Highlighted
Adept I
Adept I

Re: Ryzen Balanced power plan does not allow standby

Do you mean the PC will not go into S3 Sleep mode, Windows Sleep automatically, with the Ryzen Balanced Power Plan?

If that is the situation, that is caused by the Sleep option in the Advanced settings of the Ryzen Balanced Power Plan being set to Never by default.

Can you manually enter Sleep mode? Sleep works fine with my Ryzen PC.

You can change the Sleep setting if you click on Power Options, then select Additional power settings, and then click on Change plan settings for the Ryzen Balanced Power Plan.

At this point, you should see the Put the computer to sleep: setting displayed, which will be set to Never. Change it to whatever you like.

On that screen, you could also click on Change advanced power settings, and in the list of settings open the Sleep option. Open the Sleep after setting, which you'll find is set to Never. Change Never to whatever you want for the time before the PC enters Sleep automatically.

Why Sleep after is set to Never in the Ryzen Balanced Power Plan, I don't know. That is the default setting for the Windows High Performance plan.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Ryzen Balanced power plan does not allow standby

Thanks for the answer, but nope. That was the first thing I tried.

pastedImage_1.png

I've also tried cloning the High Performance power plan and then setting the Minimum processor state to 5% (High Performance doesn't park cores), but same result.

The system doesn't go into S3 Sleep automatically. I've also tried shorter timings than 30 minutes but no go.

I've also tried a few things by cloning the Balanced power plan.

The system will enter Sleep mode if I do it manually through the Start menu.

I've also tried cloning the two power plans and setting all the settings equal (so that the only difference is core parking) and I believe that core parking is the culprit.

Power plans with core parking disabled do not enter S3 Sleep, whereas if the core parking is enabled automatic Sleep works.

Could this be a BIOS issue or maybe a Windows 10 issue?

0 Kudos
Highlighted

Re: Ryzen Balanced power plan does not allow standby

In an elevated command window, run this:

powercfg -requests

Report back what it says.  You can output this to a file by adding >C:\Folder\To\File\Name.txt if you want to just copy-paste it from Notepad.

Step 1 is to figure out what is stopping it from sleeping; it's very likely some roque hardware that, when it's being allowed to get into a lower power state, it's waking and resetting the sleep timer.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Ryzen Balanced power plan does not allow standby

Ran the command and the output doesn't seem to have any clues. I ran it after the timer should have put the system to sleep. The power plan was set to the Ryzen Balanced.

Here's the output:

DISPLAY:

None.

SYSTEM:

None.

AWAYMODE:

None.

EXECUTION:

None.

PERFBOOST:

None.

ACTIVELOCKSCREEN:

None.

0 Kudos
Highlighted

Re: Ryzen Balanced power plan does not allow standby

What happens if you set the sleep time to like 1 minute?  It seems very odd that your computer CAN sleep (manually), but windows isn't going to sleep for no reason.

Try that, and run that same command a few times; this is the first time, personally, that I've seen that command not report (some potentially cryptic) answer for why the computer isn't sleeping.

Edit: So, I did some Googling, and it seems that the command I provided doesn't necessarily include all devices.  Found it on here:

https://support.microsoft.com/en-us/help/976877/windows-7-does-not-go-to-sleep

... namely, the section that involves "Powercfg -devicequery wake_armed". You could try disabling all of those one-by-one, see if the PC goes to sleep.  If it does, you'll know which of them is causing the issue, and maybe just disable that device's power-saving features, or hunting down a driver issue.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Ryzen Balanced power plan does not allow standby

I tried it again with a short time interval (2 minutes) and I still get the same result.

As usual, if I switch to the MS Balanced power plan the system goes to sleep. If I use the High Performance with 2 minute timer (no core parking) the system does not go to sleep (just like the Ryzen plan).

0 Kudos
Highlighted

Re: Ryzen Balanced power plan does not allow standby

Did you try the part I mentioned after "Edit" ?

Random other thing: did you install the Samsung NVMe driver?

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Ryzen Balanced power plan does not allow standby

I don't see the part after "Edit".

Yes, I am using the Samsung NVMe 2.2 driver. Normally unless there's a major issue I keep everything updated to the latest.

0 Kudos
Highlighted

Re: Ryzen Balanced power plan does not allow standby

No idea: here it is ...

Edit: So, I did some Googling, and it seems that the command I provided doesn't necessarily include all devices.  Found it on here:

https://support.microsoft.com/en-us/help/976877/windows-7-does-not-go-to-sleep

... namely, the section that involves "Powercfg -devicequery wake_armed". You could try disabling all of those one-by-one, see if the PC goes to sleep.  If it does, you'll know which of them is causing the issue, and maybe just disable that device's power-saving features, or hunting down a driver issue.

0 Kudos