Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 9 5950x Running at 74c, Is this a safe Temperature?

I have paired a new Ryzen 9 5950x with an Asus Crosshair viii hero, but I am suffering really high temperatures. at idle the processor is running at 75C.   Under very light load goes up to 80C

I have tried lot of things and just for clarity I am very experienced in building machines (over 25 years). 

I used a Corsair 100i platinum cooler and after several attempts to cool ( 4 reseats using 3 different CPU thermal pastes) I came initially to the conclusion it was the cooler at fault. 

Wanting to use I bit the bullet and bought a replacement cooler a Kraken X73, I installed and net result was  1C cooler i.e. 74C.  So not the cooler but something else!

I did some searching online to discover others have been having a similar issue multiple motherboards, I found some suggestions to help which were to switch my board into an eco mode (which did nothing) the next suggestion was to disable boosting (which kind of cripples the chip) , this I did and now see temperatures in the region of 45C. I don't know where the problem lies exactly, but if several manufactures are seeing then it kind of points to an AMD issue with the Chip or something they have supplied to the board manufacturers. After days of building and then re-applying the coolers I do feel a little cheated. I tried raising with ASUS but because I registered my motherboard for cash back it is saying the serial number is already registered so cannot raise a support case. I coming on here hoping that someone can give some advice and maybe someone from AMD can help.   


663 Replies


Let us know any results after doing what you mentioned if you don't mind


Okay.  Manifold is still in place, but now I go directly from the CPU to the GPU and the GPU back to the manifold and then out to the radiators.



Original temps on the CPU have been restored.  Parallel CPU and GPU was definitely the cause of my 10C temp rise. 


This whole platform makes no sense....


I think, at least in my case, the QD3 koolance fittings created enough additional restriction to force most of the flow down the GPU path.  I didn't have a digital flow meter hooked up so I can't quantify how much went each direction.


But again, this doesn't really explain your problem.  Now my system is in serial with an RTX 3090 in the loop just like yours.  And my temps are far lower again.




Can you post a Timespy result for me on your system?  I am curious if just your CPU score will throttle due to temps or the GPU as well.


I ran mine with the RTX 3090 FE now in the loop.  Power slider was maxed at 114C.


Well, it really is just the CPU.



Other than swapping out the CPU to test whether it is a CPU or motherboard problem, not sure what else you can try at this point.  How hot do the chipset VRMs get under load?  Anything abnormal there?







Any luck with your issue?


Looking at the image of your loop recently, is your bottom rad setup as pull into the case over the rad? and the top pushing out of the case over the rad?  As in, are you using the exhausted warm air of the bottom rad to cool the top rad?


What does your coolant temperature rise to under load?



I've since added a external rear mounted 120mm with a filter as an additional intake. Not the most elegant solution however it seems to help with temps while mining, otherwise all the same unfortunately.

I have considered changing all to intake that way all air passing through the rads would be fresh but also I'd have to put up with the rears of the fans showing, another possible alternative would be all exhaust I guess but then I'd have to dust every other day... This is what I get for going small I guess... Last case was a 900D 

for coolant temp unfortunately I don't currently have a way to check this.


Not a big deal if you don't have a temp sensor.  Does running without the case panels on change anything?  That is an easy way to check a potential airflow problem.




I currently have my CE 420 and 280 both operating as exhaust and in push/pull.  After a timespy extreme stress test my liquid temp went from 22C to 32C.  A Delta T of 10C isn't too bad considering I am actively cooling the CPU, GPU (hybrid backplate), and VRMS.


as suggested by Ero_Sennin  here above, try to use Open Hardware Monitor which looks more accurate on tracking CPU frequencies. 

I was under the same feeling as you, but after letting it run for about an hour when using my computer, I found easier to see core speed compared to HWinfo



So it seems like there are a few different issues going on here.  My recommendation for setting up Ryzen 5000 series is the following:


From default UEFI settings first set your RAM speed and timings in "extreme tweaker".


Then go into the Precision Boost Overdrive settings under AMD Overclocking.

Turn on Precision boost overdrive, and manually set the scalar to x1, auto overclocking to +100 and the PPT/TDC/EDC limits to 142W/95A/140A.  These are the default settings for a 105W TDP Processor.

Run a multithreaded load like Cinebench R23 and note your temperature and voltage on the multithreaded load (Ryzen Master, HWIFNO). 

Also run OCCT small data set/extreme/constant workload (1hr), and large data set/extreme/variable to check for errors.  If everything is fine, proceed to the next step.  If the processor is running hot here, either there is a problem with the installation of the cooling block/thermal paste, or there is a problem with the IHS on the CPU.  In the latter case an RMA is the only recourse.

If temps are fine at stock, slowly raise the TDC.  Also raise the PPT by 1.5W for every 1A of TDC.  So at 105A your PPT would be 157W.  EDC is the short term boost amperage allowed over the TDC.  I tend to keep this with 20A of the TDC.

Run Cinebench or your favorite benchmark again after each increase.  Monitor voltages on multicore load and temps again using Ryzen master or HWINFO.  Keep doing that until your voltage is hitting 1.3V on multicore loads or the temp is where you want it to be.

Once that is done, you'll see that you are bound by TDC or temperature in multicore load .  You can then reduce the PPT such that both are near 100% usage when running a benchmark.

Run both OCCT sets again to test the stability of those settings.  I wound up at 215W/140A/160A (X470 Crosshair VII).  I am at 1.3V multicore load and temp is at 70C.  TDC is at 100%, PPT is at 94% when running a multicore load using those settings.


From here, you can move to curve optimizer under AMD overclocking and try to get a bit more out of the processor.


Doing things this way should mitigate the whea/BSOD errors that can occur when PBO is enabled with motherboard settings.


Now there is a third issue where the CPU will be fine under multicore loads and only get hot under a lightly threaded gaming loads.  That is harder to explain, and I'm not sure what the solution to that would be.  That does not happen with my Ryzen 9 5950X so it is hard to troubleshoot.

I like this approach. However, in my case I started seeing WHEA errors cropping up.

I have a Strix 570-E mainboard, so following the steps was pretty easy.

I was also experiencing random reboots when pushing the RAM to 1.35v and associated D.O.C.P timings. 

I've gone back to my Ryzen Master profile. I get an all core speed of 4350 at 1.3V.

Oddly, I set the memory to be coupled at 1800 for both the memory and fabric clocks without the voltage bump to 1.35V. It seems to work fine, although the default timings are horrible (set to Auto) and nowhere near the timings you see if you look XMP values up.

Stability with good performance is what I'm looking for. Ryzen Master is pain to start every time but I think it's helped me increase the life of the CPU by not pushing extra voltage to get performance.

If I could find out how to apply this method successfully without WHEA errors, I'd like to revisit this method.





You could try the following RAM timings at 1.35V and 3600/1800.



That has been working for me, although they are fairly loose.  Turn on PBO but set it to default limits (142W 95A 140A) for a 105W TDP processor.  Do you still get errors then?


Using just the PBO settings mentioned, no WHEA errors. Using Ryzen Master to monitor.

Multi-core Cinebench R23 test showed all core running at 4113 ish for a score of 13673.

Average temp was 70C. Average voltage: 1.36907V

SMT is disabled. Single core was running about 4500. Temp was averaging 60C. Peak voltage was 1.47V. Cinebench score was 1326.

So it would appear in my case, I would be surpassing the 1.3V just using the default settings for the 105W TDP.

Just had time to do the quick test at lunch. Will look into the RAM settings. Thanks!





That voltage does seem a bit high for default settings.  If you run OCCT small data set/extreme/continuous, what is your voltage/temps per OCCT at default PPT/TDC/EDC?  


I get this exact problem on my side. ASUS Crosshair VIII Motherboard and a 5950x:

Now there is a third issue where the CPU will be fine under multicore loads and only get hot under a lightly threaded gaming loads.

-Idle temp: I get 35 to 45C
-Suddenly for no reason when browsing/opening app / defender start a scan: my CPU temp peak instantly up to 81C in Tdie Temp, after some seconds (2-3) it goes back to normal stable idle temp.
-in Benchmark or games when my CPU get a heavy load (OCCT/3DMARK) my CPU temp stabilize to 56-65C
Everything is stock, (no PBO, no overclock) with a 360mm AIO (0-60C fan curve set to ~1100RPM). My idle/load temp seems to be perfectly fine, but i keep getting random weird peak temp for no reason... I'm not sure what could be the problem. 





A similar issue was posted in this thread.


I'm not sure that it was ever resolved.  If you turn on PBO, but manually set the limits to PPT/TDC/EDC 142/95/140 does the issue persist?  This should use the same limits as stock operation.


Hi everyone,

I recently purchased an AMD Ryzen 9 5950X based computer as well.
This is my first AMD system in quite a few years, I run mainly Intel-based hardware on all of the computers in my software development business.

I too am getting rapid spikes up in temperature when I do something as simple as launching an application, even basic apps like Notepad or HWMonitor or Macrium Reflect cause the temps to spike up into the 70C's.

My idle temps are typically around 38C-42C (20C-22C room ambient) and I get around 68C to 72C in Prime95 all-core 100% load and in games like Doom Eternal and Borderlands 3.

A couple of times my temps went over the 95C threshold and rebooted my computer to a BIOS Over Thermal error message.
I found this quite concerning.
So I did a bunch of various tests and settings to determine what the issue is and how to alleviate it since I can't have the computer randomly rebooting during use.
When I apply processor over-clocks of various settings such as 4.2GHz 1.1V and 4.5GHz 1.3V the system runs stable and doesn't get overly hot.
I did a bunch of various changes with the PBO and CPB and was never able to get anything satisfactory, I was either stuck at lower clock speeds for single-core, or the temps still went wildly close to over-thermal reboot.

So I dropped my Memory settings from DOCP back to Default, which removes the memory and processor memory controller over-clock and over-voltage, and my temps immediately dropped by 10C.
A 10C heat increase for a 1% to 3% performance boost isn't worth it, so I would recommend that anyone overclocking their memory go back to the defaults.
Some of you may argue that "you aren't getting what you paid for if you buy 3200 etc memory and run it at defaults" but using DOCP *IS* an over-clock and over-voltage on the processor memory controller.  The result will be extra heat.
This memory DOCP change to Default made the biggest difference in getting my thermals back down to a lower value for idle and full load.

I reset all of the PBO and CPB back to defaults of Auto, and I noticed that a PBO of Auto is actually Disabled (which is not intuitive), and in my PBO group of settings is the Thermal Throttle property, which is also set to Auto, so I wondered if that also defaults to Auto equals Disabled...  I Enabled Thermal Throttle and set it to 80C and now my issues with thermal reboots no longer occur and my processor correctly throttles at 80C just like I would expect and just like what I want.

Some may think that 80C is too low, but I can still easily get 4.9GHz single core and 4.4GHz to 4.6GHz multi-core no problem.
So I am happy now with just that one simple setting change (Thermal Throttle enabled to 80C) and every back at BIOS Defaults.
I am also running with DOCP set to Auto which clocks and voltages the memory and memory controller at default speeds, since I don't feel the 3% performance increase for a 10C temperature increase is worth it at all.

I took screenshots of CoreTemp and HWMonitor if anyone is interested or questions my findings.
I can also take a photo of the ASUS ROG BIOS screen showing where the Thermal Throttle setting is, but on my system it is located in the Precision Boost Overdrive group of settings.

My system hardware:

- Lian Li LANCOOL II Mesh RGB White case
- AMD Ryzen 9 5950X 16-Core 32-Thread processor
- Noctua NH-D15 Chromax Black dual-tower cooler
- ASUS ROG Crosshair VIII Hero WiFi motherboard
- 128GB Corsair Vengeance LPX DDR4-3200 memory
- ASUS TUF Gaming OC 10GB RTX-3080 video
- Cooler Master V850 Gold V2 850 Watt psu
- Samsung 980 PRO 1TB NVMe 7000MB/s (Windows)
- Samsung 970 EVO 1TB NVMe 2500MB/s (Temp)
- Crucial MX500 2TB SATA SSD 500MB/s (Data)
- WD Green 2TB hard drive (Data Backup)
- WB Blue 1TB hard drive (OS Clone)
- Ducky ONE 2 White LED mechanical keyboard
- Microsoft IntelliMouse Classic
- Microsoft XBox Controller
- Dell S3220DGF 32-inch Curved 2560x1440 monitor
- Mackie CR4 Reference Monitor speakers
- Windows 10 Professional x64



@ajlueke  i tested with same results but worst, my CCD1 reached 86C


Here my screenies from Stock NO PBO Config (DOCP activated to xmp profile)

OCCT 100% usage


Cpu Mark REsulst



Idle usage spike;


TimeSPy result


I'm getting low benchmark aswell, maybe i got a bad chip. note the very low cpu usage on my 100% CPU stress test





In first place, I would suggest you doing what I did. Run everything in BIOS in the stock settings. Then download Thaiphoon Burner, find the right and correct values regarding your ram and then download Ryzen DRAM Calculator and add these values to this software for the frequency of your stock RAM maximum speed that supported out of the box.

Click on the option Calculate Safe in the DRAM Calculator. Then add these values about the RAM in the BIOS and use the recommended field values that DRAM Calculator suggests. After that you need to reboot and if the system will boot then try to run the software OCCT with the options:

Data set: Large
Mode: Normal
Load Type: Variable
Threads: Advanced

Then click on the setting icon next to the Advanced Thread Settings text and there choose:

Physical Cores: Check them all
Virtual Cores: Physical & Virtual
Core Cycle: Cycle Active Core Every 3 Seconds
Swap Active / Inactive Cores: Swap Active Cores Every 5 Seconds

Let it run for 1 hour. If it passes without any errors or reboots during the test, it means that you are most probably good to go. If you see errors then try to lower your RAM frequency by 200MHz and try again the same tests. Keep doing this until you have a pass without an error in OCCT.

After you success on that, then we can do the curve optimizer but for Per Core like I did and not for all cores. Let me know when you finish

Many thanks! Let me try...



Ok, I might be doing something wrong, but when I click on Calculate SAFE in Dram Calculator, I get an error message saying 'not supported'...

Any suggestion?




Are you sure you have added the right values from the Thaiphoon Burner into the DRAM Calculator? First, in the first field Processor use the option ZEN 2 AM4 / sTRX4. Then be sure you are adding the correct values for the Memory Type, DRAM PCB revision, Memory Rank and Motherboard. These values are all presented in the Thaiphoon Burner.

If you believe you have added the correct values and you are 100% sure about it, then just change the first option of the DRAM Calculator - Processor from the one you have to the ZEN 2 AM4 / sTRX4 and hit again the Calculate safe. Also keep in mind that in the field Frequency MT/s in DRAM Calculator, you add the MHz value the DRAM Calculator you want to suggest you the settings for.



Ok, not much success with my 4400 DDR4 and DRAM calculator so set it in bios at 3600 which gave me a CAS of 19/tRCD 19/tRP 19/tRAS 46/tRC 84/CR 1T.

Here a my results in OCCT (with recommended settings) and OpenHardwareMonitor showing CCD1 is optimized but CCD2 can probably be tuned up if my understanding is correct:



You can try the timings I have below.  ProcODT is at 48.  These are fairly loose, fairly safe timings.  You can set your kit to 3600 and 1800 on infinity fabric and then keep moving up from there. 


Adept I

Same issue here and it's nasty!

I have just done my new pc build-up:
5950x + Asus ROG X570 E-Gaming + Kraken Z73 360...

The first shock was seeing the temp at 50c in Bios... 
THen in windows idle at 74c - 78c

Worth mentioning that I just loaded optimized defaults in the Bios, had to select DDR 3600  Speed. And that's it, I don't want to overclock...

Now in windows, I have CAM software and it was blowing the fans at full speed! the pc was making so much noise...
Also, another observation, tried doom eternal and the temps were up to 80c...

I thought I am buying a super-efficient CPU,... This is very disappointing.
I will read through the thread to see what to try... I want lesser heat but I don't want to compromise on standard performance...


And I just tried the AI Suite 3 Performance mode and now Idle in windows 51c!!! with a 20% performance boost,... it works but something is seriously wrong with the bios / drivers / software...






According to Buildzoid, AMD AGESA is still changing and therefore Motherboard BIOSes are still changing and buggy. 
Hopes it will be fixed in ~ 2 months. 



Glad you got the temps down. Its crazy. This chip is the first CPU that I've ever had that doesn't work properly at default settings. One thing for sure is that it is a monster of a CPU.


I have the same problem. 5950x, asus crosshair viii hero wi fi. Idle 63C, Cinebench over 90C. Whenever I open something it spikes to 75c. The bios is update to 3003 version, but no luck. I’m using the TPU I now, it keeps the idle temps in the 50s, but it goes to 4000mhz max. Anyone knows if Asus will address this. Thanks!


Hi friend,

I have post some official answers from AMD regarding this matter because I was facing the same. I am also using the same mobo as you and I posted what I did. Check previous posts if you like and I hope you are getting some help from them. AMD also mentioned that this CPU is designed to work easily even in 95 degrees of Celcius. But however let's hope we are getting new agesa patches, bios and amd chipset drivers.

Journeyman III

I had similar issues with my 5950x and Aorus X570 Xtreme Motherboard.

Was idling in windows around 64C (few things open but CPU utilization was low).  During some games it would ramp up to 74ishC.
Cyberpunk pushed it more around 80C.

First turned off PBO which brought temps down a little but not that much (maybe about 5C).
Then went into bios and turned off core boost as well.  Now getting about 40C idle and ramps up to just over 50C in games.
That being said, only getting about 3.8GHz clock speed.

Seems to be issues with optimizing the boost performance.  That combined with these CPUs just running hotter than we are used to.  Guess we will have to wait for future BIOS updates.


Yeah, it’s bad to be frank. My pc started to freeze a few minutes ago when I had a couple of processes running.


Talk with Gamers Nexus:

Journeyman III

I also had some issues but ultimately it was case airflow that was the main issue. I didn't change my case but I have a glass front for my RGB case fans with fine filters on the sides. So I removed the side filter material and my CPU temps dropped by 30 deg celcius. Hope this info helps. Now my cpu runs at 50 deg celcius and only goes to 70 deg when playing games or video editing.

I use a MSI Tomahawk X570 wifi board with a RTX3070 and 64 gig of Corsair 3200 ram.

Obviously you have an ASUS so this may not be related to your issue. Just thought I would post if it might help in any way :D

Also running at Extreme power profile. So case airflow seems to affect a lot. As for the dust you wonder? Well I clean my pc from dust around every 6 months anyways as the filters clog up and have to be cleaned anyways.


I’ll try that, I have a lian Li 8auer. It has 2 large filters on 2 of the exhausts. 


It wasn’t the filter. No I reached 100c in Cinebench at one point. What is happening with this CPU?

Adept I

I am having the identical problem with the identical CPU and motherboard.  I got one good run after I installed it and then the chip started to run very hot 70+ at idle and close to 100 under loads.  It also appeared to throttle down since my benchmarks dropped significantly.  This was with a Corsair 360mm liquid cooler (brand new as well).  I even changed the cooler to air and there was no difference.  The only thing that has helped was to disable both the core boost and the overdrive clocking option.  It cooled the CPU down in to the 40's but destroyed my performance.  Obviously there is a problem but the question is where?  AMD or Asus?  I'm going to contact both companies but in the meantime, anyone else have further suggestions?