Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 9 5900x will not post with most recent bios, but 2600 works fine


  • AMD 5900x
  • MSI MEG Unify X570  Bios: 7C35vA82
  • 64 GB Trident Z 3600 DDR4 RAM Running at 2133mhz
  • Intel 660p M2 boot drive Window 10 Pro

I can't get to the Bios setup with 5900x. Works fine with the 2600. I keep getting a 9C Debug Code and no signal to my monitor when I try to boot with the 5900x. Tried multiple bios updates. The CPU visually looks fine. No damaged pins. Fits in the socket perfectly, just won't boot/post.


bios settings.jpg

8 Replies
Adept II

Hi elev8d

I'm assuming you're following the MBD Manual process to Clear CMOS or Reset BIOS?

Have you looked at the Manual to see what the 9C error code is for?  This might help you isolate the problem.


Yes, removed all the RAM, CPU, Hard Drives and only installed the new Bios with the Mobo and power supply.


I don't know if this helps, but yesterday I build my new PC. I have the Asus Rog Strix X-570 E Gaming and the Ryzen 5950x. In first place the system didn't boot to show the message please insert boot device etc. but it was freezing in the post screen.

So I had to update bios in a recent version that supports the Ryzen 5000. I used a Ryzen 2700x to do that and after that everything worked and the system booted with the Ryzen 5950x.

What concerns me is that I read people have high temperatures with Ryzen 5900x and 5950x. And I use 7 CoolerMaster fans and the CoolerMaster hyper 212 black edition with extra 2 even better CoolerMaster fans of 37A.

I am getting in idle mode 55 degrees celsius that it doesn't look normal. Will check again if the cooler installation didn't complete properly.

First thing is downgrade your BIOS from BETA to the  last Non-BETA BIOS which was the one ending in A7.  BETA Bios might still be very buggy.

Second check to see if the RAM you have installed is on your Motherboard's QVL list for the 5xxx  (Vemeer) Processors:

It is possible the RAM you have installed is compatible with your 2600 processor but not compatible with your 5900X processor.

IF the RAM is not compatible with your 5900X  it might prevent the PC from booting up.

What Motherboard Trouble LED are lit or Trouble Digital Codes are showing when you try to boot up with the 5900X?

Try installing a PC Speaker to hear what BEEPS occurs when you try to boot up with the 5900X.


My RAM is G.Skill Trident Z F4-3600C16Q-64GTZRC.  It looks like it only supports  a 1 and 2 dimm config. I tried booting with one dimm though and no luck there.  Does this mean I'm SOL with my 4 sticks of RAM and I need to buy a new set?

try to manually lock in some RAM settings, like  "2t command rate".  look that up


MSI support would be the ones that can help with this problem. I would suggest talking to them before regressing a bios. They may have an unreleased beta bios that can help they can give you.

You can report the issue to AMD here if you feel you need AMD's help:


Reread your original post.

The Trouble Code "9C" indicates a USB issue. Basically BIOS might be trying to boot from a USB device.

In BIOS make sure you have your Windows Drive as the First Boot Device. 

In my Motherboard I have to put my Windows Drive as the first Boot device for my PC to boot up. When I put my Burner as the first Boot device it tries to boot from the burner first and thus never boots up.

Before on my old motherboard BIOS I could put my Burner as the first Boot device and my Windows HDD as second Boot device but not on my new Asus BIOS.

Disconnect all USB external devices and see if it boots up. If you still get the 9C code see if you have any USB devices connected directly on your motherboard then see if it boots up.

From an old Tom's Hardware thread concerning 9C trouble code:

"9C is a USB error and A2 is an IDE error. Here's a couple of things to check: Your system could be searching for a USB boot device Go into your BIOS and ensure that the boot priority is set for your OS drive. Your system could be having issues with one of your connected USB devices.Jan 7, 2015"