cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

srvmood
Journeyman III

Ryzen 9 5900X Issues?

Ok here's the story I built a PC used ASUS X570 Tuff WIFI Plus,  Vengeance Pro 64 GB Memory, EVGA 3080 video card. It has ran flawless for couple of years with a Ryzen 7 5800X so I made the choice to upgrade to a Ryzen 9 5900X and it too ran flawlessly. The other day I went downstairs and the computer was sitting on the bios Del or F2 screen. I rebooted and got win stop error after error. I did everything I knew how to get it back but no luck. Went and bought new motherboard same make and model and it did the same thing. I removed the processor and put the Ryzen 7 5800X back in and it booted right up. Mind you with only one stick of memory. I put the Ryzen 9 5900X back in and tried to boot it and nothing. What happen to my processor.  

0 Likes
1 Solution

I couldn't tell you off hand, I would try the BIOS update just to see if it fixes it and if it doesn't, Then it could be a faulty CPU.

AMD Ryzen 9 5900X - MSI MPG B550 Gaming Plus - ASRock RX 6750XT -12GB. -- G.Skill Ripejaw V (32GB.) (DDR4-3200) - WD Black SN850X NVMe - Samsung 980 Pro NVMe - SanDisk SSD Plus - CORSAIR CX750M 750W - Cooler Master Hyper Halo 212 Cooler- Rosewill Prism S500 Gaming Case - Windows 10 Pro x64 - MSI Optix MAG342CQR - Samsung 27" - Apex 3 Gaming Keyboard - Rival 3 Gaming Mouse - Sound Blaster Z SE

View solution in original post

0 Likes
3 Replies
AMOCO14
Adept II

Make sure the BIOS are up to date and if not update them and then put the 5900X back in and it should be fine.

That's where I would start.

Here is a link to your BIOS,

https://www.asus.com/us/motherboards-components/motherboards/tuf-gaming/tuf-gaming-x570-plus-wi-fi/h...

AMD Ryzen 9 5900X - MSI MPG B550 Gaming Plus - ASRock RX 6750XT -12GB. -- G.Skill Ripejaw V (32GB.) (DDR4-3200) - WD Black SN850X NVMe - Samsung 980 Pro NVMe - SanDisk SSD Plus - CORSAIR CX750M 750W - Cooler Master Hyper Halo 212 Cooler- Rosewill Prism S500 Gaming Case - Windows 10 Pro x64 - MSI Optix MAG342CQR - Samsung 27" - Apex 3 Gaming Keyboard - Rival 3 Gaming Mouse - Sound Blaster Z SE
0 Likes

This pc ran for almost a year with the Ryzen 9 5900X with bios currently on the board with no issues and then this happened out of no where. Just trying to understand if there is something i did that may have damaged it. Never overclocked or ran warm.

0 Likes

I couldn't tell you off hand, I would try the BIOS update just to see if it fixes it and if it doesn't, Then it could be a faulty CPU.

AMD Ryzen 9 5900X - MSI MPG B550 Gaming Plus - ASRock RX 6750XT -12GB. -- G.Skill Ripejaw V (32GB.) (DDR4-3200) - WD Black SN850X NVMe - Samsung 980 Pro NVMe - SanDisk SSD Plus - CORSAIR CX750M 750W - Cooler Master Hyper Halo 212 Cooler- Rosewill Prism S500 Gaming Case - Windows 10 Pro x64 - MSI Optix MAG342CQR - Samsung 27" - Apex 3 Gaming Keyboard - Rival 3 Gaming Mouse - Sound Blaster Z SE
0 Likes