Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 9 3900x stuck at 3.8ghz and 1.1V

The CPU keeps running at 3.8Ghz without any boost, even I manually overclock it to 4.3Ghz in bios, it is still staying at 3.8Ghz after getting into windows. The frequency does not even get 0.1 high or low, just steadily keep on 3.8Ghz which is the lowest frequency for this cpu. The situation only happened when I flashed my bios from version 1.0 to 1.2. I can only use ryzen master to try to overclock it but after reboot all gone. I can overclock my RAM without any issue. just the CPU does not boost at all.

My mother board: MSI X570 Godlike

GPU: Zotac RTX 2080ti AMP Extreme Core

RAM: 2*8G Adata D80 3600Mhz

SSD: Samsung 970 evo plus

Power: Seasonic 850 W focus plus

Cooler: Corsair H100i Platinum

Case: Corsair 680X

11 Replies
Big Boss

coreymlh, this is probably not a problem.  What version of W10 are you running?  The new 1903 has changed the Balanced Power Plan to be more aggressive.  Please post a screenshot of Ryzen Master (RM) - simply drag-n-drop the image into your reply.  Please do a Clear CMOS using instructions in your User Manual and stop running any OC applications except for RM.  Thanks and enjoy, John.

Adept I

I had the same problem with 3900X. All the driver, windows, and bios are updated. I even tried beta bios, still not working. The CPU clock rate will be locked at around 3.8Ghz when I log in to windows. I try to overclock in bios, but not working.

The only way to fix the problem is to use AMD Ryzen Master, and hit the reset. However, even show all core will go up to 4600mhz, but the maximum of single-core and all core can reach is 4250 with 1.48v! Also, the CPU temperature in idle will go up to 50-60 celsius, with load, will go 80+. That is with Corsair H105 AIO cooler!!! My previous intel i7 5960x cpu with the same cooler only reach 60 in load and 32 idle. 

motherboard: MSI X570 Creation


RAM: 4*16G Corsair 3200Mhz

SSD: Adata S11 PRO 1TB m.2 nvme

Power: EVGA SuperNOVA 1200 P2

Cooler: Corsair H105

Case: Corsair X570

Adept I

Found a solution,

1. complete uninstall/delete MSI bloatware, called Creator Center or Dragon Center.

2. press reset in AMD Ryzen Master.

3. restart windows.

After fixing, right now my CPU at least back to 4.2Ghz when entering Windows.


healbunny‌ did you have to do something beyond just uninstalling the MSI software for it to stop affecting your system?  I uninstalled, but am seeing the issue persist.  Did you have to manually remove files, modify the registry, etc...?  I fear it has left something behind that is causing the issue to persist for me.

Adept I

I've tried all suggestions here, and cannot get my CPU out of 3.8 GHz/1.1V either.  I have cleared CMOS, I have tried every available Windows power plan, and I have removed all the MSI software from my machine.  The only way I can get the CPU working correctly again is to run Ryzen Master.  After rebooting, my system always locks back at the lower speed.  On the bright side, it sure is running cool now!

Adept III

Is there called Core performance boost, or something similar such as a precision boost 2 setting in your bios?

When I was trying to diagnose my stability issue on my 3800x, I had to disable the Core Performance Boost option in my ASRock boards bios, which locked all the cores to base clock and 1.1ish volts.  After I figured out the issue I was able to re enable the option to get proper boosting behavior back. 

This sounds like what is happening on your system.


Thank you for the reply!  It turns out it was the MSI Dragon Center software.  After removing that ENTIRELY from the machine (uninstall alone wasn't quite enough), I'm running normally again!


yes, you n

eed remove the entire msi software


What did you have to do in order to completly remove it?


system restore or update the new MSI software from MSI support page. The new version should fix the problems.

If not, just uninstall everything via Windows Uninstall or Change a Program

Adept I

I think I found a way to reproduce the CPU Stuck at 3800Mhz and how to unstuck it.

To reproduce the bug follow these steps:

- Make sure your BIOS is at Stock (for the sake if being at the same starting point)

- POST and go to BIOS again.

- Change the CPU from Auto to Manual, you'll see your board by default will display 3800mhz at 1.1V

- Save and POST or go to windows.

- Go back to your BIOS and set it from Manual to Auto

- Go to windows. Your processor should be stuck at 3800mhz

I think is a bug on how the UI communicates to the hardware and when you set it from Manual to Auto the option doesn't stick and even if you see "Auto" in your BIOS the system is still using a fixed 3800Mhz at 1.1V

To "unstuck" it you need to load an actual preset or the board's defaults in order to inject the right values in the hardware.