Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 7700x no display

I just built a Ryzen build, and at first I was getting no signal to the monitor at start up. What was weird was it would awake the monitor from its sleep mode but not send any signal. This morning I reseated the cpu and it came up and started I got everything started up, then pc went to sleep and now all I’m receiving is a black screen when pressing the power button.
I’ve tested the graphics card it works, even tried another graphics card.

  • ryzen 7 7700x
  • gigabyte b650m
  • 32gbs Gskill flare ddr5 4800mhz
  • Mail rtx 3060
13 Replies

Generally when you install a GPU Card with Integrated Graphics the GPU Card becomes the Main Display Adapter in BIOS automatically unless you manually set the IGPU as the Main Display Adapter.

Your IGPU might be disabled. Check Device Manager to make sure there are no errors both are enabled.

Does the same thing happen with your Nvidia GPU Card or just the Integrated Graphics?

Are you using both the GPU card and your Motherboard's Video Output to run 2 or more Displays?

Go to Windows Settings -Display and see if all your Monitors are showing correctly with the proper Resolution selected.

Here is the latest AMD APU Processor Integrated Graphics driver from AMD:

Try using DDU with the internet disconnected and deleting C:\AMD if it exists BEFORE installing the AMD driver again.

See if the IGPU works normally again.

NOTE: There might be some conflict between the AMD Driver and Nvidia Graphics driver. In that case just install the AMD Driver with whatever apps installs with it without installing the entire AMD Driver package.


I can’t even get the pc to post. I’m getting nothing but a black screen when pressing power, I’ve tried both on board and off board


So the computer is not booting up now?

When you apply power is your computer case HDD LED flashing or staying on solid for a few minutes?

Is the CPU Cooler fan running all the time with all the other case fans?

Please post your full Gigabyte B650M Model since there are several.

Okay, since everything happened after you re-seated the CPU I would check the CPU for any damaged pins on it. Also make sure the CPU Cooler fan is running normally when you first power up.

If the CPU isn't damaged. Check to see what Trouble LED lights are lit or Digital Codes are showing when it wouldn't boot up.

If you don't have any of those two type of Troubleshooting features then you would need to install a PC SPEAKER to hear the BEEP Sequences to determine what general hardware is causing the PC not to boot up.

I would disconnect everything from your motherboard except PSU, CPU, and one stick of RAM Memory.

Don't install your Nvidia GPU card.

Do all of the above if your PC is not going past POST and not booting into Windows.

Post back with exactly what is happening to your PC when you apply power? Post any Trouble LED lights that are on or Digital Codes or Beeps you hear.

I’m getting no screen what so ever, my bios screen doesn’t pop up at all. When I press the power button and the pc starts it gives nothing but a black display, I’ve tried on board graphics, re seating and checking the pins on the cpu, move around the ram sticks and ran just one. Even tried other PsUs

the mother board model is B650M ds3h


The fans start up as normal the HDD light flashes just no display


Do you have the latest BIOS version installed F4c which has the following fixes:

  1. Checksum : 8CAE
  2. Update AMD AGESA Patch A to D
  3. Fix NVIDIA Geforce RTX 4090 PCIe down speed issue (SMU 84.79)
  4. Add memory voltage options over 1.435V (After BIOS updated, please install “One-click EC FW Update” from Downloads-> Utility section)
  5. Enhance curve optimizer range
  6. Add iGPU overclocking option
  7. Improve memory & PCIe device compatibility
  8. Add ECC DIMM support

You can use your Mobo Q-FLASH Button to update the BIOS by just applying power only:

Screenshot 2022-11-22 114441.png

Here is your Motherboard's QVL List for RAM. Check to see if your RAM is listed or not:

Okay, I downloaded your Mobo Manual and I don't see it has any Trouble LEDs or Digital Codes. Therefore you will need to install a PC SPEAKER, if one isn't installed already, to hear the BEEP Sequence to determine which Hardware is not passing the POST Test when you power up your PC:

Screenshot 2022-11-22 114441.png


Since I know a case where this happened a long time a go:

Are you sure you connected your monitor to RTX 3060? (or by accident to motherboards video output?)

You could try unplugging the GPU from machine and connecting cable to motherboards video output as 7700X has iGPU. Maybe you need to update BIOS to get dedicated GPU working or maybe your cable is connected to one output, (GPU or iGPU), but computer is sending signal to the other one.

Once there was a case when power switch was faulty and caused issues.

If those didn't help, clear CMOS by unplugging machine from wall socket, wait a while, short CLR_CMOS pins with a flathead screw driver or similar


Also notice that first boot can take "forever" and some motherboards for Ryzen 7000 need "memory training" time and time again, likely until some BIOS upgrade or improved memory support.

If previous things didn't work, simply unplug everything (hdd, ssd, m'2, USB-devices except keyboard, GPU, RGB everything... Just connect monitor and keyboard and one stick of memory and see what happends. Remember the long first boot time. You do have CPU power cables connected to top left corner of motherboard and not just motherboards 24-pin connector on the right hand side?

Journeyman III

hello, I registerd so I can reply to this thread.

  • ryzen 7 7700x
  • gigabyte b650m
  • 32gbs Gskill flare ddr5 6000mhz
  • rtx 3070, gtx 1060, same issue.

I have almost identical hardware as you and had the exact same issue earlier today, what worked for me after trying many different things for hours -

1. disconnected my harddrives

2. it now sometimes boot into bios screen

3. when it does, revert ALL bios settings to stock, I changed quiet a few things there trying to battle motherboard coil whine issue, but thats a separate topic

4. this step might be optional, but I updated my bios from F2 to F4c (note: was such a pain to flash bios, because I restarted to black screen MANY times, preceed with caution)

5. changed boot to legacy in bios, it was UEFI before and it was working, but I too had the sudden black screen issue so I was trying everything I can think of, I was getting black screen with my 3070, my 1060, and motherboard onboard graphics.

now my issue was solved after doing the above, hopefully it can help you.

Journeyman III


I have almost same issue.

  • Asus X670-P WIFI
  • Ryzen 7700X
  • Corsair 64GB KIT DDR5 5200MHz CL40 Vengeance Grey for AMD
  • Corsair RM750x (2021)

My PC works for 2 month with some playback issues (green artifacts etc due to HW acceleration), a few time BSOD but almost stable.

After 2 month PC stop boot. No POST sequence, no video output, no beep etc. I send back to reclamation motherboard. Wait for month, but MB is ok. PSU is ok, because I tried another. Now I send to reclamation CPU, expect that issue is in CPU, because no other component can fail (I have 2 RAM modules, both tried and no one work). It looks that CPU failed / died after a months. No overclock, default settings - I use it for work, not for gaming, only with integrated GPU.


I tried clear CMOS, change RAM, disconnect all unneeded components (hdd, usb, mouse, etc).

CPU FAN start spinning, case fan work, leds light up. Replace PSU have same result - not boot. Motherboard should be fine, when service center test it with their components and return back with no issue.


I know, that the first boot took longer (minutes) for init RAM speed and testing, but it's not my case. It didn't post for a minutes (with a single module it should take 30s - 2 min), but I wait for 15 minutes with every single change (switch ram modules, PSU).


Clear CMOS and flash your BIOS to latest even if you already have done that. Let memory run at Jedec speed instead of XMP or DOCP at this stage and make sure you have connected them to correct memory slots.

Try another video output or discrete GPU, try another monitor cable and connect to TV instead of your monitor.

Which CPU cooler did you use and how were the temps?

Why did you send just motherboard to service center instead of motherboard with CPU and memory sticks, so they could have tested them as a unit?


Clear CMOS didn't help, as I mentioned ;). 
I had latest bios, but it works before (2 month of working PC), so it's not related to BIOS, it died one day and stop POSTing and booting. It was working PC for 2 months and later die. 

Sure I tired HDMI / DP cables, but no result, as I mentioned no POST sequence and no beep check from the motherboard so, of course, no video output too. I have 2 working monitors (using now with Intel NUC as backup solution for work).

CPU cooler: ARCTIC Freezer 34 eSports DUO White

Temps was around 35-40°C when idle. In load - build android apps - temp was around 60, so nothing critical for CPU...

> Why did you send just motherboard to service center instead of motherboard with CPU and memory sticks, so they could have tested them as a unit?

Because it was ordered from different stores...


So, my CPU was really dead, I got back money and buy a new one (of course not 7700x series because I don't trust it anymore).