Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 7000-series boot time

Hi everybody

I am looking into building a 7900X system & donating my 5900X to my son. I have watched a lot of reviews and i'm aware of the "memory training" that Zen4 performs when you :

  • boot up your new build for the first time
  • after enabling the EXPO profile or changing ram
  • after a power loss long enough to drain the caps.

However, i've found a reddit thread where a lot of users are reporting permanent slow boot speeds on a daily base with the memory already 'trained' so to speak.

To clarify: after a clean system shutdown, without loss of power, when you press the power button, you're still looking at a black screen for 30 seconds, before the BIOS logo appears.

After that, another 15-20 seconds to get to windows. The only work-around at this time is to leave the DDR5 running at the standard speed (not enabling XMP or EXPO) wich is silly.

Reddit thread can be found here Reddit 

I'm amazed at how little I am able to find on forums or tech channels about this issue. Are any of you experiencing this or able to get feedback from AMD ?

If this doesn't get fixed any time soon, i'm just going to stick with my 5900X or go Intel (as much as I hate to do that). It takes me 7 seconds to get to windows after pressing the power button on my current system and I can't believe people are okay with this nonsense after paying their hard earned cash. If we are supposed to be beta testers I would like to get paid for it.

Any fix to be expected soon or are we going to have to wait a few months to get things fixed as with AM4 ?

54 Replies

I saw some video about this and person in it told he got rid of it by changing some setting in BIOS. For a reason or another his motherboard kept training time and time again even though it was fully stable. By changing that setting he got rid of it. Sorry but can't remember the setting nor which channel it was - likely in Youtube though. I have faint memory, that it was something quite... understandable like "memory training Enable/Disable" or "memory training passes" and set to zero or something like that.

I think if you just google or search youtube for "ryzen 7000 boot faster" you'll find a solution if not many.

EDIT: Thinking about getting a 7000-series too, so I've been studying

I think I saw a similar video with somebody using the BIOS setting that you refer to, but it didn't really help. I guess we will have to wait until the new AGESA updates roll out, until then..i'm not buying the 7900X

If I stumble upon something i'll be sure to post it here 

is this the video

Community Manager

There is an option in the (ASUS) BIOS called Memory Context Restore. When enabled, this will skip the memory training where possible, thereby reducing the memory training time. This option may have a different name depending on the board you are using, but you can try enabling it to reduce the time spent training the memory. 

Worth mentioning that as the platform and bios mature, this process may speed up over time as a similar thing happened to AM4 initially. 

Adept II

Thank you for your reply Matt.

"Skip the memory training where possible" : I'm sorry, but in my humble opinion the training should only happen once after building your system (or swapping ram), after that it should be smooth sailing as the system remembers your memory timings. Just like enabling XMP works like a charm on my 5900X (and even on the latest 13th gen Intel systems). Why EXPO needs to train your memory on a daily basis after everything is configured as it should is beyond me, i'm sorry.

I understand that this platform needs to mature, but as mentioned previously I don't want to be a 'beta tester' without getting paid for it If i'm about to pay premium dollar (or euro in my case) on a new cpu, motherboard ànd ram, I expect it to boot at least as fast as my last gen AMD system.

Sorry if my response seems harsh, but i'm a bit dissapointed

I understand, I appreciate your feedback.


I contacted Gskill and Asus about slow boot time when enabling expo.   Gskill suggested ram swap and if that doesnt work look to the motherboard or processor so no help there.  Asus told me that by enabling expo I am overclocking? with no help there i talked to microcenter and was told that there have been issues with Asus boards so I am curious if this issue is on other board manufacturers as well.  Some one knows the answer.  Being a long time user of AMD this is extremely frustrating.  My build is a new build with the 7950x and all is stable with no overclocking latest bios and chipset and when enabling expo I get slow boots everytime.  I am now forced to return MB, Processor and ram back to microcenter as I am still under the 15 day return policy. Why/.  Because I cant be sure that it is not a memory controller issue, a bios issue or a ddr5 ram issue and I refuse to change a bios setting that should bt now have been corrected if that were the problem.  I would be interested in your opinion.  This is a stain on a good company and now i will look to intel.


I also get the long post and boot delays with similar hardware.

We are looking to gather people with the same issue in one single group so please consider joining, thanks!



I joined. I'm going to mail AMD support and gather all forum threads about this issue. Maybe they'll find it important enough to provide me with an answer after all these months

Journeyman III

The memory training time can be reduced by enabling the Memory Context Restore option in the BIOS. This option is available on some ASUS motherboards. When enabled, this will skip the memory training where possible, thereby reducing the memory training time.

Adept I

I saw comments on reddit mentioning Memory context restore presence on ASUS, MSI and Gigabyte boards. I had to find it myself in my AsRock BIOS. 

Allegedly, Memory context restore can take the POST down from ~30s to 15-17s, but may be unstable.

On my AsRock board, where Memory context restore is enabled by default, POST is 35secs with XMP, 12secs with default.  Not to mention the sleep function not being stable to the point of AsRock silently disabling it after loading XMP/EXPO and taking ages on default DDR5 speed.

Even if completely stable, would you accept 15 seconds for POST?? My (ddr4 intel not-so-) old computer goes to win10 desktop in 7 secs from pressing the power button... Really wanted to go back to AMD this time around, but I completely feel the sentiment of @Smartboomer, I am a betatester after paying 340EUR for a board, without possibility to post and follow a ticket. Everybody will just point me to various BIOS settings I tried ages ago, AsRock support will tell me to "try another RAM sticks" where literally every RAM has this issue and Youtubers care only about melting connectors on halo products these days. Should I return this mess while I can?

Matt? do you have an option to check with AGESA team? Including the sleep issue, because if can just wake my computer in an instant (not after what feels as another round of RAM training), I could imagine accepting POST under 20seconds.  It would really be more consumer friendly, if AMD was transparent about this.

I wouldn't hold my breath regarding a response from AMD..I just hope they are busy coming up with a new AGESA so the motherboard manufacturers can release a new BIOS

I send an email to the more known YouTube techreviewers like Jayztwocents, Linus, Harware unboxed and so on..but haven't gotten any response whatsoever. I thought, maybe if they made an article about it, it might speed things up, but no luck so far..

I bought the 7900X with an MSI X670E Carbon wifi motherboard but did not put it together yet. I am using my 5900X that also takes about 7secs to boot up. If AMD doesn't come up with a fix any time soon (this month), i'm returning my stuff and buying the new 13th gen Intel cpu. 

I have been very loyal and been buying AMD for as long as I can remember, but they keep making the same mistakes.

Just as a sidenote, i'm following this thread on the MSI forum, you'll get more updates there I reckon 

And this one : 


Haha, I tried the same, GN, HUB, Buildzoid... I guess their mailboxes are full of fan mail..

I'm definitely returning my AsRock B650E ITX, as the 1.12 BIOS has some bug that prevents installation of any other BIOS. The thing just goes blank screen at 0% of loading the new image. Thought its happening without video, kept the PC on for an hour, scared that the board is bricked, then booted up with the same BIOS. So no chance of any improvement ever... well maybe there is flashing app somewhere but can't be bothered with that... for 340EUR there should be flashback.. 

I hate the E-cores and Win11, so 13gen for me is a waste because I'd turn those off first thing...  Maybe OC and 12700 with 4 e-cores killed off would be the way for me...


What's the problem with E-cores and/or Win11 ?


I have the "I don't trust that" attitude, the arguments are a bit individual to me:

ring bus performance, instruction set compromises/corresponding hacks that negatively impact amd performance, too online for my liking. I like my OSes be part of computer, not bound to an identity/email. Next time they'll want my name. And also the microsoft rule... every other is good, every other sucks and win10 does not suck.


Don't the E-cores work fine with Win10 ? 


I read they don't, your primary workload may end up on an e-core. MS did not update the scheduler on win 10. In part to force Win11 on people?


In my opinion, Win11 user interface was a step down. Also I believe it is missing some features. Have only used it on virtual machine. It is not as bad as Win8, but it would appear that Microsoft is stuck in cycle where every other OS release is bad and people skip it if they can.

To my understanding, not everything works well with E-Cores. Not sure though.

Adept III

Here when I setted the ram speed to manual 4800mhz the boot takes 30 secs.

When I leave this ram speed in AUTO (3600mhz for 4 sticks), the boot takes only ~7 secs to show the motherboard logo.

Asrock x670e steel legend - 1.11 bios.

7600x - 4x 16gb corsair 4800mhz (auto setted to 3600mhz).

Adept I

Preliminary test with ROG Strix B650E-I, POST takes 9seconds regardless of XMP on/off, sleep is available at all times (however wakeup delay is still ~10sec) and the fan curves are noticeably more pleasant.


9 secs to get from power on to desktop ? 
MSI have released a new BIOS update today, based on the AGESA 1004 update. Is that what you are running too ?


nope, old 0809 FW, lot of testing pending. With XMP, aida 64 read perf seems to not improve, while the latency went from 84 to 72ns. Asrock could do 68. The read speed looks lame against both intel and am5.

EDIT: that BIOS is not so old, its from mid Oct and includes AGESA Latency after rounds of playing and CMOS clears landed at 67ns. On -20 curve optimizer, the all core frequencies are down by 50-100Mhz opposed to AsRock, which was worth +50 pts in CB20. Apparently Asus held back a bit with this board to deliver more stable experience. 


So, after reading reddit posts and listening to Buildzoid, I had a theory that maybe my RAM sticks might be the reason. So I bought a kit of Renegades, which are said to be Hynix M-Dies, and they behave identically, maybe even slower on my AsRock w 1.12 BIOS (37s each post). Because of inability to flash other bios, I returned the AsRock.

On the Asus B650E-I, Renegades have identical training and POST times, also.

To answer original question, no, 9seconds is POST only, not boot. When I started playing, complete boot from cold was 13s (with no training), now it's like 21seconds, but the POST is still the same, windows got slower in the meantime... didn't do a clean install after changing from AsRock to Asus. 

Thanks to Asus'es debug leds, I can clearly see that the RAM training is skipped and memory context restore works consistently.

Also, I had to deal with turning on and off the fTPM (the bitlocker warning when drive goes to different board), I recommend to not use it, I had apps crashing until I turned it off again.

Adept I

Good morning.
I am very interested in the 7950X CPU because of its performance, and I noticed in this discussion that the problem of slow boot to steady state (not the first boot to training) is prevalent somewhat on all motherboards.
I am asking if there is a motherboard that is better suited for booting, or does the problem affect all motherboards and one has to hope only for BIOS update.
Thank you


I think it depends on memory speed. For some reason some people with fast RAM seem to encounter that issue. I have 5200 and no issues with boot times with Asus B650E Strix Gaming. I have not flashed BIOS yet as some claim the earlier one works better, so as mine works, have not upgraded it.

How long does it take to BOOT?
I am undecided between Gigabyte X670 AORUS ELITE motherboard and Asus ROG STRIX X670E-F GAMING opèpure is a cipset B650 better?
Thank you and Merry Christmas


Not Gigabyte, but my Asrock x670 Steel Legend takes:

up to ~8 seconds with 4 sticks at 3600mhz;

up to ~30 seconds with 4 sticks OC at 4800mhz;

up to ~5 seconds with 2 sticks at 4800mhz/5200mhz.

Same time with Corsair and Kingston sticks. Same time with 7600x or 7700x.

So can this be somehow solved by choosing one 2 stik of RAM @5200MHz, or having already purchased 2 stiks @6000MHz can one set a lower working frequency?


I think the problem with 4 sticks at 4800mhz in my test are because every boot at this frequency the BIOS / Motherboard make an intensive test again if this frequency will be safe or will work.

Not tested something above 5200mhz, but with 2 sticks at anything above 5200mhz I think will be the same times. (I think....)

Today I`m using 2 sticks at 4800mhz.

I chose to get 4800mhz sticks which would be the most standard frequency possible. No overclocking, even officially with XMP / EXPO.

Journeyman III

My Ryzen 1700 on a b450 mobo boots in 10-12 seconds without fast boot, desktop is fully loaded and ready to use in 15 seconds from pressing the power button. The boot feels very slow as it has to spin up several HDDs, but the boot device is a NVMe drive on the mobo.

A 6 year old laptop boots in about 5 seconds. But that's mostly due to NVME speeds.

Cold boot time are going to vary based on the specific motherboard, BIOS version, and hardware configuration and generally improve with newer BIOS versions.

Specifically, for my Crosshair X670E Hero on BIOS 0705 with 32MB DDR5-6000 Windows reported "Last BIOS time" from a cold boot is:

Fast Boot disabled - 41.2 seconds

Fast Boot enabled - 38.7 seconds

Fast Boot disabled, Memory Context Restore enabled - 25.9 seconds

Fast Boot enabled, Memory Context Restore enabled - 20.8 seconds

For comparison a Crosshair VII Dark Hero with 64MB DDR4-3600 with Fast Boot enabled reports 14.5 seconds.

It is interesting that Memory Context Restore defaults to disabled on the current BIOS when it has the biggest impact on boot time.

Adept II

Hi all,

Looking to get into the ASRock mobo, but 40 secs of boot time is unacceptable.

I can see they dont have any updates from mid October with -AMD AGESA A. (Now its like Feb 2023...)

Do you have any updates on your end that fixes the slow boot issues?


Machines & More just released a video talking about the Asus X670E ITX board.  One of his biggest problems with it is the slow boot speeds: 

Adept I

recently I have built system with X670E Taichi , 64gb G.Skill RAM CL30 , ( 2x 32gb sticks ) , Ryzen 7 7700 . and it's not been fixed yet, whether you enable or disable Context restore it makes no difference to post times that take about 45 seconds and I am on the latest (NON-BETA) BIOS  1.11 .  , I have to say AMD is ridiculous, my next system is gonna be Intel for sure. worst of all some clearly sponsored (paid) tech sites claimed that it was fixed a few months back.

Adept I

My system is 7900X CPU, MB MSI MPG B650I EDGE WIFI with the lates BIOS, RAM G.SKILL trident z5 64GB 6400 cl32 ddr5 2x32GB, GPU 7900 XTX, SSD Samsung 990 PRO 2TB. All drivers are up to date. When Memory Context Restore disabled, it takes around 1 min 30 sec from power button pressed to Windows 10 logon screen. When Memory Context Restore enabled, it takes about 40 sec.


I wonder how many sales AMD and the motherboard manufacturers are losing because of this (or how many returns this is generating).

Journeyman III

MSI B650M Mortar bios version; last. support x3d chips agesa

7600X and kingston 6000Mhz kit. Post time 40 second and boot time 40 second. 

Give me the beta tester payment AMD!!
this is the last time i bought AMD CPU or GPU.


It is definitely a memory issue to cause the slow boot up. 

If I disable expo on my g. Skill 6000mhz Ram, the system boots up instantly without any delay. I will try to set the memory settings manually. 

Journeyman III

Posting incase anyone is having the slow boot-up issue with MSI B650 Tomahawk WIFI (and prob others) and looking for a fix. Load it back to 7D75v11z with AGESA from 11-14-2022 and Enabled Memory Context Restore in the BIOS. boot time is now 22 sec.

note: Won't work for 7000x3D chips -AGESA will but Memory Context Restore broken(in both .04 and .05 AFAIK)

Ctrl+Shift+Esc, go to Startup apps(speedometer icon) and the Last BIOS time will be in upper right section to check boot-up time


is the hibernate working fine with that bios? the last time I'm using it doesn't have sleep option and hibernation doesn't work.