Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 7 2700x Wont boot with ram above 2133

So i have 32gb of corsair vengance and when i have My 2700x in my build all 4 sticks function at 2133 but windows says 16gb avail and 16gb stored. Also when i enable xmp my computer just resets bios and speeds stay at 2133. If i use only 1 stick of ram Xmp or any other speed works perfect. Now the weird part is with all 4 sticks installed and i swap out my 2700x for my old 1700 The computer runs twice as fast and xmp @ 3200mhz works fine. Any help would be apreciated i contacted gigbyte thinking it was a mobo issue but they said it is more or less a cpu issue.

Ryzen 7 2700x
Gigabyte Aorus X470
EVGA 1070ti 
32GB Corsair Vengance RGB 4x8

29 Replies
Big Boss

siska, are you using the exact same memory with 1700 and 2700X?  Sounds like a bad stick of memory or stale W10.  Please try one stick at a time and see if you can isolate it.  Please do a Clear CMOS before.  Did you install a fresh copy of W10 on each processor swap.  If not that may be the problem.  You should always install a fresh copy of W10 whenever the CPU is swapped to another model.  Thanks and enjoy, John.


Misterj, The exact same computer, ram, HDD, etc. Just swapping out the 2700x for the old 1700 and everything works as it should. 

Things I have tried,   

Fresh installed windows 10

1 stick at a time in every slot works fine with xmp add another into the equation and NO xmp for me on the 2700x

Installed my old 1700 back in and have absolutely no issues. Same Board, ram, etc Literally the same physical computer

All individual sticks of memory work in any slot

Other misc voltage stuff in bios trying to get it to work. Dram calculator etc.

Literally change nothing and put my old cpu in and it works fine. Its sad my 1700 is triple the working speed than my 2700x at this moment


sounds like your new CPU is more sensitive to the RAM timing than the old one

I use cheap DDR4-2400 and overclocked it, G,Skill NT series, no heat spreaders even, not needed either


siska, please post a screenshot of Ryzen Master (RM) - simply drag-n-drop image into your reply.  Please do this for both processors.  EACH and ever time you change your CPU, you should install a fresh copy of W10.  Of course, you may have a defective processor.  You will need to contact AMD Online Support to deal with that.  In this User forum, we are trying to determine any other conditions that may be causing the issue.  Thanks and enjoy, John.


misterj a écrit:

ever time you change your CPU, you should install a fresh copy of W10

I've been swapping between gen one and gen two Ryzen without issue As long as chipset drivers and bios are up to date.

It's obvious that if all 4 sticks function correctly with the 1700 the Ram and the motherboard can be ruled out, Siska You've got a lemon 2700x return it and don't waste your time.




Thanks, siska.  Unfortunately you cut off the bottom so I cannot see the memory voltages.  Usually when a lot of memory is unusable, it means that it did not pass the Memory Tuning that takes place during POST.  This needs to be solved before proceeding.  Please try swapping the two sticks and see what happens.  Be sure you have performed a Clear CMOS and post a screenshot of RM only with all the information showing.  Thanks and enjoy, John.




Looks good, siska.  Thanks and enjoy, John.


This website offers several tips on how to get full use of your RAM Memory: SOLVED: Windows 10 Won't Use Full RAM - 

NOTE: Don't download their recommended software - Reimage Plus - it is basically a scam. but the information is valid.

This Ten Forums thread has a similar problem. Could be RAM not being compatible or bad RAM Module or Motherboard Memory slot: Windows 10 Help Forums 

One comment concerning the issue from above link:

Make sure you have the latest BIOS version installed for your motherboard.


Works fine and doesnt do any of this with my ryzen 7 1700 thats not the issues all that was the first things i tried.


So you are saying the 2700X is not showing 50% Reserved RAM Memory in Windows?  Which was what I was referring too since you posted images in your previous comment showing 50% RAM Reserved.

If I misread your comment then its best if you follow the other User's advice.

Good Luck


The ryzen 7 1700x works fine, no reserved ram and allows to me to overclock. The 2700x reserves 50% of ram and when i overclock above 2133 it bootloops and reverts or no posts


hardware reserved memory suggests a serious fault with the RAM


Doesnt do it with a different CPU in same computer, suggest CPU fault. 


Or incompatible RAM for the 2700X.

It is possible it could be a defective CPU. Open a AMD Warranty Request and see what they say: AMD Warranty Request Form | AMD 


You should check your RAM MEMORY for the 2nd Generation Ryzen on your motherboard's QVL List and see if it is listed.

RAM MEMORY that may be compatible with the RYZEN 1xxx processors may not be compatible with the Ryzen 2xxx Processors. X470 AORUS ULTRA GAMING (rev. 1.0) | Motherboard - GIGABYTE U.S.A. 

The Ryzen 7 1700 is a Summit Ridge CPU while the Ryzen 7 2700X is a Pinnacle Ridge CPU. Notice each has its own QVL list for RAM MEMORY.

It is possible RAM MEMORY may be compatible for both and both QVL Iist. but to be sure you need to check your RAM MEMORY against the Pinnacle Ridge QVL list.

Note: Decided to attach both QVL List for both types of processors. Just click on the attach file to download it and see for yourself if your RAM is listed for Pinnacle and Summit Ridge processors.


I suggest CPUID to determine the CPU code name, my R5 2400G is Raven Ridge


True but I normally use this website dedicated to every known Processors and its specs. That is where I got the code names for both of the OP processors: .

If the OP doesn't post CPUID then I need to go to the above link to determine the Processor's Specs.


I have pondered a table for AM4 with all the RAM that has accumulated

there are only 3 main type of processors at present, maybe one or two more down the road


i will get back to everyone i just got home from vacation. Amd keeps asking me to change my radeon settings and talking about a gpu when im talking about a cpu and dont even have a radeon card. Is amd support in a third world country? 




my ram is not on either list CMR16GX4M2D3200C16


That could indicate two things if not listed on the QVL List:

1) The RAM was tested and found to be incompatible thus not listed.

2) The RAM was NOT tested thus not listed.


I have found a way to make my system stable using all 4 DIMMs. Let me know if you have found any solution or not. You can also send me a PM if you're interested. 

Journeyman III

@misterj I do not use ryzen master


siska, please DL a copy here and post a screenshot.  Thanks and enjoy, John.

Adept I

I have a similar issue. I have 32GB of 3200MHz Corsair Vengeance RGB Pro (Hynix CJR memory) with a Ryzen 2700X and Asus Strix X470-F gaming mobo and since day one. I've been having issues using the XMP profile when using more than 2 dimms and to be able to boot I have to set the timings manually. Everything was working well until recently that the issues got worst. Although the system it's "stable" and I don't get any RAM errors when testing, my PC will eventually crash. Sometimes even after just simply rebooting the PC, it won't pass the POST and eventually, the CPU error light comes up and stays there. When this happens I have to completely drain the system power or remove to dimms to be able to boot and then reconfigure everything again. This also happens sometimes just at default speeds and/or bios settings. I've tested the RAM in a different system and there are no issues at all. All the components are relatively new (about 3 months old). I hope he can find a solution to this problem.

My full system specs are:

CPU: Ryzen 7 2700X

Cooler: RYUO 240 AIO

MB: Asus ROG Strix X470-F Gaming

RAM: 32GB 3200MHz Corsair Vengeance RGB Pro (4x8GB)

GPU: Radeon VII

PSU: Corsair HX750

Storage: 512GB SATA m.2, 128GB SSD, 1TB HDD


how is your box with xmp disabled?