Showing results for 
Search instead for 
Did you mean: 



ryzen 7 2700x restarts or black screen

Hi! Y have Ryzen 7 2700x with automatic OC from the AMD boost, reaching 1.49V. sometimes, my computer restarts, it does not matter if I'm playing or the computer is on the desk doing nothing, sometimes it restarts or it stays on a black screen and I have to turn off the power and turn it on again.

My setup(bought a week ago):

- Ryzen 7 2700x

- Asus rog strix X470-F

- EVGA SuperNOVA G3 750

- G. Skill FlareX DDR4 3200 16GB (8GBx2)

- SSD Samsung 500GB

- HDD 1.5TB

- Liquid refrigeration Alphacool CPU Eisbaer 360

I'm running the RAM at 3200Mhz. U think the problem is the Voltage from the proccesor, 3200Mhz RAM or? The PSU is new two days ago and motherboard a week ago. What can I do? When I'm on Prime95 with stress test it works, but when I play or I'm afk the computer restarts or black screen, on Windows Event View It says always Kernel-Power id 41 Category 64, on details all is 0.

Need some help, thx.

34 Replies
Big Boss

jaumes, please look in the "C:\Windows\Minidump" folder and if there are any files, please compress the folder and attach it here.  How does your system work with NO OCing?  I would suggest you go into your UEFI and Load UEFI Defaults, or do a Clear CMOS according to your MB manual.  What OS are you running?  What slots are your memory sticks in?  Please make sure they are both securely and fully inserted.  I had a similar problem on my 1800X (no OC) which turned out to be a bad memory slot (MB RMA).  My system would hang (not crash) when doing nothing.  Enjoy, John.


I don't have "Minidump" fonder in C:\Windows so I assume that no file has been generated. I do not quite understand what you mean without OC, I didn't manual OC, only installed motherboard, ryzen cpu, etc etc and installed windows, only changed to 3200Mhz memory. The boost is from Precision Boost 2, which is automatically activated without doing anything. Now im testing with AMD Ryzen Master using fixed 1.35V and 3.9Mhz to all cores and stress test with Prime95, It has been about two hours and nothing has happened, but as I say it does not happen when CPU uses more power, is random.

I'm running Windows 10 Pro version, fully patched and licensed. Clean installation after installing all hardware. Ram is fully inserted.

But my system not hang, my system restart, without error, blue screen, nothing, it's like u disconnect power and turn another time, computer restart without any apparent sign. Or my system turn black screen (two cause I have two screens) and it stops working, and can't restart with power button on case, have to stop the power or disconnect cable and turn on another time.

I don't know what can I do, all is up to date and I have not changed anything that could affect.

Thanks for your help.


Thanks, jaumes.  OK, I forgot to think about Precision Boost 2, but I still want you to either Clear CMOS or Load UEFI Defaults and run for a day or two or until crash.  What slots are your memory sticks in?  I am running W10 Pro x64 and have a "C:\Windows\Minidump", although it is empty.  What version of W10 do you have: Command Prompt-winver.


Please set your "System failure" settings as mine are set.  Thanks and enjoy, John.


I have the same issue and also have no minidumps. I did just change my settings to match your's, before it was on automatic dumps and there were no files for any dumps. I have tried a CMOS reset and have also swapped out my ram for a new set. I also changed them from being in B1/B2 to A1/A2 and it seemed to decrease in frequency but hasn't gone away. If you need the full specs of my computer then I can post them but I do not have time at the moment. I have also run Memtest on my RAM and it completes successfully. All issues seem to have no correlation to system stress or power draw from the PSU.


I know it's been over a year, but for everyone else, the solution to your and delphiki's issue is here. 

Journeyman III


I happen to have the same issue here.

My system is:

   - Ryzen 2700

   - MSI msi x470 gaming pro carbon (mobo)

   - Corsair Vengeance LPX DDR4 3000MHZ (2 x 8 GB)

   - Samsung SSD 860 EVO 1TB

   - NVIDIA GeForce GTX 1080

   - WIN10 OS build: 17134.523

I noticed that after playing a "heavy" game or after using certain application which require heavy GPU utilization, the screen goes black like it's on Sleep mode, the leds of the MOBO are still on, but the only way to wake up the system is by pressing the reboot button.

Currently the system is running with 8 cores all set to 4.0 GHZ, but the event also occurred when they were set to 3.250.

Again memory tests didn't show any problem, nor stress tests run with RYZEN master (with and without memory usage).

The CPU temperature peak that i reached was 70 deg C.


taglia, you should have really started a new thread.  Please post a screenshot of Ryzen Master (RM).  Please update to the latest W10 (1809.17763.292) and do a Clear CMOS.  Are you running the latest BIOS?  What is the size of your power supply?  Thanks and enjoy, John.

Journeyman III

I'm having the same issue...  

I went from having a ryzen 1600 running 16g of G. Skill Trident on an Asus x370 to a 2700x with a total of 32g of the Trident on the same board.  System ran good for about a day before the crashes started.  I first started with software adding/removing drivers hoping I messed something up, once that didn't work I started pulling Ram hoping maybe a stick died, but again no help.  From there I put the old 1600 back in and it crashed again...  So at this point I figured well the x370 died, didn't like the new chip, or whatever either way I went and got an Asus x470, a new EVGA 750 PSU and an AIO watercooler...  Figured as long as I'm driving way over to MicroCenter I might as well get it all...  Computer was running great while setting up and getting everything loaded back up...  BUT now its starting the crashes again...  Is my chip junk and cooking my boards??  seems strange when I put the 1600 back in the old board it crashed just like the 2700x did...  Not sure what to do at this point...

One last point, it seems like it dies more when nothing is going on then when pushing it..??

Adept I

Same problem here, with almost same configs.

Ryzen 2700 (non X)

Asus x470-f gaming, latest BIOS (march 2019)

Corsair Vengeance pro RGB 3000 mhz  @3200mhz (2 sticks 8 Gig each)

Samsung 850 EVO SSD.

Windows 10 Enterprise x64 (build 1809) all updated.

RTX 2060  drivers v430.86

XFX 750w pro Core PSU.

Everything was running just fine until last week.

Since then, PC shuts down randomly. No blue screen or any signal of error, it just shuts down. Sometimes it restarts, sometimes I must switch off and then on the PSU in order to boot again. Windows turns on without notice it had any fault.

Event viewer also does not register any strange event.

I'll reset BIOS and test with no tweaks tonight.

If I found the cause, I'll post it in here, will tell you guys.

I'm a bit afraid it's related to my PSU, which is several years old. Makes no sense a system problem that left no traces at all, so I'm betting it's a hardware issue.


So, what I notice was if I had any sort of monitoring software running it

would crash, even Asus software... ever since I tool CPUz and the Asus

suite off I haven't had an issue. But now I have no idea what's going on

temp or usage wise....


sdriver and smithb1981, I strongly urge both of you to talk to ASUS and ask them to help.  If they have no help to offer, I suggest you ask them to provide you with a BIOS that contains no ASUS OC software.  Good luck and enjoy, John.


Thanks John, I kind of stop worrying about it when I was able to stop the

resets. But I guess I should figure it out..



Alright, last night I finally had time to dig in the problem.

As I said, my PC was running just fine for several months.

Now, here comes the fuse that started the problem.

A month ago, a friend asked me to test his new DDR4 sticks. So I took off mine, insert his pair of memories(it's a Brazilian brand called Risemod) and tested for two days. Worked just fine, so I decided to add my Corsairs together as all sticks were labeled as 3000mhz with same timings. Once more, for several days, everything worked just fine with all 4 sticks in. And then I had to remove my friend's memories to give him back. It was one week before the problems start.

After taking them out, my computer was still running fine for over another week! That's why I didn't suspected the problem was related to the memories  I removed so long ago.

Anyway, what I did was removing my memories, change them to the other memory slots, and then return them back in the same slots. I also did a BIOS reset and remade all the OC settings. After each action, I did a reboot.

Now it's working flawlessly


Great, sdriver!  Thanks for reporting.  Enjoy, John.

Journeyman III


Sorry for the delay, but i haven't had much time lately to work on this issue.

So let me start by saying that i solved my problem (no more "black screens"), but it wasn't an hardware problem.

I forgot to mention in my initial post that my machine ran Win10, since then i installed on a separated disk, an Ubuntu 16.04 distrto and started doing some tests there.

Basically i ran any CPU/GPU-heavy application for some time, and the problem didn't show, so i thought that it might be a problem with the OS or rather with some software installed on Win10.

Some time later a friend told me that he was having a similar issue and he solved it by uninstalling pre-installed software.

So i went ahead and uninstalled MSI live update (which was installed day 0).

It's been 60+ days and i havent had a black screen since then.

P.S. @misterj sorry if i haven't opened a new thread, and if i still replied here, but i really wanted to share this issue.

Journeyman III

I'm having same issue. Black screen with the power/reset buttons useless. I have to turn the the psu off to reset.

Problem happens at idle eventually or I force it sometimes by running a benchmark but results are inconsistent.


Asus x470-f

32G Gskill trident ram 3000mhz (8x4)

msi rx580 armor mk2

650w corsair bronze psu

Everything is currently running at stalk speed

I have tried:

-Updating/resetting bios

-Swapped PSU

-Swapping vid cards

-Ram test, memtest86 (pass)

-Changed SSD to an M.2 with fresh windows

-Removing all unnecessary components

-My last attempt at repair was the M.2 drive. The system remained stable afterwords for two days until i started loading drivers and programs.

-I have noticed my cpu easily hits 80deg during Heaven benchmark. Is this normal? 

-I noticed someone above mentioning the problem may have been caused by system monitoring software. Seems odd but the problem started the day I loaded CAM monitoring software and technically started again after i reloaded it after the new SSD install.

-I'm an amateur when it comes to software... well PC's in general but I have learned a lot lately. I'm willing to try anything at this point, even if I have already done it.

Journeyman III

I've been having the same issue for a month.

AMD Ryzen 7 2700


16 G (2x8) Cosair Vengeance LPX

GeForce GT 710


System ran smoothly for about a month after build.  I've tried the following to no avail:

- Swapped out power supply

- Memtest successful

- Swapped memory to  Hyper FURY 2666,  made things worse

- Moved memory modules around, some configurations are more stable than others but overall problem persists.

System is more stable with one memory module than two, except for the Hyper FURY which is much worse. System reboots spontaneously even from UEFI bios screen, and when idle.


So mine has been running great ever since I removed all the windows asus

software and stopped trying to monitor temps...


Yea my problem went away as soon as i got rid of a cpu/gpu monitoring program called CAM. It seems so far fetched but its been over a week now without an issue.

Not pleased on the amount of time/money spent on dealing with this BS problem...

Also are AMD reps not supposed to be responding on this thread?

Get Outlook for Android<>


Yea I was p*ssed too... but since I stopped monitoring everything I've

been solid. As for the reps I'm not sure.


Then I suspect your problem is unrelated to mine.  Since I do not run Windows and I do not have any of the monitoring software installed, and my system reboots spontaneously from the BIOS screen.

I also noticed that previously I could barely run the system for a few minutes using Hyper FURY 2666 RAM. However, after changing the BIOS setting from Ai Tweaker (Auto) to D.O.C.P, the system is at least able to run for several hours before rebooting. The problem still exists.


Yea it doesnt sound like the same issue. Is your computer ever blackscreening? (monitor goes black, reset and power button does nothing).

If it's resetting in bios then all i can suggest is updating your bios. If that doesnt work Id be looking at hardware. 

But youre talking to an amatuer so good luck lol.


You had this issue. It's caused by more than 2 programs monitoring the CPU temp sensor. You might be able to help people by spreading this around.

Central topic for AMD random black screen/no signal issue, with power and reset buttons not working 


Finally found the problem with my system. Had nothing to do with Motherboard or CPU or memory. The problem was the reset switch on the case. Disconnected it and the system has been running for a week without issues.


Ha!! That's awesome, atleast you found it and its working...


So...the little reset connector for the front of your case was faulty and so you just unplugged it and now with it unplugged your pc doesn’t randomly reboot?


That is correct. It has been running without a hitch for more than a week. Previously it restarted every few minutes.

Adept II

i have strugle with this problem for days now, 
i dont know if it is CPU, GPU, or motherbord that cuase the black screen rebot
here is what inside.



I haven't had an issue since I deleted all my temp monitoring software.

Even the Asus software. Runs stable just cant monitor temps or clock

speeds. .


You are correct, you had this issue. I don't believe you have to remove all temp monitoring software, only check that no more than 2 programs are monitoring the CPU temperature. 

Adept II

Hey guys, i just notic this!
check energi alternative, and se if you have more options there!


Journeyman III

What power supply are you using? Have you done a memory test? Have you done a bench test?

Journeyman III

Good day,

add me to this problem. System:

- MSI x470 Gaming Pro

- AMD Ryzen 2700x with stock Wraith Prism cooler

- 2x8GB G.Skill RipJawsV @3200Mhz (Overclocked in MSI BIOS as recommended by both, AMD and MSI)

- 2x Crucial SSD MX500, summing up to 1.256 GB

- Case Cooler Master MasterBox K500L

- 2x140mm Cooler Master fans, 5x120mm Cooler Master fans

- Sapphire Vega 56 Pulse

The system has been completely set up from new, and had the Vega 56 exchanged with my old 980GTX, for 4-6 weeks, when the problem appeared the first time, around 3 month ago. Since then it happened twice, once on the 980, and once on a undervolted/overclocked Vega 56. Last weekend it happened again, with the Vega 56 now set to its factory default in the AMD Settings.

I was using various different software to monitor hardware information, specifically GPU/CPU temperature, wattage, clock speed, and all air cooling fan speeds. I used Cinebench and 3dMark to benchmark the GPU after overlocking. The CPU never got overclocked in any way. You don't want to overclock a Ryzen 2700x with stock coolers anyways, right? 

Also improtant, I tried literally everything that got mentioned in this thread, the second thread here on AMD forums, and all things mentioned on all the various other forums mentioning the problem. How the f should I know, that this can be pinpointed to monitoring software? And why the f, would a forum veteran recommend the AMD overlocking software, to pinpoint a systemwide shutdown?

Easy answer...because AMD does not want you to monitor their hardware...the reasons should be obvious. I'd given you a chance, and really wanted to support AMD, so there's some competition with you, and Nvidia/Intel emerging again. But that pretty much breakes any trust I had build up for you to begin with. My next system shall be a safe combination again. You blewed it, and don't even have the guts to admit, it is your flawed AMD settings software, which causes the conflicting issuew to begin with.

Instead of enforcing your will to users, an attitude I would usually expect from Intel/Nvidia, you should think about some honesty, and fix what is there, instead of continously vomiting out new content update, while the old content is still pretty much broken. I will return now to using Window 10 only drivers, and only MSI Afterburner, which I was so reliably using on my old system.


I agree I has to be a know/planned in AMD issue... but since I just

stopped caring out the stats I haven't had an issue... shitty yes but I'm

cheap and the performance has been good... so I guess I'll just deal.