cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Journeyman III
Journeyman III

Ryzen 7 2700x no display on boot

Hi, I have  a Ryzen 2700x with a Gigabyte gaming k7 motherboard.

When I boot the computer the fan on the cpu spins as does the fan on the gpu.

The problem is I cannot get the computer to output to the display, I get an error code of 02 on the motherboard, that code is not listed in the motherboard manual.

Any help would be greatly appreciated.

Ian

0 Kudos
16 Replies
Forerunner
Forerunner

Re: Ryzen 7 2700x no display on boot

Is your motherboard the GA-AX370 Gaming K7 motherboard?

If so, is the BIOS updated to support the Ryzen 7 2700x processor? (F22 BIOS)

INFORMATION REQUIRED WHEN POSTING A QUESTION

0 Kudos
Journeyman III
Journeyman III

Re: Ryzen 7 2700x no display on boot

First of all thank you for the quick reply. Yes that is my motherboard and it has been updated with the latest bios.

Sent from my Samsung Galaxy smartphone.

0 Kudos
Exemplar
Exemplar

Re: Ryzen 7 2700x no display on boot

shibble, without the information requested by arcticwind no guesses are possible.  I hope you are not expecting to get video from the connector on the MB, because your 2700X does not have an Integrated Graphic Adapter.  Enjoy, John.

Journeyman III
Journeyman III

Re: Ryzen 7 2700x no display on boot

Hello John.Thank you for the reply. No i am not expecting to get video from the motherboard. I have a separate graphics card and i have tried both hdmi and displayport. Thank you.Ian

Sent from my Samsung Galaxy smartphone.

0 Kudos
Forerunner
Forerunner

Re: Ryzen 7 2700x no display on boot

So, you are using the F23f version of BIOS?

Are all BIOS settings set to "Default" or "Auto"?

Is the PCIe slot with the GPU in it set to "Enabled"?

Does your power supply have enough WATTAGE and AMPS to run your GPU?

Are all power connectors plugged into the GPU?

Is your monitor plugged into the GPU and not the motherboard?

Are all power connectors plugged into the motherboard?

Are there any bent pins on the processor?

Is there anything that might be shorting out the motherboard?

Is your RAM compatible with your motherboard? (is it from the QVL list?)

INFORMATION REQUIRED WHEN POSTING A QUESTION 

Journeyman III
Journeyman III

Re: Ryzen 7 2700x no display on boot

Hi, I do not know what version of bios I have, I was told by the supplier they have flashed the latest bios, but I am unable to see as I cannot get any video to the monitor. I have a new 750 watt thermaltake psu, all power connectors are plugged into the motherboard, monitor is connected to the gpu, I have tried both hdmi and DisplayPort.

Ram is compatible as it was bought as a bundle (cpu, ram, motherboard).

I cannot see any bent pins on the cpu.

I have tried everything that I can think of.

I really appreciate your help in trying to solve my problem.

Ian

Sent from my iPad

0 Kudos
Journeyman III
Journeyman III

Re: Ryzen 7 2700x no display on boot

I would just like to add that the message i get from the monitor is, There is no signal coming from the monitor.It sounds to me to be a CPU problem but i bought it as a bundle of ram , CPU , motherboard and it was tested at the company. The company is Overclockers uk who are quite a big company in the UK.Once again I am extremely grateful for all your help.Ian.

Sent from my Samsung Galaxy smartphone.

0 Kudos
Esteemed Contributor III

Re: Ryzen 7 2700x no display on boot

Once you are able to boot into Windows, you should update the Motherboard's CHIPSET to the latest: GA-AX370-Gaming K7 (rev. 1.0) | Motherboard - GIGABYTE U.S.A.

According to this old thread at ExtremeOverclocking.com : Gigabyte EP45T-EXTREME boot codes - EXTREME Overclocking Forums .

The 02 Motherboard error concerns the Dual Bios.

Try Resetting the BIOS thru the CMOS CLEAR Switch or shorting bridge pin. You can find out the proper way to reset the BIOS in your particular Gigabyte Motherboard using the CMOS CLEAR feature.

0 Kudos
Journeyman III
Journeyman III

Re: Ryzen 7 2700x no display on boot

Hi, Thank you for taking the time and trouble to reply, it is very much appreciated.

At the moment I am unable to boot into windows because I get a message on my monitor saying that the monitor is not receiving a signal from the motherboard.

I have tried to clear cmos as you suggested but I still have the same problem

The CPU fan is spinning as is the VGA card fans.

I have tried removing all memory, then just using 1 stick of ram.

Ian

0 Kudos