Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 7 2700x & Asus prime b350 plus motherboard

I bought the motherboard and CPU separately. Had to get the boot kit to upgrade the bios. That worked great but for some reason the Ryzen chip just gives me a black screen and won't go to the motherboard bios. Is this a bad chip or motherboard issue since it still works fine with the boot kit chip?

8 Replies
Adept II

There are several small LED lights next to the RAM slots or around CPU, a green, a orange and a red. On the black screen after boot what color is the light on motherboard? If it is orange clear the Real Time Clock(RTC RAM 2-pin CLRTC). You can find motherboard diagram in user manual, either online or the copy that came with motherboard.

"This header allows you to clear the Real Time Clock (RTC) RAM in CMOS. You can

clear the CMOS memory of date, and system setup parameters by erasing the CMOS

RTC RAM data. The onboard button cell battery powers the RAM data in CMOS, which

include system setup information such as system passwords." from manual

1. Turn OFF the computer and unplug the power cord.

2. Use a metal object such as a screwdriver to short the two pins.

3. Plug the power cord and turn ON the computer.

4. Hold down the <


> key during the boot process and enter BIOS

setup to re-enter data

If the steps above do not help, remove the onboard battery and short the two pins again to

clear the CMOS RTC RAM data. After clearing the CMOS, reinstall the battery.


MB and cpu fan have lights on them but didn't see any lights other then those like you say. Anyways I tried both ways of clearing the cmos and still don't get bios post screen with the Ryzen 2700x chip but I do with the boot kit cpu.


When using the boot kit CPU, on the main BIOS/UEFI screen what BIOS version does it list?

Any BIOS after 3803 should work with that CPU and motherboard configuration.

You can try re-flashing the BIOS again (with the most current version) maybe it did not flash correctly. I know on the Asus x370 Plus motherboard once you flash a BIOS version you cannot re-flash to a lower or older version of the BIOS using the Asus EZ Flash utility. So re-flashing BIOS should be fine.

I have not got my hands on a 2xxx series Ryzen CPU to try myself. Other than that I am not sure.

Journeyman III

When I did the bios flash. It was version 4008. They came out with version 4011 the next day so since 4008 didn't get it to work. I flashed 4011 and I'm still at no post for bios on the ryzen 2700x chip.

Journeyman III

Reflashed bios with version 4011 just incase it didn't work right the 1st time. With the boot kit cpu the board fires right up but with the ryzen cpu it's like a big paper weight. All the lights come on for the MB and cpu fan but no bios post.


It might be your RAM is not compatible with the new Ryzen 7 2700x.

Did you also update your AMD CHIPSET from ASUS Support - 4/18/2018?

Check your Memory RAM from the list from ASUS that are compatible with the particular CPU: .

If your RAM is not listed that might be the problem.


Ram is listed but not needed to just get to bios boot which I can't get to with or without the ram with the ryzen chip installed. At this point I'm guessing that the problem is the chip itself for which I will need an rma# for to at least check. Would rather do a swap to find out for sure.

Journeyman III

Hey i know this is late but for anyone else using this board, It WILL NOT fully power up endless the ram is in the correct slots. I tried booting mine with 1 8gig stick in the first slot on the left hand side and had the same issue after building. I almost tore my whole pc back apart until i realized what i had done. It will power up in slot 2.