cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

seyfodayi
Journeyman III
Journeyman III

Ryzen 7 1700 Turbo not Working.

Jump to solution

Previously, my processor can now automatically go up to 3.75 GHZ with the R7 1700 Turbo, but now it can go up to 3.2 GHZ.  My system: Asus Crosshair VI Hero R7 1700 G Skill TridentZ RGB 3200 Mhz CL14  The latest BIOS, AMD Chipset Driver, is installed and the system is running on the Ryzen Balanced Power Plan.  When I reset the Bios, it is at most 3.2 GHz under load.

In short, in no way, the processor does not run at 3.75 GHz, which is the Turbo Frequency. Bios is completely in the default setting and there is no overclocking.

0 Kudos
1 Solution

Accepted Solutions
kahless_uk
Elite
Elite

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

I am not seeing anything wrong with the frequencies you've screenshotted there.

People seem to misunderstand XFR a great deal with Ryzen and retailers don't help by marketing the 1700 as a 3.7ghtz CPU which it's not, it's a 3.0ghtz CPU. Only one core can hit 3.7 (3.75 with XFR)

Turbocore clocks on the 1700 will up-clock ALL cores at once to 3.2ghtz, however XFR will ONLY work on ONE core and then ONLY when the other 7 cores are idle.

Your screenshot shows that core 0 had hit 3.749 at one point, that is XFR with the turbocore having bumped the others upto 3.2 as normal when all cores were used.

In other words, nothing is wrong, your CPU is behaving as intended.

View solution in original post

7 Replies
gigabytes
Adept III
Adept III

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

Have you viewed your clocks with HWinfo? I'm using ZenStates so my P-States are a bit different.

HWinfoAuto@3200.jpg

0 Kudos
seyfodayi
Journeyman III
Journeyman III

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

CoreClock.jpg

These are the frequencies with which I put the CPU-Z processor stress test.

Turbo is not working. Is my processor broken?

I did not do any overclocking. Why does turbo not work ???

0 Kudos
seyfodayi
Journeyman III
Journeyman III

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

CoreClock1.jpg

The clock frequencies I observed when I loaded the processor with various test programs ...

0 Kudos
kahless_uk
Elite
Elite

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

I am not seeing anything wrong with the frequencies you've screenshotted there.

People seem to misunderstand XFR a great deal with Ryzen and retailers don't help by marketing the 1700 as a 3.7ghtz CPU which it's not, it's a 3.0ghtz CPU. Only one core can hit 3.7 (3.75 with XFR)

Turbocore clocks on the 1700 will up-clock ALL cores at once to 3.2ghtz, however XFR will ONLY work on ONE core and then ONLY when the other 7 cores are idle.

Your screenshot shows that core 0 had hit 3.749 at one point, that is XFR with the turbocore having bumped the others upto 3.2 as normal when all cores were used.

In other words, nothing is wrong, your CPU is behaving as intended.

View solution in original post

gigabytes
Adept III
Adept III

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

Those SS look normal to me also, only one maybe 2 cores will overclock at any one time depending on need. You can manipulate that a bit with windows power management settings.

Power.jpg

Furthermore if you own a Asus motherboard you can use the utility ZenStates to modify your P-States. This will allow you to set P0-P2 states for all cores. It is however a little buggy in the interaction with windows power management so it takes a lot of trial and error.

Pstate.jpg

pstate2.jpg

0 Kudos
seyfodayi
Journeyman III
Journeyman III

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

Thank you so much for your answers. Now I have learned the subject better.

gigabytes      kahless_uk ......

0 Kudos
amdmatt
Community Manager
Community Manager

Re: Ryzen 7 1700 Turbo not Working.

Jump to solution

glad to see that you have found the correct answer to your question.  In order to help others with a similar problem to find this answer quickly, we have locked the discussion to keep it focused on the issue you reported.

0 Kudos