Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 5900x: System constantly crashing/restarting WHEA-Logger ID 18 and critical error Kernel-Power

Mainboard: MSI x570 Unify
Mainboard-BIOS: 7C35vA82 (Beta version)
CPU: Ryzen 5900x
RAM: Crucial Ballistix BL2K32G36C16U4B 3600 MHz, 64GB (32GB x2)
Drive: M.2 Samsung 970 Evo+ 1TB SSD
Graphics: SAPPHIRE Nitro+ Radeon RX 5700 XT
PSU: be quiet straight power 11 750w Platinum
OS: Win 10 Pro (64bit) - all updates installed
Chipset driver: (released 2020-11-09)

I first assembled the PC with a Ryzen 3800x a week ago because it was unclear if and when I would get the Ryzen 5900x I ordered. Worked with the included AMD Prism Wrath CPU cooler for one week without any problems.

- Today I installed a Ryzen 5900x and a Scythe Fuma 2 CPU cooler.
- After 20 min the first crash/restart with the following entries in the Event Viewer: WHEA-Logger ID 18 and critical error Kernel-Power ID 41.
- Happens irregularly again and again, sometimes after minutes, sometimes longer: Windows freezes for a few seconds and then the PC reboots. Doesn't matter if load or not.
- CPU temperature between 30 and 40 °C
- Updated to BIOS and chipset driver mentioned above: Problem still exists
- XMP Profile disabled (RAM on 2600 MHz): problem still exists
- CMOS Reset: Problem still exists

Either there is a compatibility problem of something with the CPU, or the CPU is defective?
What to do? Really frustrating.

2 Solutions

Im having a similar issue, x570 aorus and 5600x. Have same errors on windows. 

Disable CBP and PBO and run it at default settings (3.7 ghz and xmp on). That works for me. 

View solution in original post

I got a new angle on this. So deactivating PBO and CBS definetely works, PC was running stable for a week now. But you'll loose performance.

So I wrote to the MSI support and the AMD support.

MSI suggested to try increasing the DRAM Voltage by 0.05 V, which I did. System seems to be stable, no crashes so far - neither in idle or while gaming.

View solution in original post

947 Replies

I updated to the latest BIOS for my ASUS B550M plus WiFi v2423 release on the 17th, it's patch C of the latest AGESA. It's already crashed, it appears far less stable.

I went out for 20mins after booting, came back everything was asleep but appeared to still be running I hit CTRL to wake the screen and it died the second I hit the button, a bit of a coincidence.

One thing I noticed, is my memory was at 2133Mhz not 3600Mhz in the BIOS even after applying DOCP. I thought this was weird, I usually check this stuff. I don't know if this was set right when I got my new CPU, I imagine I would of noticed then too however can't confirm.

I have an image from the 13th after it started crashing again, I didn't notice then but the image shows it was on 2133Mhz then.

My CPU was replaced around 21st of June, I don't think I have a record of the RAM Mhz from back then but I probably would of noticed if it wasn't set right.

I have an image showing it was correctly 3600Mhz on 1st of April with my old CPU. Not sure the BIOS version maybe 2006 back then.

Very strange, however on the bright side with it crashing so often I should be able to identify the cause easier.


So my second 5800X was perfect for over a month couldn't produce any instability.
However after a couple of months it crashed too and continued to degrade, until I could post but Windows wouldn't boot, stuck on the spinning dots.
Unbuntu however spat out heaps of CPU core soft lockup errors.

Tried a 3600, no issues, another dead 5800X.

I'm now on my 3rd 5800X, working fine so far but I'm not holding my breath, lets see if this one is stable... 


I am pretty convinced by all of the huge confusing threads like this one, and my own experience, that this is not a bad CPU problem.  If you are on your 3rd CPU it only reinforces that fact.  Its not the issue.  The issue for almost all of us have been a combination of specific hardware and firmware versions.  

Simple BIOS firmware update to my motherboard fixed it.  No more errors in event viewer no more random reboots. Is super solid.  Actually loving this chip at this point.  I do understand it's a real b*tch of an issue to troubleshoot. I was pulling my hair out.   But I would honestly bet money that its almost always going to be a firmware issue, somewhere.  We often think we are all updated but are not.   Go through all your hardware thoroughly and check for updates from the manufacturers and ensure you do your motherboard.

Mobo/BIOS update fixed it for me and indeed many of the suggestions in this and similar threads (adjusting XMP CBP PBO etc) I noticed those settings were slightly changed in the new firmware update for my gigabyte mobo.  Which explains why a lot of people were able to fix it with a minor voltage differential or disabling some of the above features



@kneel420 man don't be so direspectful to tell me what's what about my own situation when you have very little insight into my situation.

I've been working with computers since the 90's I'm not a noob at this I know how to update a BIOS. I've been troubleshooting this issue since Feb and it's annoying enough to have to replace 2 processors let a lone have someone tell you that you missed an update.

My local brick and mortar tested my CPU and got the same results on a completely separate system, it could no longer boot Windows or Linux. They replaced it on the spot. My first CPU AMD gave the store a refund after they tested my CPU.

If my first 2 CPUs weren't duds I would of gotten the CPU sent back.

Keep in mind I'm only giving the important details in the updates not every little detail and test I've gone through.

Don't claim there's not real issues people are dealing with because there are.


A Major part of the problem is everyone's issue is "just slightly" different.  I had no problem running a 3700X with XMP2 at 3600.  Doesn't seem to work with the 5950X.  I've updated my bios.  I've reverted my bios, then updated again.   The only thing that's helped me so far are reduced memory timings.   I'm still waiting on G.Skill to help me diagnose the issue.  They've responded for more information and I'm waiting to hear back from them.

Using the Ram calculator as you suggested, did nothing for me, if anything, it made things worse.   Other people have said NOT to use the "Try It!" feature on my MSI board, but that seems to be keeping me stable at 3333.  It's quite possible that the memory controller on the 5xxxx series is just way more finicky than the 3xxxx series and memory latency and timings may be a big factor.  AMD won't tell us, but they might tell the ram manufacturers... hence why I'm hoping G.Skill may offer some insight...

@kneel420   If you've read a fraction of the conversation in this thread, you would know that there is no "simple" catch all solution to this problem. And if you're aware of that fact then surely you recognize THAT is the problem. Besides, I wouldn't be surprised in the slightest if people claiming they've found a solution are suddenly facing the same problem later down the line. That has happened several times in all of the discussions I've seen relating to this issue.

3rd CPU crashed again, a little over 24hrs after being installed. Seems just as unstable as the last one.
I have a feeling the latest BIOS is less stable than previous ones but can't say for sure.

Well at least it's not dead, I can go back to troubleshooting the stability issues and hope this one doesn't die too.

Never had so much trouble with a platform before.

I have 3600Mhz CL16 memory, my PC store says that should be fine.
AMD says supports up to 3200Mhz.
ASUS and G.Skill used to have it on the QVL but now ASUS only has it on the QVL for 3000 series CPUs.

I'm used to just getting memory available on the QVL for a socket type and enabling XMP and it just works.
I can't recall a time when a CPU had s max spec it could handle.

My last CPU made no difference lowering speeds but that one was dying anyway.
I can't find any quality 3200Mhz sticks anymore it seems, everything is 3600Mhz or higher these days.

Does anyone know if this is a memory issue?
Has anyone had success lowering speeds?


try bumping VDDG IOD and/or vsoc.

@tokuro I'd rather not have to bump voltages etc, I don't want to mess with overclocking. I just want to run it stable at stock settings. I'd probably down clock it first.

Does anyone know if running 3600Mhz CL16 with DOCP is considered a normal stock config?

Should this config work fine or should I get different RAM, there seems to be a bit of debate online?

I could answer this question easy if it was Intel but maybe I'm missing something when it comes to modern AMD?


@Cmdr-ZiN technically, 3600 on DRAM is overclock on ryzen.  3200 is the "spec" max.  Your BIOS/Firmware will bump voltage when you select anything higher than 3200 (most cases).  Also, if you have 4 sticks, it may take more to make that stable on many motherboards.

@tokuro thanks for that, good to know. I can't find any quality 3200Mhz sticks so I'll try calculating the timings for my memory at 3200Mhz and see if that helps.

I only have 2 of 4 Dimms populated.

Both previous CPUs I tried running them at 2133Mhz when DOCP wasn't enabled and it still crashed, should it of been stable then? Would that rule out a ram issue or not sure?



I would definitely test the ram with good tester like Memtest86 if you didn't already tested it and if u are crashing at 2133mhz. 

Did u tried with only 1 stick of ram? test one then the other. 


@kodo28 I ran memtest through several loops without issue.

The ram is functioning normally, I just don't know if it's too fast for the CPU.

It's a worthwhile test but I'll prolly try different memory if it comes to that.



If you tested it already with memtest and ram passed the full test, then low chances are that issue is with the ram.

Ram should be able to run ok at 2133Mhz even more if 2 slots only without issue. 

If you are crashing at 2133Mhz then it certainly not due ram being to fast. It must be something else. 

I'm running 2 x 16 Corsair Vengeance LPX 3200 C16 with no issues (5800X on Asus B550-F).  Only glitch was that when DOCP was first enabled, the mobo set tRC to 74, even though the SPD has it programmed at 58.  So I manually keyed tRC to 58 and system has been rock solid (no overclocking).

It could be that your memory is technically okay, but for whatever reason the mobo is not reading/setting all the parameters (there are a whole crapload of them) correctly.  And incorrectly programmed parameters in the SPD is also not unheard of.

So, maybe worth trying a completely different set of memory.  Also, it's possible there's a problem with your mobo.

You mentioned in an earlier post that a local store tested a previous CPU - can you get them to test your current CPU and memory?

@ryzen_type_r  I have noticed on the easy setup DOCP doesn't enable correctly, but on the advanced menu all the settings were correct last I double checked, which was a long time ago. Seems about right though, I will go over these at some point, next time it crashes.

I'm still looking into maybe trying different memory and maybe even different PSU, although they've mostly been ruled as ok but not double verified.

In the end I'll probably take my whole PC to the store next time, as it'll be easier to reproduce.
Problem is it's very hard to reproduce, you just need to wait.

My first CPU, once I noticed the issue (took me 2 months to bother to pay attention to it) I was able to leave my PC on idle with Chrome in the background and it would fail after 24hrs. After a BIOS update it would error within 7 days, but once it started failing it would sometimes fail several more times before going stable again.

My second CPU was perfect for 2 months, then once it started failing it rapidly degraded, until Windows wouldn't even boot. This was definitely a CPU issue, it was the same in different systems, I can't say the cause though.

So far it's only happened once with the latest CPU, I've made a few tweaks and I'll wait to see if it happens again, then I'll make a few more tests.


Yeah, but to be fair, that's only based on your experience.

@Cmdr-ZiNhas *done* BIOS updates up the wazoo, and it still didn't stop the errors coming.

I agree that it's *likely* that there is definitely a deepset issue with the current generation (and previous?) of Ryzen CPUs and how the BIOS & Driver (proven by linux users replicating their Windows issues without fault) interacts with them. However it's not going to help to sound like the authority on something when not everything is known. You potentially lead people down blind alleys.

Apologies if any of this has already been pointed out to you, mate, and I'm not saying it harshly, but thought it should be mentioned for new folks coming to this thread ... likely linked to it from others.

@kneel420 wrote:

I am pretty convinced by all of the huge confusing threads like this one, and my own experience, that this is not a bad CPU problem.  If you are on your 3rd CPU it only reinforces that fact.  Its not the issue.  The issue for almost all of us have been a combination of specific hardware and firmware versions.  

Simple BIOS firmware update to my motherboard fixed it.  No more errors in event viewer no more random reboots. Is super solid.  Actually loving this chip at this point.  I do understand it's a real b*tch of an issue to troubleshoot. I was pulling my hair out.   But I would honestly bet money that its almost always going to be a firmware issue, somewhere.  We often think we are all updated but are not.   Go through all your hardware thoroughly and check for updates from the manufacturers and ensure you do your motherboard.

Mobo/BIOS update fixed it for me and indeed many of the suggestions in this and similar threads (adjusting XMP CBP PBO etc) I noticed those settings were slightly changed in the new firmware update for my gigabyte mobo.  Which explains why a lot of people were able to fix it with a minor voltage differential or disabling some of the above features



To all:

At this point I would recommend that everyone (whether the issue is resolved or not) use the AMD Technical Support contact form, below and raise an INCIDENT with them.

The word 'incident' is important. When talking about these concerns with a helpdesk, you must use that word, in short, it is how they work. Especially don't use 'problem', and try to steer clear of other words (like issue), this will indicate that it isn't a major thing for you.

If we copy/paste the following, then it will be more likely to register as a major issue.



Ryzen CPU Cutting Out - Incident - WHEA?


Problem description:

The above link is where I have been discussing this incident (and recurrences) with others who have experienced this. You may not have seen it as it is marked as resolved, but for most it is not.




So, that's the base link to this thread, up front and center, and showing that you're aware that they might not have seen it.

Try to mention the WHEA errors if you've experienced them (or seen them), and include as much/many log references as you can. Also include any/all troubleshooting that you and/or your supplier have done.

If you have resolved the incident mention this at the end, and say that they can close the ticket once you have a reference number. Because if @Cmdr-ZiN's experience is anything to go by, this will recur (repeat incidents are called 'recurrences' in helpdesk world) then you will need to either open a recurrence or re-open the ticket.

Hey guys,

I got my whea 18 bsods to stop by changing my memory from 1t with gear down enabled to 2t with gear down disabled. I have 4 dimms (16x4 gb) and apparently getting full slots to run at 1t with gear down is tricky. I actually wrote g.skill about it, I wanted to know if the kit was suppose to be at 1t or 2t. Their response was with 4 dimms and this memory size that its always 2t. Sometimes it can be stable at 1t, if so then go for it.


The difference is night and day. When I had 1t with gear down enabled I get whea 18s within 15mins of gaming or going idle. Sometimes I'd get lucky and it would last for a hour. I noticed that when I increased the soc, vddg and vddp voltage that I was able to game or go idle for quite sometime before it rebooted.

Now everything is on auto, xmp enabled but 2t instead of 1t. Now there are no errors. 

@crayraven I'm going to try this with XMP enabled.

G.Skill basically told me that since the ram isn't rated for my mb that I should run it slower.  When I told them it worked fine with a 3700x they said to RMA the ram.

I'm very much doubtful it's the ram, as I've run multiple ram tests that all turned out fine.

I do have 4x8gb sticks, and I have been running them 1t with gear down enabled as recommended by that ram timing calculation software that's way overdue to be retired. 

Going to test it out tomorrow!  Thanks for this. 



I had the same issue. Memtest would come back clear so I really didn't think it was a memory issue. I only started to think it could be one after putting together the facts. Which was that whea 18s became infrequent when memory related voltages were increase. If I'm right and I hope I am, the reason why the increase voltage was needed is because the memory wasnt stable at 1t with gear down enabled. It would make sense.



Stock, default, whatever. Whatever you want to call out of the box settings. Also, you making a suggestion in an attempt to help isn't the thing I took issue with. It's the notion that one would have to make such adjustments to get their system up and running "out of the box". Adjusting voltages of any sort isn't something that should be expected of your average consumer. Since you seem to recognize that there are "numerous types of people" out there, I shouldn't have to point that out. Anyway, to be clear my frustration wasn't aimed towards you or your attempt to help. I apologize if it came across that way.

@crayraven thanks for the tips, It's possible we might be on to something with the memory. It's also strange how a lot of us have G.Skill.

@koguma I could of sworn my RAM was on the QVL for my board but when I noticed it wasn't on the QVL of G.Skill's website for my board I double checked. It was only on the QVL for the 3000 series not the 5000 series.

It's now on the QVL on G.Skills website for my MOBO again. I find it very strange the 5000 series is having more trouble with RAM than the 3000.

Maybe I made a mistake I wish I'd documented it. Maybe ASUS removed it after there were issues reported.

So yeah I might need to mess with RAM timings. However what's throwing me off is it's acting like a CPU or PSU fault, not getting any blue screens etc.

I guess Ryzen is different with Infinity Fabric and picky with RAM, many say it is, but does that cause what we are seeing?

I also found some F4-3200C14D-16GFX for $200 locally it's just come back into stock, the only 3200Mhz CL14 memory I could find. I could go for 3600Mhz on the QVL but that would require a lot of search and CPU still might not like it. Anyway thinking of getting this just as a test to rule out RAM issues. However so far it's not crashing with my current tweaks, so need to work out if it still crashes before I make a change.

Awesome analysis ZiN


After playing around yesterday with power option/balance/processor management to 10 and xmp to 3000mhz have made my 5600x stable,bsod when set xmp to 3200mhz which I dont understand, maybe it is cpu/memory related to the bios/ryzen 5000s architecture 


I think Zen 3 is very picky when it comes to memory. When I first upgraded my system from a Ryzen 1800x and x370 platform back in June I used a 16x4gb corsair dominator kit. While it had been very stable for the past 4 years with my old x370 platform it was not with my 5950x and x570. 


I got whea 18s almost immediately, even with cmd 2t. Which I thought was weird, since it worked with my old platform just fine. Because of the whea 18s I decided to get a g.skill 64gb kit. Because I thought it was just a ram incompatibility with the new platform. When I installed the kit everything seemed fine until I got the whea 18 bsod again and again. So I really started to think it was voltage issues with the cpu when its idle or doing light load tasks.

I now believe its a RAM issue. I don't believe any of the cpus RMAed were faulty. Maybe a few of them, but not as many as we think. I think the main issue is that the xmp profile doesn't set 2T +gear down disabled when needed, when it should have. This causes people to believe something is wrong with their system. And eventually think its the cpu broken. Its surprising, out of all the threads I read no one suggested that it could be the ram set to a cmd rate that it couldn't run stable at. I mean, I didn't even think that until I started to put all the facts together to form a picture.


So far I've had my pc on for 24 hours straight. Not a single whea 18. It feels great. I hope this solution actually works for everyone. I know I did NOT want to RMA my cpu or board. I'm sure most did not. 



What have you done exactly to the ram setting to have it stable for over 24hrs? 





In your dram settings, disable gear down mode and change cmd to 2T instead of keeping it on auto. 

If both are on auto then gear down mode will be enabled by default and cmd will be set to 1t by default. My view on what is happening is that sticks like mine put a lot of strain on Ryzen mem controller so it can't handle 1t or 1.5t (that is 1t+gear down mode enabled). 



I will be RMAing my CPU an go back to intel/10850k i cant keep on going with setting changes every day for the past 3 months.

@crayraven careful not to assume we've sorted it until we've proven it but we might be on to something.

My second CPU clearly died but it was working perfect before that, it also was easy to determine once it had fully gone.

The instability is a bit more unknown.

The 5000 series was supposed to handle faster memory

Please let us know if you're still good in a week or two then let us know if you're still good in a few months, these things tend to come back.

This may not solve everyones issues but It'd be interesting to see how many people this helps. It'd be kind of similar to other methods people use but safer than boosting voltages.



I will keep everyone up to date.

this is just my experience.  FMMV !!


There's something about AMD chips that did not change over time.  i have used AMD on and off a long time.  Just like last ones, For my Ryzen 5000 (i have 5950x with x570 Elite GB MB), having memory setting "correct" was key to success of having a stable system.  I am not a heavy overclocker, nor gamer or anything but do need a reliable system for my work.  for this setup, I've started with 2 sticks of DIMMs (2x 32GB).  I got what i need to do and got to a stable place.  Then i added 2 more (2x 16GB) making total of 96GB.  (side note: i do have another 2x32GB but they are different timing chips and i just could not get them play nice with other 2).  That's when some issues started to show up.


At first, problem was random reboots (mostly during idle) and there was one bench mark that i knew it would make the system reboot.  All other testing etc passed fine.  To resolve this last issue, all i had to do was to push vsoc to 1.2v & vsoc LLC to "medium".  RAM timing etc were all left to manufacture's stated values for 1800MHZ (so DDR 3600 settings).  for good measure, i have VDDG CCD 1015, VDDG IOD 1045.  with these, i have no more issues and it's been that way for months.  Since i have the system stable, i bumped fabric/mem clock to 1833 to be a bit faster with no other changes in voltage etc.  Even with that bump, the system is having no issues at all.  I also have all core CO at -15 (too lazy to get that all fixed for 16 cores).  On memory front, since i have just about all at default, gear mode is enabled with 1T.  BGS is disabled, BTW.

Yes, this is not the fastest memory but i need more memory than less of faster memory for my needs.  And yes, i have no WHEA or any other issues.



Hey guys,


After a couple days I finally got a bsod. Here is the interesting thing, its a Kernel 41 + system service exception tcpip.sys bsod. Not a whea 18. I have no idea what that means.


@crayraven hard to say what the error means, when the system fails it might spit out whatever it was working on at the time and that might not be the cause.

Have you tried the ram calculator to get safe timings?

Mine is still stable for some reason.



I have, but it didn't work for me.

You could be right, but I've always been doing something when I get the whea 18 when my pc isn't idle. So why didn't I get a different bsod then? 


I have been getting whea incorrectable error, yesterday I removed my ssd m.2 and installed clean window on a regular ssd no whea error for 24hrs, strange af, I had nearly orded my 10850k an tho il give it one last shot, I recommend trying a non m.2 ssd


@crayraven I found it would mostly occur during idle for me but once or twice it occured during a game. It's pretty random.

I get very few WHEA errors now, I believe they mostly point to a GFX card error. However my previous GFX card was Nvidia and it gave a different generic windows GFX error. I my case it was something other than the GFX card causing that error. However a few DDU's later, some drive, chipset and BIOS updates and WHEA errors became pretty rare.

I don't get BSODs so it's hard to narrow down, that's why it seems like a power, mobo/ram or CPU issue. If you're getting real BSODs you might want to take a closer look are your GFX card.

I mostly check in event viewer after coming back up and look for even ID 6008, the error was more comon, every WHEA error also had a ID 6008 error too but not every 6008 error had WHEA errors. It would be nice to have a BSODs to go on, all I know is it's a hardware issue.

Yours seems very unstable I'm not sure what next to try, depends on what you've done previously.

@Optimalnz I've also wondered it was a NVME Gen4 issue, I've had the crash occurs a couple of times installing stuff and once after a 100 gig file transfer. I was wondering if it puts instability on the bus but not sure. I've had the crash occur outside Windows so I kind of haven't paid a lot of attention to this aspect now.

Let us know how you go it could take a 3 months to reoccur.

Little update... I'm trying the 2t with gear down mode disabled.  Switching to 2t, gear down mode is greyed out on 'Auto'.  I also disabled "power down mode'.  Bumped FCLK to 1833 and set uclk==fclk in the bios, and set delayed latency mode to 'msi' setting. Everything else is on 'Auto'.

My ram now seems to be running at around 1772 with matching uncore.  No WHEA errors so far.  I've been running ok for a few days now.  Keeping fingers crossed, because I can live with this ram speed.



I've still been following this thread since having the same issue and ditching the 5900x for a 10900k in the hopes this maybe fixed so I could revisit a AMD setup.
What's concerning me the most is the issues are still there and AMD or any other media outlet have never addressed them publicly.

There's a clear ongoing issue that seems to be ignored.
My overpriced 5900x/Dark Hero ran perfectly for 2 weeks, then started to hard reboot on idle constantly with WHEA errors, no overclocking beside setting the 2x16GB 16-16-16-36 3600Mhz ram's speed, but even running it at stock wouldn't stop the problem.

For someone looking to just run the CPU pretty much stock out of the box with no issues, this is really bad and I hope the next gen Ryzen doesn't have this problem because when they work they are impressive CPU's.

Have some new info I want to share.   Was running ok at the previous sub-optimal speed using the G.Skill F4-3600C17-8GTZR.   But I ran out of ram, so decided to upgrade.

I bought 4 sticks of Kingston HyperX HX432C16FB3/32.  It was pretty cheap, and had "AMD Ready" on it.  Cleared the cmos, plopped them in, booted into the bios, enabled XMP-1 (3200) and away it went without a hitch.  After about a day, I decided to test my luck.  Used the Try-It! and went up to 3600.  Running like that the past few days with zero problems, all settings on auto.

I feel like I could push it even more, but I'm happy as-is and I'd rather have stability.   So imho it's definitely a ram compatibility issue.  With the G.Skill, I couldn't push it to even XMP ratings.   After some Googling, it seems the Kingston ram is Hynix c-die, and people have been overclocking the crap out of them.

Of note, the G.Skill ram had a JDEC setting of 1000Mhz, while the Kingston is 1200.  That tells me that at least, the ram is definitely of a better quality on the Kingston:





@koguma cool that's good to hear I hope it stays fixed for you.

I still think there's a combo of issues but RAM instability seems to be a big factor. A lot of people struggle to get speeds higher than 3200Mhz and I was feeling the 'AMD ready' RAM might be the safer option.

For myself though with my first CPU lowering the RAM speeds made no difference, however this was on much earlier BIOSes and drivers. My RAM wasn't marked AMD ready but was on the QVL but then removed for the 5000 series by ASUS but then added later by G.Skill on their site, so definitely questionable ram.

My 3rd CPU crashed twice when I first installed it, However since another round of updates I think the August ones for BIOS and chipset I have only had one crash. I think that crash was a bit different and maybe was a software issue.

I'm now unable to reproduce any instability. According to CTR 2.1 I have a Golden Sample CPU, I don't know if I believe that but I do think some CPUs can handle a greater range of memory than others.

If this issue returns I think my next step will be to get some 3200Mhz AMD Ready RAM, but it looks like for now my current CPU is happy with my original RAM. It really might of been only my first CPU with the instability issue, my 2nd CPU got unstable after something died inside. Since then I've been checking every crash, when if it was a brand new build I wouldn't of care until it happened more.

Good luck.