Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 5900x: System constantly crashing/restarting WHEA-Logger ID 18 and critical error Kernel-Power

Mainboard: MSI x570 Unify
Mainboard-BIOS: 7C35vA82 (Beta version)
CPU: Ryzen 5900x
RAM: Crucial Ballistix BL2K32G36C16U4B 3600 MHz, 64GB (32GB x2)
Drive: M.2 Samsung 970 Evo+ 1TB SSD
Graphics: SAPPHIRE Nitro+ Radeon RX 5700 XT
PSU: be quiet straight power 11 750w Platinum
OS: Win 10 Pro (64bit) - all updates installed
Chipset driver: (released 2020-11-09)

I first assembled the PC with a Ryzen 3800x a week ago because it was unclear if and when I would get the Ryzen 5900x I ordered. Worked with the included AMD Prism Wrath CPU cooler for one week without any problems.

- Today I installed a Ryzen 5900x and a Scythe Fuma 2 CPU cooler.
- After 20 min the first crash/restart with the following entries in the Event Viewer: WHEA-Logger ID 18 and critical error Kernel-Power ID 41.
- Happens irregularly again and again, sometimes after minutes, sometimes longer: Windows freezes for a few seconds and then the PC reboots. Doesn't matter if load or not.
- CPU temperature between 30 and 40 °C
- Updated to BIOS and chipset driver mentioned above: Problem still exists
- XMP Profile disabled (RAM on 2600 MHz): problem still exists
- CMOS Reset: Problem still exists

Either there is a compatibility problem of something with the CPU, or the CPU is defective?
What to do? Really frustrating.

2 Solutions

Im having a similar issue, x570 aorus and 5600x. Have same errors on windows. 

Disable CBP and PBO and run it at default settings (3.7 ghz and xmp on). That works for me. 

View solution in original post

I got a new angle on this. So deactivating PBO and CBS definetely works, PC was running stable for a week now. But you'll loose performance.

So I wrote to the MSI support and the AMD support.

MSI suggested to try increasing the DRAM Voltage by 0.05 V, which I did. System seems to be stable, no crashes so far - neither in idle or while gaming.

View solution in original post

947 Replies

I have a 5800X and had a lot problems with idle freezes (after around 20-30minutes)!
It seems like there was a driver Problem with my 3080 cause with the newest drivers there aren't any freezes anymore!
I have my Corsair Vengeance RGB Pro 3466 overclocked to 3800 with cl16 (and the other timings are at b-die niveau) and if clock 1900mhz!
PBO +200 and curve -8 on all cores! I use it on a B450 Carbon Pro AC (non Max) Beta Bios!


I had another WHEA ID: 18.
But this time I managed to trace the possible cause that was my distrust. The CLINK cable from the Corsair RM-1000 source. The memories of ADATA XPG arrived to complete the setup with 32GB. So, it was the moment I needed to remove the adapted cable that Corsair sent me to put in a single USB port, the source and the toilet. I removed this cable and put only the one from the toilet that came with it.

The error was pointed out exactly in the USB port where the two were. I hope I don't have any more problems with that. There is no further explanation for this. It sucks when the system doesn't point out where the problem is. As the forced reset held more this time, it even recorded the folder with some information.


[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]

About these crashes, BSODs and etc., from the experience I had so far, and in what I observed others experiencing, we need to separate for the most possible causes and work on them.

Are they:
- Undo any overclocking. Keep only Boost and XMP active and you will eliminate the options;
- Device drivers - Source, Chipset, Graphics, mouse, keyboard, toilet, fans;
- Mainboard and / or monitoring applications. Validate whether the dlls or components are old and / or conflict with other new or old applications;
- Poorly connected or broken cables in your body;
- Validate the device management cables - WC, Source, etc;
- In the last case, validate Source, CPU, Memory (if it is in the Mainboard's QLV), VGA and Mainboard.

Often the problem will be driver and software. It will hardly be a hardware problem.

[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]

Nobody gets a WHEA 18 error because of a mouse driver or a dll.

I got one once when I was literally booting off the USB in bios to install windows which pretty much invalidates 90% of your list.

These WHEA errors are most likely a combination of CPU lottery and AGESA/BIOS. 


I took WHEA because of the USB port, conflict well with the USB HUB. I removed the guy who was causing the problem and solved it.

Take a deeper look at the forums out there and you will be amazed at what people have taken WHEA.

So, my list is not as invalid as you mentioned.

I believe there is a fault with the BIOS, but after I bought new memories in QLV, I removed the CLINK driver and the CLINK cable from the source (which worked in a double adaptation on a single door with the WC), everything stabilized. Before I had WHEA constantly.

[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]

Hello, again! Update from me

I send CPU, MB, memory - as I have two issues - one is WHEA BSOD in load and another black screen restarts in idle.
In the shop's service after check, there were found defects in memory and in the mainboard - but for CPU they did not find anything wrong.

So I got a new mainboard (MSI B550 Carbon), memory (Crucial 2*16GB 3600c16), and the same 5900x.

I test this build for 3 days - I was unable to reproduce black screens restarts in idle mode - so far, so good - that is great for me.

But I still got these WHEA errors on load (I tried Shadow of Tomb Raider benchmark - 2560*1440 highest+rtx ultra - with RTX 3080) - In this benchmark, I am able to get this WHEA BSODS with 100% on default bios settings (Core performance boost on, Performance Boost Overclock off, XMP on). If I turned off Core Performance Boost - everything works fine

So I am again frustrated and in sad mode( Does somebody know if new agesa 1.2 0.0 fixes WHEA errors or not?)

Also, please write - how you can reproduce this WHEA error - for me:
1. the most stable way to get one is this benchmark in Shadow Of Tomb Raider.
2. second way to reproduce RDR2 benchmark also 2560*1440 and all settings on high.

I was unable to reproduce the issue in AIDA64 Stability Test, Cinebench R23 also works just fine.

Please, share some other ways to reproduce the issue.



The game you're crashing on is CPU intensive and the shop might not be able to replicate the problem if you only send 3 parts in. Send the whole box in so they can try it out the way you have it assembled. It could very well boil down to a defective CPU, many on here have RMA'd that CPU with success. Check your PSU as well for age, etc. Sounds like you got a bad CPU given that it works until PBO is on. You can add some Vcore and SOC voltage to it in small increments to see if it becomes stable. There are guides on doing this. When you enable PBO, there's certain OC mode voltages that you can enable in BIOS usually that will fix stability issues. Like LLC set in the middle of the scale. 7C90v152 is the latest BIOS for you, going back to 7C90v12 might be more stable. Make sure the RAM is in the A2-B2 slots.

I glanced over your manual to look at the BIOS layout and you might need to manually set certain voltages to get stable. The "auto OC" deal from MSI is still the same as it has been for about 10 years, worthless in my opinion. The manual area is "ok" but you need to know more than I'm willing to go into here to properly skew some settings that would most likely clear this up. But in theory, the CPU should just work with PBO or not on that board. So to keep it real simple, either send that whole rig into the shop so they can run a "real world" test on it, try a different BIOS, but one that can flash back if need be, or RMA the CPU on a "hunch" that it is at fault.

"It worked before you broke it!"

mackbolan777, thx a lot for the answer and for the hints. 

PBO is disabled in my case - I turned on CPB (Core Performance Boost) only. I collected fatal hardware errors after several such crashes from System events

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 11 (also instead of 11 I saw 10, 7, 8 ids at this error)

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Bus/Interconnect Error
Processor APIC ID: 8

The error usually happens at the end of the benchmark. MSI Afterburner shows just 10% CPU usage, but the CPU clock is  4850-4950. This is the time when game stops loading many cores and by some reason all load goes to a single core - and boom - it crashes. Now I am trying to understand how to repeat this error not in games but in benchmarks (to make it more easy to reproduce in service). I tried to run 1-Core Cinebench R23 and 1-core Prime95 - these benchmarks work without any issues.


One thing that fixed me having that error on my 3600X was a RAM to IF speed error. Meaning I had to manually set the RAM in BIOS to reduced speed (3600 from 3733) and set the IF to half of that, meaning the IF=1800. That ended all issues and that error until late November when Windows did an update that caused the issue once more.

Now never have an error, but I have reinstalled the OS using the latest image from Microsoft's Media Creation Tool which brought me up to the 20H2 in full.

The IF is always half or less than the RAM speed. The "auto" selection in BIOS for the IF may not keep the IF stable at one speed, which can cause the crashing and errors. You can try setting the IF to half the RAM speed manually to see if it resolves the problem, not to exceed 2000 on that CPU, most can only go to 1900. Matching half the RAM speed is best and is not an OC.

"It worked before you broke it!"

mackbolan777, yep I also thought about IF - so double checked in HWInfo that I got 1800 for IF and 3600 for RAM.
Also I tried to go down - 1600 for IF and 3200 for RAM - this did not help - same errors.
Another thing I tried is to set PPT limit to 100W (I guess the default is 142W) in CPB settings - I got ~10 degrees less during benchmark but CPU anyway get this boost to 4850-4950 at the end and crashes.

I also have a clean install of Windows 10 2020H2. I am not sure if it's needed to install AMD chipset drivers or not - as I see no difference. I got crashes with and without them.


PPT I have set to "motherboard max", the CPU will only use what it needs, much like a video card and the power limit slider. I would not lock it lower. Definitely install the newest chipset drivers. But at the end of the day, if nothing is working, RMA the CPU. If the new one doesn't work, don't buy MSI and get a different brand board. Also check temps. Sudden overheat can cause a crash. PSU unstable or poor connections at the CPU header?  

"It worked before you broke it!"


I would like you to inform me what you see in this folder C:\Windows\LiveKernelReports\?

[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]

Hi Ivan,


Could you tell me what solution worked for you?
I'm experiencing the same issues with my 5950X. 
I did not overlock my set-up with the RT 6900 XT.

Errors have been shown ID 18, 30, 4, 24, 12, 2, 6, 0...



In this moment dont exist a specific solution. Only try some tips here.

Sometime work change(RMA) CPU, sometime changing GPU in other Mobo or PSU. In other case BIOS upgrade.

Please read and try in your case.

@12348766754 Look on page 68, I posted a list of the trouble shooting AMD sent me. If that doesn't fix the issue you might need to replace a part or something, it would depend on your setup.

If AMD's troubleshooting doesn't work for you please contact their tech support.

If I recall correctly I think I contacted them from this page


Adding to the list of people who have been running into these issues as well.

CPU: 5950X
Mobo: MEG X570 Unify
RAM: Crucial Ballistix DDR4-3600 (4x16GB, Micron rev.B, 16-18-18-36), currently at stock (I've tested other kits too, to be safe - doesn't make a difference)
PSU: Seasonic Focus PX-750
GPU: EVGA XC3 Ultra RTX 3070, currently at stock

I've been consistently running into issues with WHEA-Logger (ID 18) and Kernel-Power (ID 41) events pretty much since I first built my system back in December. I've already RMA'd my 5950X once, and even RMA'd my mobo with MSI to see if they could find anything. Both 5950X had the errors paired with a hard crash, both with different physical cores (12 for the first one, 14 for the second one IIRC).

I've done a lot of pretty extensive troubleshooting as well - switching out RAM, playing with BIOS settings, testing in and out of the case, etc. Nothing's worked with my current CPU. The only way I can get it to run stable is by disabling CPB, which gimps the CPU. I submitted a new warranty request with AMD.

At this point, I genuinely can't tell if it's just really bad luck or if the board I have still doesn't play well with Ryzen 5000 yet. Anyone have any thoughts? Anyone run into similar issues with this particular pairing of CPU and motherboard?


I am one of the many that though was also affected with the 5900x. 

  • x570 aorus ultra 
  • G Skillz 2x16gb Trident Z Neo 3600 C16 32GTZNC (AMD)
  • bequiet! Dark Rock Pro 4
  • Zotac 970 
  • EVGA G3 750w

Ran very cool at 35-40C.

From searching online I found my temporary fix: DISABLE CPB & P¨BO (make sure to disable in all locations) and anything that would bring the frequency above 3700mhz / voltage around 1.008, +/1 0.012v. This means my CPU seemed to always go between 0.996, 1.008, and 0.120 on Idle. 

It works, it's stable, I ran every other test on my PC and every component seems to work very well. Including the CPU until you boost it to stock settings. 

I was then writing this post as I had questions about RMA and I was conflicted, then while describing it occured to me that my mobo has 2x 12V connector for the CPU: a 4 pin and an 8 pin. I only connected the 4 pin as I did not realize you could plug a 4 pin in half the 8 pin connector 

Long story short, issue is now fixed. I have all the latest drivers, bios, and after days of troubleshooting I realized that it was underpowered which means I had to run it in an undervolted setting.

Wow what an adventure! 

Hope this may help someone else!  


Cheer mates!



That did not last long. 

I was so sure this would fix the issue. 

Unfortunately while running additional benchmarks it crashed during Borderland 3. 

Shame.... I am in the beginning of my RMA but I don't trust my seller.... they want to run tests and then charge me if they deem it works but I also contacted AMD, they acknowledged that I was suffering from whea 18. and ya it's exactly that, including some kernel p, and bluescreen view seems to confirm that as well. So they suggested a few other tests which I ran or had already ran, and then advised to send a warranty claim if I was still having problems. 

Should I wait until my 30 days with my seller so I can  go with AMD instead? or can I still go with AMD regardless of my 30 days with the seller?  
Or should I  sell it and downgrade to a 3900x? 

I am conflicted, spent quite some money on all this and I kinda regret going with the latest Ryzen after all these years with Intel. I was excited to change, but I don't think it is too late to drop the sponge yet. I still have some faith after seeing many people receiving replacements CPU that solved their issue. 

Anyway cheers mates!



Please confirm that you yoi did set in BIOS the PSU to 'typical' power instead of AUTO.

Just doing that, with everything default (but RAM forced down at 3900 in plave of 4400), fixed all of my issues!

No more crash nor error 18. Just enjoying my new config!


TECH TIP:  Look at the timings your manufacturer gave you for your RAM chips.  For good RAM those numbers are something like 3600-15-15-15-15-32-56.   Okay, now go into BIOS, and look for the  tRCDRD and set it to +1 or +2.  For example, I have some of the worlds best RAM, and it was running at 3733-14-14-13-12-28-42.   ONLY under very heavy special loads, I had errors and crashes.   So I changed  tRCDRD +2.  The errors went away. The crashes stopped.  AIDA64 and other benchmarks reported much more consistent performance metrics. Keep in mind...  The RAM modules, the motherboard and the CPU ALL SAID the timings should have been fine.  But in fact, the read timing had to be bumped up a little bit, OR I had to boost my DRAM voltage more, OR I had to reduce my system clock rate.   I think something with the combination of their LCLK PCIE and their new chiplet design... they needed an extra memory cycle and it exceeded the original spec, but they don't want to tell us WHY ARE they working with major memory manufacturers RIGHT NOW to change the chip specs ONLY for AMD?  hmmm... it's almost like they know exactly what I'm talking about, huh.


Contact the people that sold you the PC and tell them you are willing to process an RMA with AMD directly, versus through the seller/integrator.  Be prepared to open the case, pull off the heat sink, and take a picture of the CPU serial number, with enough extra details to convince them that the picture is unique and yours.   If you cannot partially disassemble the PC without voiding a warranty, then don't do it yourself.  Because you've already told the seller/builder that you're about to process the RMA.  Now, you contact AMD with the photo and ask them for a box in which you can put your old CPU for RMA.  When they tell you to use toilet paper and hopium to wrap up the chip... You should debate with them ..... The best way to protect the CPU from pin damage in transit for RMA.  Tell them you REALLY don't want to take full legal responsibility for any damage that happens.... and you refuse to fabricate your own container, because you're not a professional package designer, and it is your belief that a judge in the court of jurisdiction would not release you from liability unless you use a pre-made shipping container.  I mean, there's a good reason that CPU trays are a very specific shape of plastic .... down to the millimeter.  IF a customer attempted to make their own packaging, they could refuse to honor your RMA, "due to customer damages".  So then eventually, they will send you an empty box with a pre-built shipping container... ORRRRR....   you fill in the blank and enjoy.


Tried both the ram read tweak and the typical setting for the PSU. Still same issues. 


Going back to disabling cpb & pbo so at least it works... Like a 3900x...

#1 Reseat RAM modules and CPU to make sure bus is clean. Only do this yourself if you're really careful and good with tiny tiny little pins that can bend and thermal paste that needs re-applied, and all that.  Plenty of youtube videos.

#2 reseat the video card, and make sure that if you can, the pwoer lines from PSU to video are on separate cables/rails (just spread out the love)

Verify your power supply is not some crappy 500 watt junker. IF you have a buddy with a spare PSU, maybe put it in there for a day or two. 

Ensure memory is set to 'Gear Down Mode' Enabled. 

CPU and SOC LLC auto

Consider manually setting VSOC, VDDG IO and VDDP. They all matter. We all underestimated the right numbers, I think.

In the PBO Curve optimizer, you may actually have to set all cores to +15 or +20, to get stability. Not all the CPUs were that great in batch 1 and 2.  And your Motherboard might not be using LLC the same way as others.

The following is not for all RAM modules. Need to research what you've got to get your exact numbers. Ryzen DRAM calc and Taiphoon Burner get close, but still may not be perfect.

1.55 RAM voltage
1.1275 CLDO VDDP

14 CAS Latency
15 Read Row Column Delay
8 Write Row Column Delay
13 Row Precharge Delay
12 Cas Write Latency
305 TRFC
32 tFAW
6 TrrdS
9 TrrdL
16 Twr
4 TwtrS
10 TwtrL
1 TCke
10 Trtp
11 Trdwr


@ViciousDelicious on page 68 I posted all the first level troubleshooting I got when I contacted AMD, they'll probably ask you to do that if you start the RMA process. 

I'd already done most of it except changing the PSU idle current setting to Typical.

This fixed it for me, I still run DOCP and all MOBO settings default.

However this setting shouldn't need to be run, I suspect it's my PSU's fault as it's from 2012 before the new low power specs from Haswell that year. But the PSU manufacturer said they were supported and worked fine for many years. Chips use even less power these days, PSU's often don't advertise the minimum amp spec of the 12v rail if you can get a 0 amp spec you'd be fine. I calculated mine to probably handle as low as 5 or 6 watts and typical idle control forces this to 7w. Although If I recall correctly I think I saw my system often get down to 3w. Auto on the mobo it supposed to detect what modes your PSU can handle, so is it the MOBO's fault?

Anyway for you it could be the MOBO, high speed ram, CPU or PSU at fault. Change some settings swap out any part and the issue might go away. However there's not enough data but seems strange that people that swap out other parts had no success and those that swapped out CPU did, You'd expect to see reports of both.

My plan when I get enough spare time and money is to swap out my PSU to one with a 12v 0a min rail and see if It runs fine on the default setting for PSU idle control. Otherwise I'll swap the CPU out with the store, I only need a receipt and they'll exchange with a new one over the counter. I could of done so already, However I don't want to do that unless I'm 100% sure.


Tommorow replace my PSU, this is old ANTEC 1000w platinum but work fine with 5600x. The new PSU is a Bequiet Dark Power 12 Pro 1200w and have 2 MOBO for test, Asrock Taichi X570 y Asrock Taichi X570 Razer Edition. If the system is not come stable maybe rollback to intel

Had the same issue with my PC. I bough it in august 2020 with a Ryzen 3800X and a motherboard GIGABYTE B550M S2H and it work fine until march when the whea logger 18 error first occur. i have never overclock the PC or change the BIOS settings before the first crash.

I looked to find a solution on the internet and i tried lots of things to solve this error, but none of this changes worked for me :

  • check the processor fan and the processor temperature (all good)
  • check the memory (no error)
  • update all drivers
  • update the BIOS
  • reinstall Windows 10
  • roll back to a previous version of Windows 10
  • disable global c-state control and precision boost overdrive
  • set power supply idle control to "typical"
  • try an external PSU
  • try lots of differents settings with CPU voltage (CPU Vcore, memory voltage...)

With some voltage settings, I got temporary stabilities (several days, max 1 week), but the error returned each time i started to think it was ok.

Finally, the only solution that work for me is to change the CPU. I have a new Ryzen 3800x and my PC is ok now.

@TrapoSAMA  Nice let us know how you go.

I couldn't find with a brief look the min specs for that PSU but it said it supports C6/C7 states, that were released with Haswell, which go down to 0.05A which is 10 times lower than my current PSU. Although my PSU never had issues with Haswell but I don't think Haswell was efficient enough to drop that low. BTW I upgraded from Haswell

I'm looking at "SilverStone SX1000 80PLUS Platinum Fully Modular SFX-L Power Supply" because it supports 12V 0A but it might be overkill. You'd think if is was the PSU there'd be a specification you can check or something. However my PSU was released just before Haswell, Cooler Master only after the fact said it should work, so I do suspect it's potentially an issue but not completely sure. I just can't find good data, most vendors all list completely different specs.



My PSU is from 2013, work fine with i7-3930 and Xeon, ryzen 5600x too, but with 5800x dont. And 5800x work fine in other system mobo/psu. 5900x same history, i hope so today test the new PSU

@TrapoSAMA Good luck


Good luck.  


Once again, UPDATE THE BIOS because it changes the voltages. IF you haven't checked, here they are:

1.1275 CLDO VDDP

Oh I forgot to mention.  There is a stamp on the original 5900x CPU that created a raised portion on the IHS on the CPU.  Unless I felt like using sand paper (I didnt') there was no good way to ensure thermal paste and proper cooler alignment.  Imagine a bump on the CPU EXACTLY where you're supposed to have a flat surface that marries the cooler to the CPU.... That's bad.  Okay, that alone was enough of a reason to exchange via RMA.  Add to that the CPUs were not regulating their voltage well under load TRANSITIONS, and I knew something was wrong.  Finally, I saw some people disable CBP and/or PBO, or lock in their TDP EDC numbers lower than normal for their hardware... And I'm not about to set my max TDP/EDC to lower than my capabilities to compensate for whatever happened. The new chip worked fine, though.  And it didn't have that bump.



PSU was replace but still have random reboot, trying to adjust some voltage, if not next step replace mobo.


replace the god **bleep** CPU...

i follow this thread since literally months and every single day i get my notification emails about people STILL playing the die hard fanboy that does not accept that the CPU IS THE PROBLEM...

Oh your brand new 5900X does not work, reboot, is unstable?

JuSt Do ThIs AnD tHaT iN tHe BiOs! 

A new CPU does not work with stock settings?

there is still (said that before) NOTHING to do.

Typical Current idle, disable cores or boost (**bleep**?!) run your ram at 2133... i don't understand these delusional insanely dumb options.

stop replacing powersupplies and mainboards.. replace the more than obviously broken CPU.


Is not always a CPU problem. The 5800x previous CPU in my system have random reboot, but in other system work perfectly. 5600x work perfectly in my system and others.

If not work the best option is not replace CPU again and again, sometimes are mobo or GPU or a mix, is too much time. Go back to intel and done

Anyway, i try with RMA maybe.


I agree with you.

There is something that causes or problems in not necessarily the CPU, mainboard or PSU.

I passed WHEA problems with a RX 5700XT. Mudei for nVidia and isso parou. It was as R7 3700X. This is with the R9 5900X CPU and continues to do so well.

[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]

Hey all, just want to share my experience,


I have a 5900x with random reboots (not idle or stressed) and no bluescreen with PBO off,

it will reboot on an average of once a day.

after months of debugging I RMAed it just last week.


The point is I am currently using a placeholder 5600x and it hasn't rebooted for 2 weeks with the same daily usage.


@zkkzkk32312 thanks for the info. Others have reported similar and it's likely your RMA will fix the issue. Let us know how you go.

However is the issue just silicon lottery or is the BIOS not tuned for all the CPUs out there or is it something else?

It could be a lot of different things for all of us, Mine could be an old PSU but I might be the only one with that cause.

I have a feeling there could be an issue AMD knows about but I haven't heard anything concrete to confirm and that issue will prolly have a BIOS update in a month.


So I'm getting the constant bsod restarts on my pc with 5900x. I would say it's my cpu but this is what I've been through. 

Specs are 5900x, 1000w gold psu, sabrent 4.0 Gen plus 1tb, 6900 xt(started with 3080), 360 aio cooling and 3600mhz royale and asus b550-f mb

So this is how everything started for me. 

After a windows update to something kb1330 my nvme disappeared(sabrent Gen 4). So I contacted sabrent and did rma and they sent me another one. After installing this new nvme I started crashing little after few games then after it became so constant bsod restarts(whea_uncorrectable_error and all that good stuff) so I did test with occt and got errors on cpu then I did memtest and got error on rams. Swapped out rams to test swapped out gpu to test and swapped power supply to test. Running out of ideas I decided to swap my new nvme that came in from rma with my old 970 evo 500gb and all the crashes were gone I did occt no cpu error I did memtest and no ram errors. And this is with the same specs I had errors with but with my old nvme. 


So again I went ahead and rma my sabrent again and went ahead and bought a Samsung 980 pro. 


Just received it and installed with fresh window and everything and now I'm having bsod and crashes again. 


Right now I'm ok with pc on pbo off in bios but I'm not utilizing my components at its maximum potential which sucks.


I would say it's the cpu but why didn't it have any problems when I was on the 970 evo nvme?


There has to be something else cause with the 970 evo in I was able to leave pbo on leave bios as is with docp or xmp on.


Sorry to bring this topic up but I am getting random reboots with my 3950x. When i disabled cpb the PC was so unstable, whenever I opened my 3d modeling program and render, the Pc would randomly reboot. When i re enabled it, it would work but also quite unstable. Over all, the pc may randomly reboot under low load, sometimes i would game for hours with no problems. 

is there a fix?


@NewAMDGuy check page 68, I listed AMD's troubleshooting they gave me. You might also want to contact AMD yourself.


@K0NG95 you know you can unsubscribe right?

Some of us like to test things rather than guess and assume.

@TrapoSAMA thanks for the infomation, I wonder if it's because the PSU you swapped didn't support a 12V 0A rail. I don't think it'd be the MOBO, I haven't heard of that fixing it yet, maybe a BIOS update would be more likely to fix it. However if you do replace it let us know how you go.

If swapping out my PSU doesn't work I'll be going back to AMD to ask why.



I asking to AMD, ticket is open now. But after change PSU for the best bequiet digital PSU and persist reboot, then the previous PSU is fine. waiting por change mobo and test