Showing results for 
Search instead for 
Did you mean: 


Adept II

Ryzen 5900x: System constantly crashing/restarting WHEA-Logger ID 18 and critical error Kernel-Power

Mainboard: MSI x570 Unify
Mainboard-BIOS: 7C35vA82 (Beta version)
CPU: Ryzen 5900x
RAM: Crucial Ballistix BL2K32G36C16U4B 3600 MHz, 64GB (32GB x2)
Drive: M.2 Samsung 970 Evo+ 1TB SSD
Graphics: SAPPHIRE Nitro+ Radeon RX 5700 XT
PSU: be quiet straight power 11 750w Platinum
OS: Win 10 Pro (64bit) - all updates installed
Chipset driver: (released 2020-11-09)

I first assembled the PC with a Ryzen 3800x a week ago because it was unclear if and when I would get the Ryzen 5900x I ordered. Worked with the included AMD Prism Wrath CPU cooler for one week without any problems.

- Today I installed a Ryzen 5900x and a Scythe Fuma 2 CPU cooler.
- After 20 min the first crash/restart with the following entries in the Event Viewer: WHEA-Logger ID 18 and critical error Kernel-Power ID 41.
- Happens irregularly again and again, sometimes after minutes, sometimes longer: Windows freezes for a few seconds and then the PC reboots. Doesn't matter if load or not.
- CPU temperature between 30 and 40 °C
- Updated to BIOS and chipset driver mentioned above: Problem still exists
- XMP Profile disabled (RAM on 2600 MHz): problem still exists
- CMOS Reset: Problem still exists

Either there is a compatibility problem of something with the CPU, or the CPU is defective?
What to do? Really frustrating.

2 Solutions

Im having a similar issue, x570 aorus and 5600x. Have same errors on windows. 

Disable CBP and PBO and run it at default settings (3.7 ghz and xmp on). That works for me. 

View solution in original post

I got a new angle on this. So deactivating PBO and CBS definetely works, PC was running stable for a week now. But you'll loose performance.

So I wrote to the MSI support and the AMD support.

MSI suggested to try increasing the DRAM Voltage by 0.05 V, which I did. System seems to be stable, no crashes so far - neither in idle or while gaming.

View solution in original post

947 Replies

It is a scandal.


"i will just sell it and go back to Intel"

Unfortunately, there is no Intel's alternative to 5900x\5950x.
11900k is gonna be 8 cores only... 


Update #2 (previous update here):

AMD has apparently agreed that I've exhausted all debugging options available to me and provides for an RMA under warranty. I'll be shipping the CPU back to them in tomorrow - hopefully I'll have a working CPU in a couple weeks. I'll post back the results of the new CPU when it arrives!


wait... for RMA they want you to send in the CPU then wait weeks for a new one?  Screw that, I'm going to dump this 5900x to some poor sucker locally on facebook and go intel.  I was really excited to be back on a powerful AMD machine but this thing is fragile and crashes randomly.  Never under full load, which is what's so **bleep** weird.  Get your **bleep** together AMD, you just lost another customer. 

@zukmeister  Unfortunately so. I still have a 3700X that I can use in its place for now, so it doesn't bother me too much - but if I were in a situation where I didn't have other PC components to use (e.g. if I were building a PC for the first time), this would definitely be a bad experience.

If this were any other PC component, I would just return it to the store that I bought it from - but since the store sold out of 5900X's within a few minutes on the day that I bought mine, and they have no idea when they'll get more, they wouldn't be able to offer me an exchange anyway.

The whole situation sucks. ¯\_(ツ)_/¯


I suggest exploring threads from more sources than here. There's a few simple things in BIOS besides the newest out for most boards that cure the low power crash problem on many 5000 series CPU's. Like set your SOC voltage to 1.10v, default is 1.2 or higher. There's c-state adjustments that can stop it, not using XMP/DOCP settings can help too. RMA usually isn't the fix at all for the low power crash problem. But you both are bent on going down the RMA path or selling it to some guy on Facebook (who will do the adjustments and have a good CPU), so I won't waste my time trying to help. 

I do agree a degree in computer science should not be a requirement to own an AMD CPU or GPU. Nor should one need to hunt down info about these things for days/weeks, wait for BIOS updates, etc. It all should be consistently working not failing. Good luck!

"It worked before you broke it!"

That's bs.

there is no "new" Bios/Agesa.

the SOC Voltage never exceeds 1.15V (at it's absolute max stable 1:1:1 Clock)
Stock is 1.1V

All your "tips and tricks" like crippling your performance, disabling stuff that is supposed to run etc. are not a solution in the first place.. and second that does not fix anything at all.

you wasted your time with trying to defend the same old problem that can not be fixed by the user in 100% of all cases with posts and "ideas" that the same fanboys on reddit took over here.

it's AMDs fault, they are the only one who can fix it. it seems to be a Hardware issue and there is NO SOLUTION.


I'm using the new BIOS AGESA from AsRock 2/5/21, I got the numbers out of order. SOC on many boards are over 1.1 for the 5000 series. 1:1:1 is the memory to fabric ratio, not he SOC voltage or anything to do with that. As far as "fanboys" or whatever, look at  my results. 

There is a "fix" for most of this non-sense and with 22 years experience selling and building mostly AMD PC's, passing the Microsoft software/hardware certification tests, I have enough knowledge to go beyond Redditt. Besides, that is a decent source for info if you know where to look. There's an AMD area, and one for nearly every part or board manufacturer, along with Discord's to various tech related or manufacturer direct support, that you're missing out. 

Of course not all  case will be correctable, most can be. Decent resultsDecent resultsTemps, all core OC at 4700Temps, all core OC at 4700Custom timingsCustom timings3 times a winner3 times a winner

"It worked before you broke it!"

exactly what i said.

the SOC voltage does NOT reach 1.2V. and it can not since it's governed by the CPU which limits it to 1.15V at stock settings.

you have a SOC Voltage of 1.15v on average. and it can not touch 1.2V (even if it's going to 1.19)

and your "fixes" are nothing bearable for a customer and indicate a hardware defect.

telling someone to only drive 40 km/h and not going above 4000 RPM in their brand new car is not a fix.. it's a bandaid fix until you get a functional car.

not being able to run a CPU completely stock without even visiting the bios is in fact an issue that shows that something is wrong with the product.

my failure rate of Zen 3 CPUs is at the moment 100%.

i have three Zen 3 Chips and all of them are not behaving normally.
5800X = Cache hierarchy reboots
5900X = Cache hierarchy errors (RMA)
RMA replacement 5900X = Unstable at stock speeds in Cinebench and other "Stress" tests.

we don't need a discussion about crippling performance with disabling XMP, Core Boost or even just disabling anything in the bios.

AMD has to fix it, refund the customers with broken CPUs and at least having a official post where they explain that they are known of the issue and they will fix the problem for every single existing CPU on the Market.
anything is completely unacceptable and needs no further discussion.


I feel for you. The WHEA problem is related to n variants. Some cases are the CPU, others the VGA, memory, source, cables or drivers. It sucks to do the identification. For that, just patience.

After 2 months with headaches caused by problems with the VGA RX 5700XT, I decided on two well-thought-out days to go to nVIDIA with the ASUS ROG STRIX RTX 3070. I have no regrets. It was Plug n 'Play! Plugged in, installed drivers, didn't even need to configure the drivers, played. That simple.

I will not return to AMD on VGAs until it improves design and drivers. I do not indicate for ANY VGAs of architectures derived from NAVI (v.1, v.2 and v.3).

I removed the RX 5700XT, put the RTX 3070 on and all my problems are over.

I want God to direct friends where the problem really is and that they be resolved as soon as possible.

[ AMD Ryzen 7 5700X (step B2) | CM MASTERLIQUID PL360 FLUX | MSI MPG B550 GAMING EDGE WIFI - 7C91v1G | 32GB DDR4 3600MHz XPG SPECTRIX | MSI GeForce RTX 4060 GAMING X 8G 8GB GDDR6 ]


I'm using all the same hardware besides the motherboard and CPU in the new Intel 10900k, guess what it all works perfectly.
The constant hard reboots an WHEA errors I was getting with the now returned 5900x system was a joke, it was run at stock, like you said you can't gimp a car just to say "look its workings" anymore then you can with a cpu running defaults.

Now @mackbolan777 not to point out you're tooting your own horn, but if you've sold "mostly AMD systems" over 22 years you've done your customers a huge disservice, there was a time you should never of touched a AMD CPU due to Intel being more value for the money with greater performance, it wasn't until Ryzen 2 (while Ryzen 1 was a good comeback) you should of even considered AMD again.
I'm impressed with what AMD are doing, currently there is something seriously wrong with these CPU, turning off key DEFAULT features are not a fix.
Look we're all in the same boat, but you trying to make out you're something better than reddit is stupid, I post on reddit, here's my credentials:
I'm Apple Certified (word for Apple themselves), started in the Umax clone days, full degree in electronics, started board level repairs on C64's at 15, I hold  MCSE, CISICO and REDHAT certifications, work in many different Apple/PC service centres along with data recovery, sold what was good for the customer, again there was a time you couldn't recommend AMD, they had nothing to match the Q6600 builds.
I personally had a Athlon 64 X2 4800+, that was my last AMD machine, it was a beast.

What I am trying to point out don't through your weight around by posting what you may know, using it to try and prove everyone else is stupider than you and don't know what they are doing.

This downtime AMD is causing for some costs them real money, or downtime for their work, 56 pages of the same problem posted by many different people does indicate a problem, whether it's CPU hardware or bios, (motherboards are ruled out due to all of use have different brands/types).
Glad yours is working for you, but many aren't like myself, I can't afford the downtime waiting for a "maybe" AMD work out a fix in the near future, Intel for myself has been rock solid for many years, both time using AMD (Had a 3900x on launch) have worked out buggy, not bad, but unreliable.

Just tired of seeing people blaming the end users when it's clearly not their faults.

Currently waiting for my replacement CPU to get to me. Supposedly it has been shipped. Checking back in on this forum after a few weeks and it is saddening to see that people are still struggling with these CPUs and even RMA one's as well. This doesn't give me much hope that my computer will be stable with a replacement CPU. AMD really needs to step up and publicly address the issues with this line of processors and give all its customers some answers about what they are going to do about it.

5900x | Asus TUF X570-PRO | 32GB GSkill DDR4 | EVGA 3090 FTW


Fitting name btw. You respond like a troll and talking about "tooting your own horn", yours is super "tooted" with dinosaur degrees. This isn't an Apple forum and if you want to go there, Apple first stole the idea from the original inventor and gave him nothing in return. The original maker of Macintosh wanted to give the idea away for free, like Linux. Apple also used and now went back to using proprietary parts, so you can only get them from Apple or eBay for older stuff. Apple had plenty of problems as well, however with not many people able to afford one for the longest of times, their customer base was a million time smaller than Intel, AMD, or IBM. 

You say I did a disservice to my customers at a time when my customers couldn't afford an Intel and all of my new builds were in the AM3/AM3+ era where AMD did have something to compete against Intel with. A family member, also US Government contractor, had me build 3 AMD machines for "back up", they wound up using all 3 and closeting their Intel counterparts because they ran so well for 1/4 the cost of a Dell. They remained in service for 6 years until they were ready to sell the business. Also in this time frame I sold roughly 200 or so units with FX 6350's, 8150's, 8350's, and 8370's. 2 came back out of all, from the same customer that insisted on using a poor model MSI board simply because it had a serial port connection. I couldn't change his mind and he ran a commercial real-estate firm and a commercial farm with these. I did manage to get his to run properly in the end, with one board needing an RMA.

The Q6600 was before those and my FX 8150 beat the pants off my Q6600 when I built that in ~2009 and used it until 2018. I built an 8700K with an Nvidia MSI Duke 1080i and my both my 3600X and current 5600X build (same board) run total circles around that. Benchmarks have mine beating the latest Intel's until the multicore tests where some Intel's have a core advantage. AMD has a clear advantage, however, as I've said before I admit they are not for a normal user to slap together at this time.

With all this education, you never learned to spell either. You have more spelling mistakes than Sydney Powell. I'm not " through your weight around " or trying to prove anyone is stupid. In that sentence you imply that I am stupid as well. You are a troll. Accept that and move on to your Apple, Intel, whatever makes you happy.

FYI, people are on here for help, so that means they do not know it all. Some do not know what they are doing, like one posting to set your vcore to 1.375v and call it a day. That's beyond any Ryzen's FIT and one should not run at FIT 24/7 or over it, ever. Mine is set well below the FIT of 1.31v. My recommendations are for those that want to continue to push their CPU's or find basic stability rather than simply go run to Intel, spend ~$800-1000 to switch, if they reuse some parts and to have less performance.

The "key" defaults you refer to are things like PBO, which are flawed and the "curve optimizer" is a band aid for uneven core quality. Using the CPU's out of box defaults there shouldn't be any issue as there wasn't with my 5600X. They come with simple CPB enabled which gives the user the max advertised box speed, although AMD says not all will hit that exact number. Intel has the same language. 

The end user should never need to enable a thing that voids the warranty to attain the box advertised speed. I've never said to disable a regular out of box default unless the OP has done so already or is really bent on fixing the problem. Certain BIOS settings can eliminate the low power shutdown issue, not 100% of the time but those who are willing to try it might not need an RMA. With PBO the chip runs hotter, albeit slightly less power use, I have found it not worth my time on Zen 3. My results are proof that my concept works, you can look back at those results and compare your Intel to that.

56 pages of the same thing means there's a problem? Read all the posts, not everyone is posting the exact same thing, in fact they really ought to go by forum rules and make a new post. Easier to find and less confusing. This thread has nearly every CPU in it and a lot of off topic stuff. If you're worried about AMD's profit to loss ratio and downtime, etc. you should contact the AMD corporate office.

I haven't seen posts blaming end users for any AMD issues. If one builds their own PC and they set something wrong or whatever, corrections may be suggested. Most asking questions on here want to keep their product and then there the few that want to troll, degrade, insult, those that volunteer their free time to help others. Have a super Intel day!

"It worked before you broke it!"

Can we please remove the 'solved' tag from this thread as this is a very much ongoing issue for way too many Ryzen 9 owners. 


It is solved... Do RMA and hope the new one is ok 


Go Intel... 

GG ...





Also just so I can contribute to making this issue known ( problem has been discribed already and solved xD )

Asus Rog Strix x570 E 

5900x BG 2046SUS

Upon building first time flashed new bios 3201 then after 3 days went stupid with restarts and bsods.

While reinstalling windows noticed new version beta and flashed that.

Worked 2 days then came restarts and bsods.

While troubleshooting came other beta version flashed that one.

Worked 2 hours then went bye bye again.

At this point i new something was off with the currents and suspected the PSU...

Nope ...

Changed everything except MB and CPU. all other components work on other builds with no problems whatsoever.

Kept trying settings in bios .

Sometimes it worked sometimes no.. wouldn't even post or would post and restart.

After trying every bios so far beta and not, the latest beeing 3405 I think, it always works 2 to 4 days with every bios update then starts going crazy.  

I can confirm it starts happening when idling for me too or after a shut down and boot up on the next day mostly, rarely under stress but even then it happens. 

I am so tired after all this... So I  have two solutions 

1. Monday 22/02/2021 I will start the RMA. If the new one works then ok if not idc anymore...

2. I don't want to wait for nothing at this point... Will also order Intel motherboard and CPU equivalents and that's that...

I read all the pages hear btw... So yeah I had tried most of the things people suggested  and the ones I hadn't I tried last 3 days...

Anyway the point of my posting is so that people with this CPU know that it's a common thing ( obviously...) and act accordingly...






Have the same issue with MAG B550M BAZOOKA and 5600x. Yestarday get new cpu from AMD after RMA, but with this new cpu still have the same problem. Rebooting even on idle if RAM runs more than 2133MHz. So two variants here: motherboard is bad, or I got again defective CPU


Hi there,

Another one bites the dust.

System specs

CPU - Ryzen 9 5900x (PN: 100-000000061)
Motherboard - Gigabyte B550 Aorus Master (Rev.1.0, Bios: F13c)
Ram - 2*16GB DDR4@3600MHz CL16 Crucial (PN: BL16G36C16U4R.M8FB1)
Cooler - Noctua NH-D15 Chromax.Black
GPU - Sapphire AMD Radeon RX 5600 XT
PSU - Corsair 550 Gold

Windows 10 PRO 64-bit (Build 19042)

Fresh new install, latest drivers. latest bios.

Bios settings:

  • activated XMP profile for DDR4@3600
  • activated virtualization
  • everything else is on default/auto

Used for almost 2 weeks now, last WHEA was 1 day ago:

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 16

Issue manifest itself when in idle.

Tested with:

cinebench r20 - 8509
cinebench r23 - 21611
aida64 - all benchmarks
memtest86 v9 pro

- found no issues.

Using this computer for remote work + VM's and casual gaming.

Started the RMA with AMD, I really hope this will clear the issue!


Good luck with the new one xD 

I don't mean to be irritating but this has gotten ridiculous...

People RMA and get the same broken thing back... Just different piece...

I am curious how will AMD handle this? Hide it and hope not too many are diffective? Announce it?

Meh... Wtv... 




Day 4 with Intel.

no crashes, no reboots. 100% Stable System. 
Overclocked to 5 GHz, saved 50% money and have the same performance.

Just thought I'd post an update on my situation.


I've sent my 5900x to AMD for a replacement, and while I'm waiting I thought it wouldn't hurt to try my 1600x in my MEG x570 Unify, even though that CPU is not officially supported by that motherboard. So far it has worked very well! It sure beats having to reinstall my old motherboard or crashing after 10 minutes of videoconferencing. I'll post an update on how the replacement 5900x works. Fingers crossed...

Guys, if you have the pc crashes - please post the CPU's batch number here.

My CPU was built in 2020 (BG 2046SUS) - I wonder if we still have the same issues with CPUs from 2021



5900x BG 2046SUS is mine too

@K0NG95Same here, even got a 5.3Ghz overclock out of it.
Slammed the CPU for a whole day with heavy stress tests and benchmarks.

Leave it on overnight Chrome running with at least 10 tabs, Thunderbird in the background, come out in the morning PC is exactly how I left it.

Something I couldn't do with the 5900x..
Sad really, seems like Hardware Unboxed is trying to call BS on the failure rates of these CPU's.


So yeah.. after a month the RMA completed. The CPU was found deffective and was replaced. But now I am just in dread to use the new one. I mean I ve been using the 10900k for the past month and I don't even want to try the 5900x. It's just sitting there on my shelf.


Well, like I said before among many others.

RMA or go Intel.


I am running into same issue. The same config with 3900x working rock solid.

5900x fails with same issue whenever Windows goes into lock screen/some sort of state.


When I was on AGESA ComboAm4v2PI Patch C, I wasn't getting any errors.

After upgrading to AGESA, I would get the dreaded WHEA-Logger 18 error/BSOD after about 15mins of gaming.

**However doing as you said, setting the offset of 0.05V in the BIOS has so far solved it for me on the newer BIOS.

My specs are:

Ryzen 7 5800x


Gigabyte RX 6800XT 

Corsair 3000mhz 2X16GB DDR4 CL16 RAM XMP Profile




The same MB, R9 5900x,Trident Z Neo 2x32GB 3600Mhz. Similar isues : 

AGESA Patch C:

   A lot of WHEA19 during AIDA mem/cache test at xmp (3600-18-22-22-22-42), no WHEA18/bsod for about 2 months.

   Fully stable at 3200 16-20-20-20-38


   xmp (3600-18-22-22-22-42) playing ACValhalla WHEA18 every 5..10 min

   xmp (3200-18-22-22-22-42) playing ACValhalla for 4-5 hours WHEA18 again ;(

   never seen WHEA19



I get BSOD about memory management. 


I try with 2 sitck at default and change for the other two and error is repeated. WHEA error is not i all cases. Sometimes systems only hangup, keyboard and mouse is led off, screen black. Need reboot to recover.

Next time i try to check 5600XT in other PC, if work one component good and more posibilites to change mainboard from X570 to B550, is a lot more stable



Can you please see if you have a Kernel-Power Event ID 41 10-20 seconds BEFORE the WHEA?

I think we are all looking at the wrong error.  The first Critical is the Kernel-Power is the culprit.


I have been straggling for 2 days now with BSOD's, tried almost everything recommended in forums. Nothing helped except what you said... I disabled CPB, XMP is on and I haven't had any far... and I am saying so far because, for a week I didn't have any crashes with CPB on either... Now performance is lowered of course.

Update 20/03/2021 11:30 I now tried CBP on, XMP on, changed RAM voltage from 1.36v to 1.4v. Pc boots normally, no issues so far....

Update 20/03/2021 12:06 Pc crashed again right after testing cinebench. I will disable CBP again. I already RMA, waiting for answer...... CBP disabled is not acceptable for a costly CPU, i miss my 3700x stability right now...

After like 2 Weeks without any error after the installation the érror is back. I thought it was fixed but yeah it wasnt. Im so pissed right now. its alwas the same **bleep**... Can you please say what this error means or is? DMP Data is here. 



I solved mine differently, there's probably different causes.

I emailed AMD and they advised to set Power Supply Idle Control in the BIOS, from Auto to Typical Current Idle.

I did this and I've had no issues for 6 days.

see for more info.

I hope this helps some people with older PSUs



Good point about PSU and that parameter. I have a old but good PSU. that parameter are in Typical Current Idle. The system for now are stable but cant play for now. Only work use, maybe GPU mobo/cpu dont work  well for a unknown reason.


I have the same issue with an AMD RX 5500 XT, intel i-5 9400, Gigabyte Z390 UD motherboard. Besides the Kernel-Pnp errors logged in Windows Event Viewer there is also one mentioning that AMD drivers failed to install completely, the information is as follows:

Device not started (amdkmdag)

Device PCI\VEN_1002&DEV_7340&SUBSYS_38221462&REV_C5\6&2f1654d3&0&00000008 had a problem starting.

Driver Name: oem5.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Service: amdkmdag
Lower Filters:
Upper Filters:
Problem: 0x15
Problem Status: 0x0

I have tried updating my BIOS, uninstalling some windows updates, using different versions of the AMD drivers. Nothing so far works. I was thinking of using your solution, increasing the DRAM voltage slightly. Do you think this could help? I'm not a super tech-savvy person so I thought it wise to ask for some help first. (Contacted Microsoft and AMD support, AMD never replied and Windows have been of... limited help)


I have been struggling with BSODs and tried everything, only disabling core boost helped so I RMA got the new one, now with xrp on and everything else default I have no far... kudos to AMD for the fast reply and fast replacement.


Hi Guys

Just a quick update on this.  I disabled the "Global C States" option and stability has been rock-solid since.  What I noticed using a monitoring tool is that the voltages on idle CPU cores dropped down as low as 0.944 volts (when C-States were enabled) but turning off the "C States" has raised them 1.044 volts (or thereabouts).

The instability seemed to occur only when the system returned to idle after running intensive applications and only on certain cores.  I wonder if the programmed voltages on some processors are set too low at the factory?  I also used the curve optimiser to add a positive value to the cores that threw WHEA errors and that also seemed to solve it but realistically the end user should not be needing to do this.

Luckily,  turning off the C States doesn't seem to have had much effect on idle power consumption or when loading all cores.



it seems that some CPU cores behave wrongly when in low voltage, I was having whea 18 when exiting and returning to cyberpunk, with the 3603 bios from asus this problem disappeared.

@ace50k Just curious how old your PSU is and if PSU idle control will have the same effect as C-States?

You shouldn't have to disable C-states and PSU idle control worked for me. There could be different causes but your symptoms were very similar to mine.