Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5700g crashes in games with kernel 41 error


i have a problem with my new PC i've just bult for my son, trying to solve it for a month or so but still without any success

AMD Ryzen 7 5700G BOX
Goodram Iridium Pro [IRP-3600D4V64L17S/16GDC]ddr4 3600
be quiet SYSTEM POWER 9 700W
OS win 10 pro

PC constantly crashes in games with Kernel Power 41 error (need to be rebooted or even to switch PSU off). In windows or browser it works just fine. Comes almost in every game no matter newer (Fortnite, Enlisted) or older (Company of Heroes 2). Can happen after 2 mins oor a couple of hoursf gaming. Tried everything: installed clean OS, all new or older official drivers, set latest f14e BIOS, lowered CPU power supply, switched off RAM XMP, PBO in BIOS, set core voltage manually both 1.35 or 1.4. Also checked if the stock cooler is installed properly and unplugged and plugged everything including RAM. Same issue. All temperatures are OK. Requested AMD to provide some assistance no answer so far.

Thank you for time and feedback!


18 Replies
Adept I

My first guess would be faulty power supply. Have you tried swapping out?

Adept II

you are only crashing when gaming? how long can you web browse/leave computer running?

Kernel 41 - is from improper shutdown of windows. Something is is causing the shutdown- was everything new when you bought it?



Seems like you might need to update using that driver the guy in this post used


I tried any drivers that are available


Yes, it was all new


Do you have any other errors beside kernel 41? Something like WHEA Logger. And how its crash? Does your PC going black screen and restart. or its just BSOD?

Journeyman III

sorry to threadjack, but i have the same problem. everything works great until i play a game. SOME 3DMark Stress tests (extreme ones only it seems?) will do it as well, but the gpu-z render test + prime95 blended + youtube etc. all day long. it throttles when it should. just games crash it. hard. here's my hardware:

  • AsRock Jupiter X300 w/ 120W PSU
  • Ryzen 5700g
  • 2x16GB Kingston HX432S20IB2K2/32 
  • 1TB WD SN570 nvme
  • Intel AX200 wifi/bt
  • Win10 Pro 21H2 (build 19044.1466)
  • Radeon 21.12.1

I've run a few hwinfo logs and uploaded them if anyone can decipher something from that. The last lines coincide with the crash. I would hate to RMA anything until I know what it is.   

hwinfo logs (google sheets) 


I also have the same problem. I've read several people who have it too, and we all have same processor (Ryzen 5700G).

I bought my PC one month ago, and it works just fine when I'm using it in daily work (youtube, hearing music, doing some homework). I've even stress tested my computer and it works well. The problem is whenever I'm playing some game my PC crashes ramdomly, it can be 15 minutes or 3 hours, and it seems irt doesn't matter which game is (GTA V, Left 4 Dead, Halo). The only "game" I've tried that doesn't crashes it is Minecraft.

I hope it will get fixed soon with some drivers actualization, because of all comments I've seen in many sites, there's no possible way to fix it. I really don't know what we should do, so I'll be reading what you have to say...

Adept II

The only test I can run to produce an error was with PRIME95.  If you haven't tried it, install it and run the Torture Test and leave it running while you go to sleep.  Mine took 3 hours and 3 minutes for window 3 to produce an error.  the readme suggested upwards of 24 hours.  If your BIOS is fully updated and reset to default with the same settings, I think like me you have a faulty CPU, I'm waiting for their AMD Tech support to confirm my findings.

I have a similar problem but with an AMD 5600X CPU.  For me to get my system as stable as possible, I had to set my BIOS like you did.  RAM XMP 3600 profile not used and set to full AUTO, then manually set the speed to 3600 MHz and bump up the voltage up to suggested rating.  

And to set CPU Overclock from AUTO to 3.7 GHz so in Task manager I wouldn't see any more precision boost upward of 4.6GHz.

MOBO: AsRock B550 Taichi

CPU: AMD 5600X


PS: eVGA 750 WATT Platinum.


Have you, or could you try the beta BIOS for that board available here on AsRock's site? 

I see a looooottt of boards got updates including latest AMD AGESA stuff, which just might fix all our problems.

Unfortunately, I have Jupiter X300 mini thing that wasn't important enough to get an update with the rest of the boys on Jan 17th.


So it seems there's a new BIOS update that is a possible fix
Currently my mobo hasn't yet received that update 
I have a Asrock B550m Pro4

But i have observed that in the 3D Mark time spy benchmark my system would crash at CPU test

If my memory is set beyond 2133mhz

I am using Corsair vengeance Lpx 3600mhz c18

The system would totally go to BSOD with 3600mhz, dropping it down to 3533mhz would fix the BSOD issue

Did a HCI mem test with 200% coverage with no issues found [with xmp enabled 3533mhz]


I still haven't figured out what and why is causing this issue at face value it looks like an driver issue because the system runs fine while not doing graphics intensive work, yet at the same time memory speed is also affecting the system


Reset your Bios to default and make sure it is fully updated not with a beta build. Then set memory xmp speed to the fastest listed (corsair 3600 ram when I last checked wasn't verified working on asrock, my 8x4 3600 cl 18 corsair dominator kit failed in my asrock MB550 pro). This is the kit that I got and worked and is on the listed of verified working 

Boot to windows and run memtest *extended* when you go to sleep (8 hours plus hours) and check the results in the morning, if you have zero errors there is a good chance your problem is else where...  Then stress test your CPU for up to 12 hours with a Prime95, if you have zero errors then... Reach out here for further isolation. 


Trottster I checked the "wmi host provider" process did not found anything abnormal

crenshaw1979 and to others I don't know if this is a permanent fix or not I like reset the BIOS to default did 3D Mark time spy tests [the ram defaulted at 2666mhz] and it completed the test [which previously was crashing at CPU test even at 2133mhz xmp]

Been playing games for like 2-4 days around 2-4hrs of sessions did  not see any crashes as of yet I know this isn't an extensive of a test Ill update a few weeks later

I think the RAM voltage is an issue combined with factors such as motherboard compatibility

After resetting the BIOS the default voltage for ram was 1.2v  vs 1.35v of xmp


Before you waste any more time lets verify your memory.

download memtest5 and use it to verify your RAM.  The link below will give you everything you need to verify your RAM.
Link --> Memory Testing with TestMem5 TM5 with custom configs |

First let your RAM run at the BIOS default settings (no changes, this will be the baseline test, if this fails, then your RAM is most likely the problem).

After you download and extract the program in windows right click on TM5.exe and run as admin.  If you get a few errors saying admin rights required, just say yes or continue w/ each one (4-8 times, I forgot). 

When you see TM5 load, close it, and reboot your PC.  Now when you run TM5 with ADMIN rights it will just load.  Now click on Load Config and exit, go to the bin folder in the memtest folder and load Extreme1@anta777 config file.  Memtest will just close.  Now when you execute memtest it will load w/ the most Indepth test to root out memory errors.  Let it run for an hour, if it runs for at least 1 hour with no errors, now go into your BIOS and just change one RAM setting at a time until you get errors.  I suggest first bump up the RAM to 3200 MHz, if that run clean, then bump up the voltage to 1.35.   This will be slow process but it will isolate the memory if that's the problem.  Feel free to reach out to me or anyone here who knows how to work w/ memtest5.  Good luck buddy...  AMD doesn't gurantee RAM to run at 3600MHZ and above, only 3200 MHZ.  So, let's focus for now to get your running smooth there 1st, then move up to 3600 if possible.

Journeyman III

Open task manager>processes scroll down to wmi host provider if power usage is very high scroll up to AMD client experience program and end task. Go back down to wmi, power usage should be very low. Try running a game. 

Journeyman III

I have the same problem too.



I agree with the focus on the RAM in the system.  I've never heard of the branding and I bet it is not of sufficient quality to run at 3600 MHz.  I would set it to a lower frequency (highest at 3200) and game with that for a while.  There are lots of good suggestions to determine if the RAM is at fault in this topic.  Your PSU sounds like it should fit the bill for a system without a graphics card.  I have one system running the AMD 5700G and it runs just fine with no crashes, using the CORSAIR Vengeance RGB Pro 32GB (2 x 16GB) 288-Pin PC RAM DDR4 3200. 

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
Journeyman III

Had the same problem. What helped fix it was to change the core voltage in ryzen master to 1.33125 and set the max ghz speed to 4.0. Since then no crashes, hope it helps