Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5600X, random reboots and exits from sleep


I have a Ryzen 2600 system that I have been using for more than 2 years without any issue. I wanted to upgrade it to a Ryzen 5600X.

So, I upgraded the CPU only and got the following issues immediately:

  • Random resets (no BSOD, just a small freeze and the system reboots), about once a day. It happens randomly without any discernible pattern and it is not linked to a higher CPU load (I ran benchmarks without any issue). The only diagnostic I can find in Windows are 6008 events indicating that the last system shutdown was unexpected. However, it has been 3 days since the last unexpected reboot... My PC just rebooted...
  • When I put the system in sleep or hibernation, it wakes up by itself a few minutes later, indicating in Windows diagnostics that the power button was pressed (it was not). If it is totally shutdown, it does not wakeup. This happens every time I try to put my system to sleep.


  • Motherboard: TUF B450M-PLUS GAMING, BIOS 3002 (latest), default settings
  • Memory: Corsair Vengeance LPX 16Go (2x8Go) DDR4 3000MHz C15
  • GPU: Gigabyte GeForce GTX 1050 
  • PSU: Corsair RM550x

As I only changed the CPU, I guess it can be either a compatibility issue with the rest of the system, or a defective CPU. Any idea, in particular for the second issue for which I did not see any similar issue here? I saw here similar random reboots cases that were solved by changing the CPU...

I am still able to send it back if it appears that the CPU is the cause.


Thanks in advance.

1 Solution
Adept I

Yesterday, it started to reboot in loop and not even POST... Today, I put back the original CPU and my PC starts again normally.

Case closed, it seems, the Ryzen 5600X I got really seems to be defective...

View solution in original post

11 Replies
Adept I

Yesterday, it started to reboot in loop and not even POST... Today, I put back the original CPU and my PC starts again normally.

Case closed, it seems, the Ryzen 5600X I got really seems to be defective...

i think the issue is with memory and undervoltage.

try to change the memory to only xmp and dont change other value.

dont undervolt your cpu for stability purpose.if stable than you can try undervolt 


@anyen  that's funny, you are not the only one to suggest that memory is the most likely culprit. What makes you think that if I changed only the CPU in my system and it does not work well, then the memory (that did not cause any issue during more than 2 years) must be defective?


Of course, I upgraded to the latest BIOS (as I wrote above), tried memory settings at stock and XMP optimized timings and did not undervolt in any way (I am not chasing the last % of performance, stability and power efficiency first). All settings were at default settings, the ones that should always work!


The last status was that the Ryzen 5600X did not boot anymore and would not even let me access BIOS (though, before that, it worked more or less during a week).

I reverted back to the 2600 and all symptoms disappeared. The system seems stable, and no unexpected exits from sleep now.



I have exact same problem all new stuff:

MOBO ASUS ROG Strix B550-I Mii ITX Mobo
CPU Ryzen 5 5600X Fabric Clock @1067 or @1600 doesn't matter.
RAM 2X16GB G Skill Trident Z Royal F4-3200C16-16GTRS
GPU XFX Radeon RX 570 4GB
SSD Samsung - 980 PRO 1TB PCIe 4.0 NVMe M2
AsusRyo CPU Water Cooler (CPU Temps Hit 55c max in prime 95)
PSU CORSAIR - RMx Series 850W

When I put 3200g CPU in everything else the same everything runs fine. 



@flagrant99  same problems that I got or only one of those (most likely the random reboots)?


I just returned the 5600X and will continue using the 2600 until there is another alternative at AMD (5600 non-X, cheaper and more energy-efficient?) and will watch what's happening at Intel...


Well I guess I meant same problem in that I get random reboots not related to load. Mine always show Machine Check Exception, 
Bus/Interconnect Error or Cache Hierarchy Error though. It still to me seems odd to be unstable without cpu being stressed.

I'm waiting for RMA process to get another 5600X. 


Hi, i am also using 3200g previously and now trying to swap to 5600x, same issues happens to me. The cpu is work but only run the windows 10 a while and sometime it run longer time as well.

Here is my specs:
1) gigabyte b450m s2h mobo (bios F62b)
2) thermaltake powerlite 650w psu
3) 16gb ddr4 2667mhz ram (8x2ram)
4) ryzen 5 5600x with wraith stealth cooler
5) rx5500 xt oc 4gb gpu

I wonder what make the pc restart constantly. 


Adept I

or have you update bios to latest?

Adept I

.in win powermanagement disable fast startup.

.reinstall chipset driver

.sfc /scannow

.delete all hidden driver in device manager

.try other power supply

reflash the bios.. i also upgrade from 2700x to 5800x after flash the latest bios my cpu is slow detected wait a few second to after reflash instant detect.

see event viewer all the error related to hardware




@anyen  Well, the 5600X is now on its way back and the "old" 2600 runs flawlessly...


Why should any of your suggestions have solved both of my issues?

For example, why should I BUY another PSU given that mine worked for the last 3 years, I changed for a CPU with the same TDP, the wattage is already more than enough, the voltages seem to be stable when monitoring them and reboots did not seem load-related at all?



buying new psu is not recommended but for testing if you have other pc you can try that

one more  asus bug...since you are using asus you use hwinfo or aida64? the wmi trouble

it make my chasis fan to stop and if you have aisuite...uninstall recommended

my other pc intel reboot every 10m it is the powersupply.