cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Awesomo
Journeyman III

Ryzen 5500 CPU Black Screen

Hi, 

I have recently installed a Ryzen 5 5500 in my Gigabyte ab350 gaming 3 motherboard.  The cpu fan will run for 10 seconds then turn off.  I do not get BIOS , only Black Screen. 

I have updated the bios to latest version and I also updated incrementally to avoid issues. The only update I did skip was bios version f25.  My Ryzen 2600 still works fine when installed.  

I have tried taking out one of my 8gb ram sticks and no joy.  I have also reseated both. 

I'm not sure what to do? Can anyone help with this? 

0 Likes
4 Replies

Have you watched the Diag. LEDs to see where its freezing or looping, or tried removing CMOS battery for bios reset ?

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

Thanks for your reply. I haven't watched the LEDs, not sure what you mean by that? I have removed/reset the CMOS battery but no luck. 

0 Likes
vialli100
Forerunner

You will need to install at least bios F.40 as that gives 3rd gen Ryzen support.

Read your post again and you have already updated.

Check the pins on the CPU, make sure none are bent.

  1. Update AGESA 1.0.0.2 for 3rd Gen AMD Ryzen™ CPU full support

Note:
1. If you are using Q-Flash Utility to update BIOS, make sure you have updated BIOS to F31 before F40
2. Before update BIOS to F40, you have to install EC FW Update Tool (B19.0606.1 or later version) to avoid 4DIMM DDR compatibility on 3rd Gen AMD Ryzen™ CPU

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb Corsair Vengeance 3000mhz, Samsung 970 EVO Plus 1tb NVME, Samsung 960 EVO 500gb NVME, Lian Li Galahad AIO 240mm, Seasonic X850 PSU.
0 Likes

I will check the pins and I will also try to go through the bios updates again to make sure. 

0 Likes