cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

papahomer
Adept I

Ryzen 5 3600 won't POST in existing mobo.

Starting configuration:

AMD Ryzen 3 1200 Desktop Processor
ASRock AB350 PRO4 ATX Motherboard
G.SKILL FORTIS Series 16GB (2 x 8GB) DDR4 SDRAM (PC4 19200)  Model F4-2400C15D-16GFT

Gigabyte Geforce GTX 1050 2GB GDDR5 128 Bit PCI-E Graphic Card (GV-N1050OC-2GD)

Replaced Ryzen 3 with AMD Ryzen 5 3600.

Power & lights.  All fans (including CPU) spin.  No POST.  No beep.  Does not get to BIOS.  No display.  Keyboard lights do not light.  Power cycles every 25 seconds.

I re-installed the Ryzen 3.  Updated BIOS to 5.80

Re-installed Ryzen 5.  Same result:  No POST... does not get to BIOS ...Power cycles every 25 seconds.

Unplugged and removed CMOS battery.

Same result:  No POST... does not get to BIOS ...Power cycles every 25 seconds.

I'm at a loss.  Any ideas appreciated.

22 Replies
elstaci
MVP

Re: Ryzen 5 3600 won't POST in existing mobo.

If you have the correct BIOS Version for your new Ryzen 5 and the RAM Memory is listed as being compatible in the Motherboard's QVL List with the the new Ryzen processor, then I would open a Warranty Ticket with the Retailer you purchased it from or open a AMD Warranty ticket and see if they believe it needs to be RMAed from here: https://www.amd.com/en/support/kb/warranty-information/rma-form 

Note: AMD Warranty starts once the Retailer's Warranty expires.

Can you install that processor on a different compatible Motherboard and see if it does the same thing?  If it does then that is a good indication the Processor is defective.

Also check to make sure the new processor isn't physically damaged like bent or broken CPU Pins or has some abnormal discoloration due to overheating.

Also remove all the RAM sticks EXCEPT one and see if it boots up. Also remove all hardware connected to the motherboard EXCEPT:

1-Monitor

2-GPU Card

3-PSU

4-Processor

5-Keyboard and Mouse

6-One RAM Stick

See if it boots up. Also makes it easier to find out which hardware is causing the issue.

Does the Motherboard have any Trouble LED's or Digital codes indicators when it doesn't boot up?

0 Likes
mccharle
Elite

Re: Ryzen 5 3600 won't POST in existing mobo.

Hello papahomer,

on asrock website, updating bios require attention to avoid problems.

before upgrading to bios version 5.80 can you remember the old version ?

Latest bios is 6.30 for Matisse CPU.

Also try only one stick of DRAM on A2 slot.

papahomer
Adept I

Re: Ryzen 5 3600 won't POST in existing mobo.

Many thanks elstaci .   Let me try to disconnect HDs and try one stick of RAM tonight.

0 Likes
papahomer
Adept I

Re: Ryzen 5 3600 won't POST in existing mobo.

Thanks mccharle  I Will try one stick tonight.

I had 5.0....following Asrock instructions... I updated to 5.40 (rebooted just fine with Ryzen 3).  Then I updated to 5.80 (rebooted just fine with Ryzen 3).

I'd like to try one stick. That seems very logical.

Just wondering if 5.80 is good..or if I should go further.

BTW, after the updates I had a friend supervise (another set of eyes) as I reinstalled the R5.

0 Likes
elstaci
MVP

Re: Ryzen 5 3600 won't POST in existing mobo.

One more thing about updating the BIOS on ASRock Motherboards. YOU MUST FIRST UPDATE THE MOTHERBOARD'S CHIPSET BEFORE UPDATING THE BIOS VERSION.

Go to your ASROCK Support for your motherboard and read the Notes or Comments in the far right column in the BIOS Download section.  There it instructs you on how to update the BIOS.

But since you mentioned that the Ryzen 3 worked correctly with the new BIOS then it does seem to indicate it was installed correctly.

If you still get the same results with one Stick of RAM then I would open a AMD Warranty Request and see if they believe your processor needs to be RMAed to be check or replaced.

I would update to the latest BIOS but since it is doing it on a supported BIOS Version I have a feeling that it will not make much of a difference. It should at least boot up with BIOS Version 5.80 installed.

Is your RAM listed on ASRock Support Motherboard QVL list for Matisse Processor for RAM MEMORY?

EDIT: In my previous reply I forgot to mention to keep connected your Windows 10 HDD/SSD.

0 Likes
elstaci
MVP

Re: Ryzen 5 3600 won't POST in existing mobo.

Okay went to ASRock Support for your Motherboard. The minimum BIOS version you needed for the Motherboard to recognize and boot up is version 5.80 for the Ryzen 5 3600 Processor: ASRock > AB350 Pro4 

The QVL list for RAM MEMORY for Pinnacle Processors, there isn't any for Matisse, shows some RAM close to what you have installed. The two closest are only supported on two RAM Memory slots on your motherboard: ASRock > AB350 Pro4 

papahomer
Adept I

Re: Ryzen 5 3600 won't POST in existing mobo.

@elstaci and @mccharle  ...You were both on the right track !
In the words of that famous musician "Great googly moogly".
In summary: 
One stick in A2:  No joy.
Different stick in B2:  After one power cycle, it got to BIOS.
Shows DRAM voltage 1.21 (from Auto setting).
Temp was showing as 47° C...which seemed a bit high coming from R3 1200, but that's not terrible.
The only really troubling part was when it left BIOS it didn't give me the "No Boot Device Found.  Press __ to reboot"
So what would you suggest now?  Should I put in the second stick?  Try increasing the voltage then put in the second stick?  Get new RAM? 
Not sure which list to use for R5-3600.
Looks like R5-3600 is looking for DDR4 3200 memory
Thanks!
0 Likes
elstaci
MVP

Re: Ryzen 5 3600 won't POST in existing mobo.

I believe you mentioned you were going to disconnect the other HDDs connected to your motherboard. if you disconnected all your other HDD/SSDs, reconnect them again. See if it recognizes your C: drive.

I have 5 HDDs in my computer. When I disconnected all but the Windows drive, my computer wouldn't boot up until I reconnect at least 2 other drives. It is a mystery why that occurred. It should have booted up with just the Windows HDD installed, but in my case it didn't.

I wouldn't install the second RAM stick yet until you are able to boot into Windows.  8 gbyte RAM is enough to run Windows x64 in a computer. Once you are able to enter Windows then you can try and add the second RAM Stick and see if it boots up.

Try running a Windows Installation DVD or USB, not to reinstall Windows, but to enter the Troubleshoot Menu. I would first click on repair Startup in Windows and see if that fixes the problem.

But if an error message comes up saying there was no Windows OS installed then you can also use Windows Installation to enter Command Prompt and run DISKPART and see if it shows your Windows Drive and Windows Partition.

In DISKPART, the lettering will be completely different then in Windows.

If you are unfamiliar with DISKPART you can look it up in the internet to get some basic commands to check to see if it sees your Windows HDD/SSD.

EDIT: Before using Windows Installation, Since you are able to enter BIOS once again, check to see if you see your Windows HDD connected in BIOS Settings. Make sure you have all your other HDD/SSDs connected first.

Make sure the cable to the Windows drive is connected firmly. You could have accidentally loosen the cable to the Windows HDD when you were working in the computer case.

0 Likes
papahomer
Adept I

Re: Ryzen 5 3600 won't POST in existing mobo.

It definitely does not like the second stick of ram.  With one stick it will boot into Windows just fine.  Once in Windows things look normal....processor is recognized.

Booting is slow

I'm thinking there is a compatibility issue with the memory that I have and the R5 3600 (Matisse ?).

I don't see a QPL for AB350 Pro 4 for Matisse/Zen 2.  I could go by specs and try to pick something.  I'm OK with that, but would feel better if there was something more official. 

Got any thoughts there?

Thanks again for the help elstaci

0 Likes