cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

augustobotossi
Adept III

Ryzen 5 3600 Fatal hardware error - Cache Hierarchy Error

I built this PC 22 days ago with the following new parts:

Ryzen 5 3600 w/ Thermalright AM-14 cooler

MSI B550 Gaming Edge Wifi

16GB RAM Patriot Viper 3600 CL17

Sapphire RX 5700 XT Pulse

Seasonic Core GC Gold 650W

Kingston A2000 250GB

Crucial P1 1TB

It's the second time I get the following error while gaming (2-3 hours gaming):

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 8

I am not overclocking neither the CPU or the GPU. The RAM is using the A-XMP profile 1.

The highest temperature I get while playing is 72 Celsius on the CPU. I tested the RAM use Memtest and no errors were found.

Is this a faulty CPU?

The motherboard is currently updated with the latest driver available.

44 Replies
augustobotossi
Adept III

Third time the PC restarts after the same error. I think it's time to start the RMA process.

0 Likes

Hello
Technically you are overclocking your system by using A-XMP profile for your memory. 
Memtest doesn't often stress CPU+RAM enough to spot the instability that you have later during gaming.
I suggest to run Prime95 blend for at least an hour and check if there are any rounding errors in threads logs with XMP enabled. If yes then repeat the same with XMP disabled/manually tuned memory settings.


It is still possible that your CPU or motherboard are faulty. Anyway CPU+RAM stability worth checking with Pime95 in my opinion.

Good luck

Thank you for the hints. I just finished testing, ran Prime95 Blender for one hour and 15 minutes with standard Bios settings, and the same time with A-XMP on, and no errors or reboots on both scenarios.

Should I stress it a little longer? The three times happened when I was gaming, two times with Destiny 2 and one with Assassin's Creed Origins. CPU temperature is always aroung 68-72 degrees while gaming, but GPU reached 92 degrees.  

0 Likes

I believe longer than 1h15min blend tests aren't required in your case.
If you didn't have rounding errors in Prime95 worker logs then your CPU+RAM are stable under load. 
pastedImage_1.png
There are multiple posts on internet where ppl with similar to your specs had crashes with Cache Hierarchy Errors.
The desciption hints that it's most likely CPU/Ram overclocking or faulty CPU/RAM issue. Most often it is.
But there are also user reports where changing their AMD GPU has solved problems.
I suggest resetting your BIOS settings, updating chipset drivers from AMD site,  reinstalling your graphics driver with DDU and setting pcie power management in Ryzen Balanced powerplan to "disabled" (or using "Ryzen High Perf.") to see if you'll encounter the same error during gaming. 
If crashes won't be fixed then i'd start RMA process

Thank you again.

On Sunday, I played for over an hour using PBO ON + AutoOC 200MHz and had no crashes.

Then,  used the bios/flash function to reinstall the BIOS and applied A-XMP Profile 2, and kept PBO OFF. I ran memtest for over 400% and got no errors. I also ran Realbench and no errors. I decided to undervolt my GPU (Sapphire RX 5700 XT Pulse) and ran Unigine Heaven 27 times, and no crashes also. I also ran Prime35 Blender for another 1h15min which, as you showed in the picture, didn't show any warning or errors. I didn't have time to actually play, so I will try and see.

This is a new installation, which I assembled on June 19, so all drivers are the newest (I think only the video driver had a new version released, which I did update), but if it crashes again, I will definitely try even doing a clean Windows 10 installation.

0 Likes
brownan
Journeyman III

Hi there I am having the same issue. My setup is a 3700X with an nVidia RTX 2070 Super. Also for me it seems to happen a lot less then the others on this forum. It happened once 5 days ago and again today. Event viewer shows the same error as the OP but with different APIC ID numbers.

I have run Prime95 for 1 hour and got zero errors. My BIOS and chipset drivers are already up to date. 

I just did DDU and also changed the PCIe power management for the Ryzen Balanced power plan to disabled. I'm yet to find out whether or not these will have fixed the issue or not though since it rarely occurs. One other thing to note is that it doesn't happen to me when gaming. The first time it happened my computer was locked, asleep and not in use. The second time it happened I had just woken the PC and entered my pin to unlock the computer. So maybe its somehow related to sleep or locking/unlocking the computer? I'm not really sure.

0 Likes
brownan
Journeyman III

It just happened again. Rebooted with the same error. So those fixes did not help unfortunately. Any other suggestions?

0 Likes

I am out of suggestions. If you want, more have been discussed in the thread: https://community.amd.com/message/2991171 

0 Likes
hardcoregames_
Big Boss

try xmp-2 profile

augustobotossi
Adept III

Just as an update, I got the error again, after playing for several hours. In this case, Windows Event Viewer showed two messages instead of one, with the difference being Processor APIC ID: 8 and Processor APIC ID: 14. I got the error after upgrading the BIOS with a new release, with the expectation of fixing it.

I undervolted the GPU to try to low the temperatures, which was successful in this case, but still got the same error.

I rearranged the RAM sticks this morning and left Memtest running for over six hours, all over 700% so far, and no errors.

So, after all of that, I think it might be the CPU. 

0 Likes

You've done a lot.
Basing on the log that you have posted, it points out to the CPU. Considering that you've made clean windows install, updated the chipset drivers and the bios (7C91v12), verified RAM stability under prolonged stress tests and still experiencing rare crashes in stock condition it looks like certain hardware is faulty (can be CPU or motherboard).
I found a user post having similar issue on this forum. Replacing the CPU solved it. Please check through the answers, hope it can help.
https://community.amd.com/thread/232625 

Good luck!

It is rare that a CPU fault is causal as both AMD and Intel check them close in manufacturing

more likely RAM timing could be a problem, I am aware that Ryzen is more sensitive to RAM timing than Intel is.

I did stress tested the RAM and tried running without A-XMP enabled, but got the same error.

0 Likes

I am using G,Skill Flare X which is marketed to Ryzen users, I have had no problems with it.

Most others model are not as forthcoming for compatibility

accn
Elite

You are looking in the wrong direction, a similar error often occurs among owners of amd navi gpu's. Try to temporarily replace the gpu and check if this error continues to occur.

There is a thread on Reddit where people got rid of this error by replacing gpu https://www.reddit.com/r/AMDHelp/comments/hq7jcu/cache_hierarchy_error/ 

Thank you for pointing it out. I will definitely take a look. I undervolted the GPU, it runs four degrees cooler, but I still got the same error.

0 Likes

I have exactly the same issues, but different pc specs. The only thing that matches is the combination ryzen + rx5700. Some people advise to check for updated vbios on the vendor's product page

augustobotossi
Adept III

I did that, and apparently, the version the GPU has is newer than the one I found.

0 Likes

You can also check vga bios database on techpowerup

That's where I looked, but the bios there is older than the one that came with it.

0 Likes

If you are still in your return period and can exchange the GPU, I would try a different GPU. I have seen many of these complaints across the net and many do come back Navi related.

It's pretty obvious from your testing it isn't memory and/or cpu. 

Trying another GPU will at least rule out the GPU. Just don't get the same architecture if you try another. 

If you have an old GPU at home you could throw that in to test with too. With some older GPU's though you may want to force the slot to PCIe 3.0.

Don't pass up your chance to try another GPU. 

0 Likes

I will try it. Unfortunately I don't have another, but I will see what I can do.

brownan
Journeyman III

I am also having this issue however I have a 3700X and an nVidia RTX 2070 super GPU. Although mine does not occur very often. It happened 5 days ago and then again today with the same error OP listed in event viewer albeit mine had different APIC ID's

0 Likes
joshuayoder
Journeyman III

I

I'm curious if you ever got this figured out?

When the issue occurs do you get 'Green Screen Reboot', with the Cache Hierarchy Error in Event Log?

I'm experiencing this and have been for months, off and on. The only thing similar between our builds is I have a Ryzen 3700X and an XFX RX5700 XT Thicc III edition. So Ryzen + RX5700....

I'm running 2 NVMe SSD on the PCIe 4 bus as well

Also nothing overclocked.

My issue does NOT occur if running an RX560, which is PCIe 3.0 instead of 4.0

 

0 Likes

I'm having the same issue for months, I've tried everything! I don't even know what component is faulty.

CPU: 3600X

GPU: 5700XT

MOBO: x570 i aorus pro wifi

It only happens during gaming. Never happened on idle. I have tried a lot of different stress tests but I was able to reproduce the error only once in OCCT VRAM test even though I tried at least 20-30 times.

0 Likes

I have the same problem with my system. And have not found a solution yet :(

ASRock Steel Legend B450M
AMD Ryzen 5 3600
PowerColor Radeon RX 5700 XT Red Dragon
G.Skill Ripjaws V DDR4 16GB 3200MHz (X.M.P Profile)
WD Blue SN550 NVMe SSD - 500GB
Gigabyte G750H - 750 Watt

0 Likes

I got in contact with Microsoft and they told me to turn off fast startup, and it’s worked so far

0 Likes

Dear friend!

Could you please tell me if your problem persists?

I'm having the same headache with my system.

- 1x CPU AMD Ryzen 7 3700X
- 1x Corsair Hydro Series H115i Extreme Performance Liquid CPU Cooler
- 1x Mainboard MSI MPG B550 GAMING EDGE WIFI (MS-7C91) Bios 7C91v153
- 1x Memory Corsair VENGEANCE RGB PRO DDR4 PC4-28800 (3600MHz) 16GB Kit (2 x 8GB) CL18 - CMW16GX4M2D3600C18 - Micron
- 2x Memory Corsair VENGEANCE RGB PRO DDR4 PC4-28800 (3600MHz) 8GB CL18 - CM4X8GD3600C18W2D-CN - Nanya
- 1x VGA MSI RADEON RX 5700XT GAMING X 8GB GDDR6
- 1x Power Supply Corsair RM-1000 1000 watts
- 1x SSD 970 EVO NVMe M.2 250GB (MZ-V7E250BW)
- 1x Seagate 2TB FireCuda 3.5-Inch SATA 6Gb/s 7200-RPM 64 Cache Gaming SSHD (Solid State Hybrid Drive) (ST2000DX002-2DV164) / SN: Z4Z7TAJY / FIR: CC41
- 1x Seagate 10TB BarraCuda Pro 7200RPM SATA 6GB/s 256MB Cache 3.5-Inch Internal Hard Drive (ST10000DM0004-1ZC101) / SN: ZA20VDZD / FIR: SC60
- 1x Seagate 4TB Barracuda 5900RPM SATA 6GB/s 64MB Cache 3.5-Inch Internal Hard Drive (ST4000DM000-1F2168) / SN: Z3019LBS / FIR: CC54
- 1x Seagate 3TB Barracuda 7200RPM SATA 6GB/s 64MB Cache 3.5-Inch Internal Hard Drive (ST3000DM008-2DM166) / SN: Z504753B / FIR: CC26
- 1x Seagate 3TB Barracuda 7200RPM SATA 6GB/s 64MB Cache 3.5-Inch Internal Hard Drive (ST3000DM001-1ER166) / SN: W5003QZR / FIR: CC43
- 1x Seagate 4TB Barracuda 5900RPM SATA 6GB/s 64MB Cache 3.5-Inch Internal Hard Drive (ST4000DM000-1F2168) / SN: S301MZ37 / FIR: CC54
- 1x Corsair Obsidian Series 750D Performance Full Tower Case
- 1x Mechanic Keyboard Gamer Logitech G512 CARBON (TACTILE)
- 1x Mouse Gamer Redragon King Cobra (M711-FPS)
- 1x Hori Fighting Commander 4 Ps4 016u
- 1x HECATE G2000 Bluetooth 32W RMS EDIFIER
- 1x Microfone Condensador USB FIFINE K669B
- 1x MONITOR GAMER AOC HERO 27 COMPATÍVEL G-SYNC 144HZ 1MS IPS (27G2/BK)
- 1x Nobreak TS SHARA USP 1500VA 2BS+BA BIV/115V

[ AMD Ryzen 9 5900X | XPG LEVANTE 240 | MSI MPG B550 GAMING EDGE WIFI (MS-7C91) - 7C91v16 | 32GB DDR4 3600MHz XPG SPECTRIX | EVGA GEFORCE GTX 1650 SUPER 4GB | XPG CORE REACTOR 850W | SSD 970 EVO NVMe M.2 250GB ]
0 Likes

If you regularly update your bios and have older cpus, i suggest stay away from bios that supports 5000 series. Either try the latest BETA (AGESA 1.1.9.0 ) or roll back to a version without 5000 series support.

My System: Ryzen 5 3600 @ Auto | MSI MPG x570 Gaming Plus (7C37vA9) | SAPPHIRE PULSE Radeon RX 580 8GB Lite (noDVI) | Gskill F4-3200C16D-16GFX | AOC 24G2U | Windows 10 Pro 20H2
0 Likes

The problem occurs both new and old.
I am doing some more tests to ascertain this correctly. I disabled Windows Fast Boot on Windows 10.

[ AMD Ryzen 9 5900X | XPG LEVANTE 240 | MSI MPG B550 GAMING EDGE WIFI (MS-7C91) - 7C91v16 | 32GB DDR4 3600MHz XPG SPECTRIX | EVGA GEFORCE GTX 1650 SUPER 4GB | XPG CORE REACTOR 850W | SSD 970 EVO NVMe M.2 250GB ]
0 Likes

Same issue, Event 18 Cache Hierarchy Error during gaming resulting in a green screen and immediate crash. 

R5 3600x + RX 5700. 

This may be my second 3600 RMA, the first CPU was defective, though in that case 1 core failed the short ffts on prime95.  I never wanted to be back to spending my free time hunting down phantom solutions on this forum again and creating custom views on event viewer but here we are....

0 Likes

I do get a green screen, but this may just be how Navi handles the crash

0 Likes

Just wanted to add that there is a huge reddit thread on this issue

 

https://www.reddit.com/r/AMDHelp/comments/hq7jcu/cache_hierarchy_error/

0 Likes

Come on!

 
After a lot of analysis of the web forums and similar settings if equal, I came to the conclusion that the problem, besides Dragon Center, is the Fast Boot feature of Windows 10.
 
I do not activate this feature in the BIOS, as it affects the nominal speed of my SSD which is 3500 Mbps reading and with it active it drops to 3000 Mbps or less. Most who disabled Windows 10's Fast Boot managed to have system stability. You have two days and nothing. I already played, I already restarted the system and everything is very stable.
 
I need to do more tests to certify, but I say that I am really enjoying it. I didn't have to reformat the system or install the latest driver as recommended. I have 20.11.2 and I'm doing great, thanks.
 
For those who are having problems I suggest this. No traces of errors I was having before in the system and application logs.
 

For AMD, it is well known that something needs to be done so that we can return to using the Windows Fast Boot feature.

[ AMD Ryzen 9 5900X | XPG LEVANTE 240 | MSI MPG B550 GAMING EDGE WIFI (MS-7C91) - 7C91v16 | 32GB DDR4 3600MHz XPG SPECTRIX | EVGA GEFORCE GTX 1650 SUPER 4GB | XPG CORE REACTOR 850W | SSD 970 EVO NVMe M.2 250GB ]
0 Likes

2 hours of prime 95 yielded a fatal error in the 18K test:

FATAL ERROR: Rounding was 0.4996781519, expected less than 0.4
Hardware failure detected, consult stress.txt file. 

 I'm going to re-run for the smallest FFTs and see if it fails again.  After that I'm updating the chipset driver and repeat.  Next I'll update the bios and re-run.  Finally, I'll try two of my ram sticks at a time to eliminate those. If its still failing its another 3600 RMA for me, sigh.  I'm wondering how many defective 3000 series CPUs are in the wild where people don't stress enough or just live through the crashes.

0 Likes

I have almost exactly the same specs as you - 3700X, 5700XT.

My problems only started after I bought a new 1440p 144hz monitor. I was previously using a 1440p 60hz monitor, no issues of this type at all. 

I'm also still seeing these issues with Fast Boot off, so certainly not a magic bullet.

0 Likes

Esteemed,

I'm still testing.
I acquired new memories and now everything seems more stable. I took one that was inside the mainboard's QLV. ADATA XPG - AX4U360038G17-ST60.

I'm just having problems right now with the AMD VGA driver. Before I tried to play and pow! Reboot.

It is known that there were problems with this driver since version 20.10.2 that have not yet solved this one.

[ AMD Ryzen 9 5900X | XPG LEVANTE 240 | MSI MPG B550 GAMING EDGE WIFI (MS-7C91) - 7C91v16 | 32GB DDR4 3600MHz XPG SPECTRIX | EVGA GEFORCE GTX 1650 SUPER 4GB | XPG CORE REACTOR 850W | SSD 970 EVO NVMe M.2 250GB ]
0 Likes

Friends,

I'm still testing it, but it's stable so far.
The solution was to exchange the memories.

Ahhhh!
If you have an MSI mainboard, check here for updates to an AGESA still in beta, but it seems to be more stable. Waiting for my version 1.2.0.0 to be released.

MSI X570/B550 Beta BIOS Update & Bug Status | MSI Global English Forum - Index

[ AMD Ryzen 9 5900X | XPG LEVANTE 240 | MSI MPG B550 GAMING EDGE WIFI (MS-7C91) - 7C91v16 | 32GB DDR4 3600MHz XPG SPECTRIX | EVGA GEFORCE GTX 1650 SUPER 4GB | XPG CORE REACTOR 850W | SSD 970 EVO NVMe M.2 250GB ]
0 Likes