cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

schoodrick
Journeyman III

Ryzen 5 3600 Asus TUF x470 won't boot

I'm upgrading a system with the following components:

MB:

Asus TUF X470 gaming

CPU:

Ryzen 5 3600

RAM:

G.Skills v 2x8 3200

GPU:
MSI RTX2070 super ARMOR OC

I bought the MB used. The last person who used it swore he upgraded the BIOS and it was working with a gen 3 chip... but I'm not seeing any post. everything powers up (fans, rgp. etc) but I'm not getting any video out. Tried 2 GPUs in both PCIE slots. I'm not hearing any beep codes at all. My little case speaker might not be working though as I didn't have it installed in my old build. 
I'm thinking the BIOS might not have been updated or the MB is dead somehow. Is there any way to tell if it's a BIOS issue or not other than trying to get a boot kit from AMD? 

does anyone know the behavior of a out of date BIOS on an x470 with a ryzen 5 3600 chip? is there a beep code usually or does it restart or something that would help indicate that that is the issue? 

I also tried using just one ram stick one at a time just in case that was the issue but no change.

I also tried clearing CMOS but i'm not sure if that worked at all since there was still no post and i couldn't see any change in behavior.

0 Likes