Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5 3600 APIC ID Errors

Hi, I am looking for solutions on resolving the problem that I have with my setup which I build:

CPU: Ryzen 5 3600


Graphics: AsRock RX 5500 XT 4gb Challenger OC

Memory: T-Force Extreem 16GB (8gbx2) DDR4

PSU: Enermax Revolution 750W 80 Gold Plus

Storage: Gigabyte 240gb SSD


I started to experience the issue today after disconnecting my a4tech webcam and the system reboot on its own. I encounter a WHEA logger APIC ID: 13 after the system was fully rebooted and it suddenly restarts the whole system again and gave me APIC ID: 0 and it restarted again and same WHEA logger.


I have red a lot of support forums stating that fresh OS install might help but unfortunately, I was getting the same error and the system reboots on its own, black screen and proceeds on rebooting the system and freezes the screen after I logged in to Windows 10. The temperature was 36c to 48c during at night and 44c to 56c when daylight. I am using the latest drivers from MSI and the latest BIOS before the beta version. I also did stress tests using AIDA64 for 8 hours, Prime95 for 1 hour, and Furmark for 20 minutes to see if the errors persists before I reinstall my OS however, it didn't allow me to encounter the said problems.


For this, since it is brand new and I made the purchase since last week, would it be possible for an RMA or replacement for this? I only built the unit for development and other projects that uses rOCM. Any help or comment is highly appreciated.

6 Replies
Adept I

I think its buggy motherboard bios, but not sure. I have a new system with a ryzen 5900x and a b550e from asus, and its happening to me as well, but for me is just random reboots, no mather the load. no matter the bios settings. Ram shows no errors with both kits. 

Im returning my motherboard and im waiting for the hero viii to arrive since it gets bios updates faster and test it.


I wish I can still outright warranty it but it was already lapsed last Monday and I am scared to go out due to pandemic. Yes, it happened to me 2 hours ago after unplugging my webcam after my meeting using Google Meet. After it rebooted and gets the APIC ID: 13, it rebooted twice and given me APIC ID: 0 twice. I switched on my setup and it gave me APIC ID: 12. My board's bios was downloaded from the MSI support page. It was AMD AGESA ComboAm4v2PI Patch C (version 7C95v24). I am also not overclocking my processor, ram, and graphics card since I am not using this setup for gaming. I switched on my setup an hour ago and it didn't do the same random reboots, black screen to reboot, or any freezes. Any help that may have cause the problem so that I can isolate it?


A friend of mine advised me to try changing my PSU since it was more than 5 years old and I bought the Corsair CX650m by Thursday. So far, the system didn't have any random crashes, freezes or black screen while booting which is a good sign. I even installed World of Warcraft Classic to kill sometime during the Thanksgiving. By Saturday to Sunday, I played it for more than 12 hours and didn't encounter any other issues, however, when I was shutting down the unit, I didn't expect any other issues but when it turned off, it gave me this error:

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 9

The details view of this entry contains further information.


I just red it today and I was surprised to see this error but this time, on another code number. Any help on how to fix this? I am running out of options.


First reset your BIOS to Factory default or Optimized defaults or do a CMOS CLEAR on the motherboard in case it is a BIOS setting causing the issue.

Also make sure you have the latest Non-BETA BIOS installed.

According to this Microsoft Forum concerning a similar error, the MS Person gives a few suggestions including that Over voltage the Processor can cause your error. Overheating also:


TBH, I dunno how to overclock even there are a lot of tutorials and forums online and since I am afraid to decrease the lifespan of this unit that I have built.


In addition, it has been a week now since Windows 10 2H02 November was released. I have the update applied on my unit's OS (Win10 Pro) because I need to try something else that fixes my concern and since the drivers from MSI's support page are still the same and no updated drivers. I am using this unit for playing games like WOW Classic on ultra-high settings, app and backend development for my work, and watching Netflix to relieve my stress and it didn't do any crashes, black screens, or sudden reboots. I also keep my unit locked and I only shut it down when I leave my place.


I will provide an update again after a week in case the issue persists.  Thank you for your advise BTW.

It has been 2 weeks back then and I haven't encountered any other issues. Is it safe to say that the issue disappeared after the Windows 2H02 November update? I also have the update for December applied this week and no issues so far.

In addition, I also have the latest update applied for the BIOS and chipset driver of my B550M PRO-VDH WIFI, and no issues so far. Will keep this posted just to make sure that everything is okay.

Happy Holidays and thank you for thread responses.