cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

tonekid
Journeyman III

Ryzen 5 2600x BIOS setting wont take effect

Hi all,

I wanted to disable PBO as I dont want the cpu to run at 4.0 since I dont have a great cooling system (getting over 80C while playing). The thing is that all the changes I'm doing wont take effect when logging in to Windows 10.

I use HWMonitor and Ryzen Master to check all my values, whatever change I make in the bios is not going through  Window.

I already contacted my motherboard support (Gigabyte B450M DS3H) to see what they think as well.

Any ideas?
Thanks!

0 Likes
10 Replies
misterj
Exemplar

Re: Ryzen 5 2600x BIOS setting wont take effect

tonekid, please post a screenshot of Ryzen Master (RM) - simply drag-n-drop the image into your reply.  You should be aware that you cannot OC via the BIOS and RM.  This will lead to a conflict and may explain what you are seeing.  I suggest you do a Clear CMOS using instructions in your User Manual.  That should disable PBO and set all setting to default.  Enjoy, John.

0 Likes
elstaci
MVP

Re: Ryzen 5 2600x BIOS setting wont take effect

 In Ryzen Master be sure to click on the box to reset the CPU to factory standards or Reset and then either disable or uninstall it temporarily (In case Ryzen Master is preventing BIOS from resetting).

Then reset your BIOS to factory default by either clearing CMOS (Removing the battery) or through BIOS itself. You motherboard manual should instruct you on how to do both.

0 Likes
tonekid
Journeyman III

Re: Ryzen 5 2600x BIOS setting wont take effect

Hi, first of all thanks for answering!

Regarding clearing the CMOS, I thought about that but the thing is that by default the 2600x has PBO enabled, so if I clear CMOS shouldnt that just to back default meaning PBO enabled?

Regarding RM I'm not overclocking through that, just using it to check values.

Thanks!

0 Likes
tonekid
Journeyman III

Re: Ryzen 5 2600x BIOS setting wont take effect

Hi! I just did that but no success sadly.

I reset RM to default then uninstalled. After that I cleared  cmos, entered the bios which told me the values where reset. I checked them and not all of them were reset (for example: PBO did reset but memory clock values didnt)

I disabled PBO once again, logged in to Windows, open HWMonitor and the cpu was still at 4.0.

Not sure what to try next.

Thanks again!

0 Likes
elstaci
MVP

Re: Ryzen 5 2600x BIOS setting wont take effect

I was looking at your Motherboard's BIOS settings. I didn't see any mention of PBO. But I did see something that is similar called Core Performance Boost. Try to "Disable" this function and see if the processor continues to run high.

If your BIOS does have PBO, in my opinion, it shouldn't be "enabled" by default since according to AMD Documents it would void your processor's Warranty.

Your Motherboard has new updates for both BIOS and Chip Set (03/2019). Possibly by updating these may help, especially the BIOS update: B450M DS3H (rev. 1.0) | Motherboard - GIGABYTE U.S.A. 

According to the Spec on your Processor: 2nd Gen Ryzen™ 5 2600X Desktop Processor | AMD 

0 Likes
elstaci
MVP

Re: Ryzen 5 2600x BIOS setting wont take effect

PBO is a special CPU Overclocking AMD Feature whereas Core Performance Boost, I believe, it is not an Overclocking Feature and should be safe to be "enable".

I believe you did the correct action in contacting Gigabyte Support about your BIOS issue. IF the latest BIOS version (F30 - 03/2019) does the same thing it might indicate a motherboard hardware issue.

According to AMD Bundle Processors, your Ryzen 5 2600X came with a AMD Spire CPU Cooler. This should be adequate to keep your CPU with Operating Temperature. The Maximum Operating CPU Temperature is 95C.

Make sure the CPU Cooler is installed correctly and is making good contact with the Ryzen and is tightly on it. You can always purchase a stronger 3rd party CPU Cooler. That way you don't have to worry about the CPU getting to hot.

Here is a good AMD Wraith Review of three of the Wraith: AMD Stock Coolers Tested: Wraith Prism vs. Wraith Spire vs. Wraith Stealth - TechSpot 

0 Likes
tonekid
Journeyman III

Re: Ryzen 5 2600x BIOS setting wont take effect

Thanks a lot for your answer!
PBO option is under the AMD CBS option in the bios, by default comes Enabled because of the 2600x version.

That F30 version of the bios is the one I installed in the first place.

I wanted to go stock because when trying The Division 2 which came with free with the cpu, it went up to 80C and the bios alarm went on. Is 80c normal for this cpu?

Thanks!

0 Likes
misterj
Exemplar

Re: Ryzen 5 2600x BIOS setting wont take effect

tonekid, please do not use RM for anything but observing!  When closed/rebooted all RM changes are lost.  I believe you when you say the 2600X sets PBO Enabled, but that seems like a terrible idea to me since AMD says PBO will Invalidate your Warranty.  I suggest you discuss this with them.  So, sounds like you must Disable PBO in the BIOS.  The recommended sequence is to Clear CMOS, boot and enter BIOS and Disable PBO, boot into W10 and use RM to see if PBO is Disabled.  If it is still Enabled, then open an AMD Online Support Ticket and complain to AMD and also open a ticket for your MB vendor also.  Thanks and enjoy, John.

0 Likes
tonekid
Journeyman III

Re: Ryzen 5 2600x BIOS setting wont take effect

Hey guys, thanks all for replying! I just wanted to give you an update and this maybe help people that are in the same situation:

I was finally able to fix the problem, it was the latest version of the Gigabyte BIOS (F30) I tried downgrading it to the previous one (F4) and it worked! All the changes I made worked also in Windows.

Thanks all!

0 Likes