cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

kaney51
Journeyman III

Ryzen 5 2400G nothing on screen

Hi,

I just get a ryzen 5 2400g and a MSI B450I and using the GPU inside the ryzen.

I installed windows 10 1809 then i wanted to install driver for the gpu part. I first installed the one on the DVD and after the reboot, when windows is loading, the screen stopped reciving anithing, like is going in standby. I still have sound because i can still login and shutdown (thanks alt+F4).

I rebooted in safe mode, removed the driver and i could return in normal mode.

The same tings happen with every driver i tryed on the website or even with basic windows drivers from microsoft update.

So for now i can't install any driver for the GPU ....

Please, help me

0 Likes
2 Replies
elstaci
MVP

Re: Ryzen 5 2400G nothing on screen

Here the latest AMD APU Driver from AMD Download site: AMD Ryzen™ 5 2400G Drivers & Support | AMD 

Do you have the latest BIOS version installed for your motherboard from here: Support For B450I GAMING PLUS AC | Motherboard - The world leader in motherboard design | MSI Global 

Is your RAM Memory list in the Motherboard's QVL List for Raven Ridge APUs? Support For B450I GAMING PLUS AC | Motherboard - The world leader in motherboard design | MSI Global 

Also I would update your Motheboard's CHIP Set to the latest version from here: Support For B450I GAMING PLUS AC | Motherboard - The world leader in motherboard design | MSI Global 

Updating the BIOS and CHIP Set will help make your Raven Ridge APU and RAM Memory more compatible with the motherboard.

NOTE: Are you getting any "ERROR" messages or does your Motherboard have any TROUBLE L.E.D.s lit or showing any TROUBLE DIGITAL CODES or more than one "BEEP' when the problems occurs?

0 Likes
kaney51
Journeyman III

Re: Ryzen 5 2400G nothing on screen

Hi,

My RAM is on the list and i tried every link already and i only have the standby screen when rebooting after installing the GPU driver (the AMD chip driver installs the GPU too)

I don't have any message or error or bip or anything with leds

It looks like it don't want me to use the integrated HDMI and waiting to connecting on the "GPU port" from the "new" graphic card.

0 Likes