Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 5 2400g driver issue?

Hi guys just bought a new rig for some light gaming and upgrade-ability in the future!

Ryzen 5 2400g

Gigabyte ab350m gaming 3 mobo

Corsair vengeance lpx 4gb x2 3000mhz

Sandisk 120gb SSD CiT Jet stream case and 500w psu

Seem to be having some issues with the Windows and drivers. Upon first post the Bios on the Mobo was F10 to which i upgraded to the latest F23b using the website (some problems occurred after the initial flash but after a cmos reset and battery take out it seemed fine)

Began booting a old enough copy of windows 10 (2015 ver i think) and all seemed grand, updated the chipset and audio drivers using the mobo web page and updated graphics drivers using the AMD website. However noticed that the windows update feature was not working at all for some reason no matter what I tried. Also the resolution did not automatically change and I had to change it manually which I was also suspicious about. Friends told me to reinstall windows, decided to use the most update USB flash from Microsoft's own website tool. Everything went fine and windows updater worked as normal. However, now whenever I update the chipset drivers or AMD Radeon drivers the system completely crashes with either video internal error or TDR (atikmpag.sys). This would happen consistently on every boot up as soon as I get passed the sign in screen.

Tried the following solutions:

-Launched in safe mode, deleted AMD Radeon rx Vega 11 drivers from device manager and rebooted, same thing as soon as drivers are reinstalled the system crashes

-Reinstalled windows like 10 times and used the update feature over and over again (which takes like 5 hours on it own for some reason - 80-100% takes the longest. Of course when the update finishes and inevitably installs the Vega 11 drivers the system crashes and does not boot

-Tried using snappy driver or other auto driver software (which again downloads over 15gbs of data only for it to be deleted again as I try re install windows) still upon installing of drivers the system crashes and get constant blue screen loop.

-Went back to installing my old windows system which does not have the update thing working (as mentioned above) as that is about the only version I can use to get online and post this.. now when I update the drivers using AMDs drivers online I'm still stuck at the 2 pixel resolution screen, however when I load up device manager it says: AMD Radeon rx Vega 11 Graphics

"This device cannot find enough free resources that it can use. (Code 12)

If you want to use this device, you will need to disable one of the other devices on this system"

Some extra info:

BIOS menu is set at full default, states that ram is clocked at only 2133mhz? Whenever I change anything in the ram (to profile1, 2999mhz) or force integrated graphics at 2gs nothing seems to be saved? Task manager still says ram is at 2133mhz?

TL:DR, Bought new Ryzen 5 2400g, any time drivers are updated the system crashes with video failure? Anyone else got this issue before? Should i just use the system without updates cause I'm out of options here at the moment Been at this for the past 3 full days am ready to about give up and return everything to Amazon... 

5 Replies
Big Boss

i have same problem with R5 2400G + GA-AB350N-Gaming-Wifi + 2x8G (G.Skill F4-2400C15D-16GNT)

when ever i try to install driver the Screen goes into HDMI-Power-Save-Mode

BUT - its 98% the screen - in my case the LG W2442PE

WHEN i use my AOC G2460PF it runs fine - driver is working + i have no errors

so it looks like the screendriver is broken or screen-hw cant work with HDMI 2.0

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS



PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
Adept I

Were you able to solve this?

Journeyman III

It's worthy of note, however, that I'm experimenting thi issues only with Windows. On the same machine I got a Kubuntu 18.04.2 box with AMDGPU-PRO drivers and it perfectly perform. I tried with other distro too. MX Linux is ok, Fedora is ok...

Big Boss

i managed to make it work after a fresh windows install

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS