Showing results for 
Search instead for 
Did you mean: 


Adept I

ryzen 3 2200g no display


I've built my pc and it posted to bios, I've set up XMP profile (3200MHz) on my memory, it reset and was working fine.

I shutdown pc, plugged in some sata drives, powered on and went to bios. Screen froze right after bios loaded, I couldn't do anything so hard reset was only option. I tried to get into bios again but this time it froze on splash screen. One more reset and there was no display output anymore. I've tried reseating ram, unplugging sata drives, plugged cpu and mobo power, resetting cmos with and without battery, put in dedicated gpu from my other pc(yes switched hdmi cable to gpu), tried with 2 different monitors, 4 different cables hdmi and dvi, still no display.

At first I've tested everything before putting the system in to the case. After I assembled everything, powered on one more time to check if it's still ok, powered off. Connected two sata drives, powered on and that's where the trouble began. PC still turns on, fans are spinning, mobo leds are lightning up and so are lights on keyboard(although now they all light up, instead of just numlock).

What could be at fault here? Please help.

My specs

CPU: Ryzen 3 2200g with stock cooler

RAM: Patriot 16GB 3600MHz Viper 4 Blackout CL17 (2x8GB)(PVB416G360C7K)


PSU: SilentiumPC Vero L2 500W 80+ Bronze

GPU I tried is MSI GTX970 which works fine on my other PC

1 Solution

Received new CPU today and everything finally works.

View solution in original post

14 Replies

Does it work okay with just one SATA Drive installed?

Is this a SSD M.2 SATA Drive or regular SATA Hard Drive?

Here is the specs on your motherboard concerning the SATA connections:PRIME B450-PLUS | Motherboards | ASUS USA 

Check in BIOS to see if there are any settings concerning SATA. It is possible you need to change a Setting for the SATA port you are using to make it work with both SATA M.2 SSD Drives if that is what you are using.

EDIT: Depending on the BIOS/UEFI you have installed. Some BIOS settings can change the M.2 from PCIe to SATA. Depending on what type of SSD you have.

After the BIOS freezes when you have two SATA Drives connected, What Trouble LEDs or Codes or Motherboard Beeps are indicated?  That will narrow down the hardware that is being affected.

Otherwise open a Asus Support "Live Chat" and see what they recommend.


Thanks for reply.

It doesnt work at all anymore. With or without SATA drives. I think that was just coincidental. I took out battery overnight and in the morning after the first boot got 1 long and 2 short beeps, which concerns memory afaik. Reseated memory just in case and beeping stop but still no display from either mobo or dedicated gpu. I tried corsair ram from other pc with no luck, also tried putting patriots ram in the other pc and they worked. At this point I think mobo must be at fault, either ram slots or something more. If the problem would be only with Vega graphics, I should be getting display from dedicated gpu right? Also reseated cpu this morning, no bent pins, paste spreadout perfectly.
I'll also try Asus support, thank you.


Maybe my wording wasn't clear. I get no display at all anymore. After pressing button there is no display even for a second. 

Adept I

Solved. Faulty motherboard.

Today new motherboard arrived and... still same problem. It turns on, fans and lights go up but no display. Tried swapping ram sticks and both hdmi and dvi-d ports on 2 different working monitors. It has to be cpu now, right?

Considering that in the first case screen froze two times before not displaying anything it looks like the problem must be igpu..


If the CPU is still under its 3 year AMD Warranty, Open a AMD WARRANTY REQUEST and see if they believe the CPU needs to be RMAed from here: 

By any chance, do you have the correct BIOS/UEFI version installed that supports that processor?

Another User had a similar experience. He needed to install a separate GPU card to get video.


I can't know that because I can't see anything, but on the box it says Ryzen 3000 series ready so that shouldn't be a problem. I swapped cpu to different mobo ASUS STRIX X570-E, and debug led light was stuck on vga and Q-code was 06 - Microcode loading - whatever that means. Tried with two separate GPUs, one older GTX970 and one I have in my other system RTX2070 SUPER, still no video..


In my opinion, since you used it on two compatible motherboards, it sound like the processor is defective. Also when you installed the GPU card, the Motherboard  should have automatically made it the main Boot Graphic display and not the integrated Graphics on the CPU if set to "Auto" in BIOS. So you should have at least video when you connected the Monitor to the GPU card Video outputs and not the Motherboard's video Outputs.

Make sure you have the proper BIOS version installed that support the 2200g processor. wrong BIOS version installed the motherboard won't boot up since the CPU is not supported.

You do have all the motherboard's power cables connected including the 8 pin and possibly the  4 or 6 pin aux power connected. Most motherboard won't boot if you just have the main motherboard cable connected and not the 8 pin aux power cable connected.

Here is your Asus Trouble LEDs:

The Motherboard's 8 pin Power connector should be connected. The 4 pin is not necessary unless you plan on Overclocking the CPU.

I am just going over the basics before you contact AMD Warranty.

If everything above is correct,

1- Correct BIOS version installed for the 2200g

2- Main Cable and 8 pin power cables are connected on the Motherboard

3- BIOS settings, you have the GPU setting on either AUTO or PCIe GPU. (If BIOS is in Default then it probably is in AUTO by default).

4- You connected your monitor to the GPU card and not the motherboard. (Try different Video Outputs on both the motherboard and GPU card to eliminate bad video output port)

5-Your Monitor cables are not defective

6-VGA LED saying you have an issue with the GPU hardware.

7-Install the least amount of hardware on the motherboard and test to see if video works. (Keyboard/Mouse, GPU, one RAM Stick, PSU, and CPU) This helps eliminate other connected hardware to the motherboard.

Than I highly suggest that you open a AMD Warranty Request to see if it needs to be RMAed. Before you do, make sure the CPU has no physical damage like bent or broken pins and the CPU Cooler is running when you power up.

AMD WARRANTY gives the purchaser of the AMD Processor in a box a three year warranty. But even if it should be out of Warranty I would still open a Warranty ticket just to see if AMD believe the CPU (APU) is defective.


1 - B450 motherboards should work out of the box with 2200G, so I don't think bios is the issue here, especially because on the first motherboard it posted fine two or three times.

2 - They were.

3 - Can't get to BIOS settings because there is no display at all..

4 - Tried many different configs with 2 systems and 2 different gpus and 4 different screens and cables which all work fine.

5 - They work on different system so that's def not the problem

6 - Could this mean hardware integrated with CPU? When I put 2200G in my other system with RTX2070S, it was still stuck on VGA led. 

7 - Already tried that, with RAM stick in every slot.

All the hardware is brand new. Bought it like a week ago. Before mounting system to the case I tested it on mobo box and set xmp profiles on the first try. Then I mounted it into the case and tested again if everything works fine - it did. Then I turned it off. Plugged in m.2 ssd and sata drives, and it freezed in the BIOS. Reset and another freeze on BIOS splash screen (where you have to press del or F2). After that there was no display. I disconnected all drives but it didn't help. I really think I've tried everything at this point, with different ram, gpu, psu and mobo.

I opened warranty ticket with AMD but I guess I'll just try to RMA it with retailer I bought it from.

Anyway, thank you for your help.


Yes, You need do go first through your Retailer's warranty before AMD Warranty becomes effective. But it is still a good idea that you opened a AMD Warranty ticket. At least maybe they can tell you if the CPU is defective or not by your symptoms. AMD will probably say to RMA it through your Retailer if it has an active Warranty.

If the VGA Trouble LED lit up on both Motherboards without a GPU card installed and with just the AMD APU then it does suggest the graphics part of the APU is defective. Because if the Integrated Graphics was working than that VGA Trouble LED shouldn't have lit up since it is seeing video output from the motherboard.

Sorry I am out of suggestions. Hopefully it is a defective CPU and your replacement will works flawlessly like all of my AMD Processors that I have and had in the past.

Take care and Good luck!

Received new CPU today and everything finally works.

Damn, that was fast. Who is the retailer with that fast service Warranty. 

Well, really glad your nightmare is over and it turned out to be a defective APU. It can be difficult to determine if it is a defective motherboard or a defective CPU. Many Users just RMA both the motherboard and CPU. 

Thanks for letting me know that it was finally a defective processor.

Happy computing!

Oh. by the way, mark you last reply about replacing the CPU as "Correct" so that others will know what fixed your problem.

Adept I

 Great CPU. 

Adept I

 Great CPU.