Showing results for 
Search instead for 
Did you mean: 


Ryzen 2700X locks out localhost:8129 on Crosshair Hero VI MB

Fair working system with the 1600X, slight memory timing issues from day one, but it did 3200Mhz on the ram from the beginning and now since fixing timings flawless operation. It is used in my Media Server PC and records TV broadcasts in mpeg2.ts and converts them to h.264, 24/7. The administration is via web gui on localhost:8129. I just purchased a 2700X dropped it in and it booted w/o issue. But once the media server software loaded it could not bind port 8129 and was forced to 8130. The software is hard coded tor port 8129. Snapstream Media BeyondTV 4 version 4.9.3 build 6535. I had the developer login and try to fix it. They were at a loss as to the problem. I put the 1600X back in, problem gone.

How do I fix this or is the 2700X defective in some way or is it a MB issue? I even did a bare metal install of the OS and software, no change, port is still not bound to anything as reported by the OS. But still blocked and not by the firewall of windows. Anyone else seen this kind of problem where a cpu change will block or take ports away?

Ryzen 5 1600X, Asus Crosshair Hero VI bios v.6302, EVGA 3200Mhz DDR4 (Hynix), Sapphire RX Vega 64 8Gb @1630Mhz, Samsung 950 Pro 256 NVME (scratch drive for video), WD Blue 256Gb SSD (c:), Corsair RM750i pwr supply.

15 Replies
Big Boss

king_of_pain14, your images are very slow to load.  Please simply use the image icon at the top of the Reply window.  I could blame the first problem on using a stale copy of OS after a major change.  What OS are you using?  Be sure to DL your AMD chip set drivers from AMD ONLY.  What does a "bare metal" install do.  Did you format your install disk and where did you get a copy of your OS?  From the slow loading images, I can see you are running Windows, but please tell us exactly what version.  Thanks and enjoy, John.


I don't know about your internet connection. It loaded for me in a sec. "Bare Metal" refers to a clean install on a wiped drive. USB made from MS on their website. You might want to check your browser or isp.


Pics loaded just fine for me, sir j : D thanx and enjoy


Here is an article from Tom's Hardware on how to open a Port in Windows Firewall: How To Open Firewall Ports In Windows 10

Firewalls are designed to protect a network from threats. Either threats from the outside trying to get in or threats from the inside trying to get out. It does this by blocking network-enabled ports. Every time a program tries to communicate through this port, the firewall checks its database of rules to see if it is allowed or not. If it doesn’t know, it asks you, which is why you sometimes see prompts asking you if a particular program is permitted to access the internet.

Open firewall ports in Windows 10

You can manually permit a program to access the internet by opening a firewall port. You will need to know what port it uses and the protocol to make this work.

  1. Navigate to Control Panel, System and Security and Windows Firewall.
  2. Select Advanced settings and highlight Inbound Rules in the left pane.
  3. Right click Inbound Rules and select New Rule.
  4. Add the port you need to open and click Next.
  5. Add the protocol (TCP or UDP) and the port number into the next window and click Next.
  6. Select Allow the connection in the next window and hit Next.
  7. Select the network type as you see fit and click Next.
  8. Name the rule something meaningful and click Finish.

You have now opened a firewall port in Windows 10!

If you are using a Anti-Virus Firewall in place of Windows Firewall, This instructions should be similar if not you need to contact the Anti-Virus Support on how to configure their Firewall. I am using McAfee Firewall instead of Windows Firewall.

This article explains and defines Port 8129: Port 8129 (tcp/udp) - Online TCP UDP port finder - . Might help you to find out why it is not available.

NOTE: When I click on the posted images link, it doesn't work correctly. Just shows it trying to post the image. But when I right click on the image link and click on "Open in New tab" it shows up immediately.

EDIT: Just reread your post and you mentioned you tried opening a Port in Windows Firewall.


Thank you for trying to help. I guess I need to make it clear this is not a firewall issue. In the screenshots I provided failed2bindport8129 you can see where the program is loading into windows and is requesting its ports, port 8129 and 8131 are not blocked by the firewall but is grayed out because of this mysterious fault.  They disappear when the program completes loading and a error occurs as shown in the attachments New Desktop, and failed2bindport8129B. I was hoping an ASUS motherboard engineer has any idea what could cause this fault? between just changing cpus as I said I put the 1600X back in and it works like it never happened.. Maybe this motherboard isn't fully Ryzen compatible as they claim between 1st gen and 2nd gen? I wanted to wait until X570 comes out next year so I could get 3yrs out of this system before Ryzen 3000. It is a premium motherboard so I am perplexed.


Sorry, my Fault, I reread your post after commenting and saw that you did try to use Windows Firewall to open the port.

I couldn't find anywhere where a particular CPU will block a Windows port from working. So it could be something to do with the motherboard's BIOS and the newer Ryzen CPU or possibly the LAN/Network Driver need to be configured under "Properties".

Will try to see if I find anything else that might be of better help.

See if Asus Support has a BETA BIOS that you can download and see if it makes the Ryzen 2xxx more compatible with the Motherboard and hardware/software installed.

EDIT: Here is NETSTAT commands: netstat | Microsoft Docs . I realize you are aware of the commands but maybe there is a new switch you can use besides -a and -n like  switch -o.


king_of_pain14, you did not answer my questions.  The behavior you are seeing is exactly what I would expect if the OS was not installed from a fresh copy of W10 installation files.  Please Google "W10 Media Creation" and DL a fresh copy of W10, format your C disk and install it.  Media Creation will build a USB ready to go.  Please let us hear.  Enjoy, John.

EDIT: I failed to say a very important fact!  You must do a Clear CMOS!


I don't think you really read or understood my question. All that you asked was done that's what bare metal means. Look at the screen shots. Thanks for trying to help but it doesn't seem you have the knowledge I seek on this issue.


Listen, I am sorry if I am repeating something you already are aware of.

From Snapstream Forum about the same problem you are having with Windows 10: Unable to connect to the SnapStream WebUI after running Windows 10 Version Update – SnapStream

SnapStream​​ SnapStream KnowledgebaseSnapStream Express

Unable to connect to the SnapStream WebUI after running Windows 10 Version Update


April 24, 2018 14:18


Issue:  The SnapStream WebUI becomes inaccessible after running a Windows 10 version update.  This can affect SnapStream Express systems, and SnapStream Encoders.Cause:  This happens when Windows update moves the IISExpress config files that our Web Interface needs to run (they end up being put in the windows.old directory).  When this happens, no one will be able to connect to the SnapStream Web Interface on that Windows 10 machine, and the system will not have the path below anymore.

C:\Windows\System32\config\systemprofile\documents\IISExpress\configResolution:  Perform the steps below

  1. Copy all of the IIS configuration XML files from the path below.

    C:\Program Files (x86)\IIS Express\config\templates\PersonalWebServer

  2. Put a copy of these IIS configuration XML files in the paths below.
    NOTE:  You will need to recreate these folder paths on the system if they don't exist.


  3. Go to Windows Services (Start > Run: services.msc), and stop the SnapStream IIS Express Wrapper Service.

  4. Download and re-install IIS 10 Express (iisexpress_amd64_en-US.msi) on the system.

  5. Got to Windows Services (Start > Run: services.msc), and start the SnapStream IIS Express Wrapper Service.

  6. Stopping the SnapStream IIS Express Wrapper Service before re-installing IIS Express should prevent you from having to restart the System, but if the WebUI still doesn't work, please reboot before trying again.

Here another article about Snapstream (BeyondTV) configuration: Network configuration for SnapStream – SnapStream


king_of_pain14, thanks so much for the insult!  Enjoy, John.


No insult intended. I guess it was just miscommunication. Thanks again.


BTW: My answer to your 1st question is still with the moderator so you haven't seen it. I guess he/she missed it. Sorry about that I am new to this forum.



Not sure if any of the info was helpful or not. But as you know, this a Forum where Users try to help other Users with their problems. The Moderators are the only ones that are actually AMD Employees.

This sounds like you need to contact AMD Support via Email from here: Online Service Request | AMD​ .

It is really odd that by just upgrading the CPU will cause a Windows Port to be inaccessible. Seems like this is a Work station computer. Make sure you note that you work for a business environment if that is the case.

Good luck. Hopefully you find your answers.


Thank you for trying. Unfortunately this is for their server version. Windows 10 doesn't come with IIS server. I did contact their support and a engineer logged on my computer and tried for 6 hours on friday to no avail. So Sunday I put the 1600X back in and it's up and running. I am going to return the cpu as defective and get a replacement. It wouldn't be the 1st time, I had to replace my entire 1st Ryzen purchase MB, memory, and cpu because of memory issues and just weird  behavior. This is the replacement system and has been running ever since. My 2nd system is a carbon copy of this, just custom water cooled. I liked how the 2700X ran out the box, it boosted to 4.35Ghz, ran most of the time at 4.25, 4.0-4.1 while gaming. It did have memory issues, but I thought that had to do with adjusting the memory timings for Ryzen 2. But after doing that they seemed to of continued, but the binding of port 8129 took over and I didn't look into it further. I reset the timings for the 1600X and haven't had an issue.


Cross your fingers that the next 2700X will work as well as the 1600X and the issue wasn't caused by some upgraded CPU instructions or feature on the 2700X.

I did noticed that there was a fairly new BIOS for your motherboard. But I didn't mention it because I have a very strong feeling you already have the latest BIOS installed from Asus Support.

Anyways, at least , you still have your computer up and running as before just not upgraded YET.

By the way, if the new 2700X has the same problem or doesn't you may still might want to let AMD Support know about it. In case other Users open tickets for similar issues.

See ya, If you happen to remember, post back if the 2700X  CPU ;was defective or not for future reference when you install the new 2700X.