Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 2700x build problems

Hi everyone,

I've built a system based on Ryzen2700x about 2-2.5 months ago, specs are below:

Ryzen 2700x running at stock speed (no overclock)

Cooler: Phanteks TC14PE

Asus Prime x470 PRO, bios up to date

32 gb Corsair Vengeance DDR4 3000 MHz C15 XMP 2.0

Evga GTX1080 SC

Samsung EVO 970

Seasonic Prime Platinum 750W

and a couple of hard drives (5400 and 7200 rpm)

Windows 10 Pro 64 bit

The case is big, has good cooling, CPU never overheats (temps are usually below 65C under heavy load and around 25-28 at idle)

I use this computer for graphics creation, never do any gaming on it. It runs well and it has plenty of speed when rendering.


It's randomly freezing in Windows, sometimes with extremely basic/simple things like browsing web pages and the only way to bring it back is a forced reset... and it also randomly restarts, with no obvious warning, sometimes right after starting it up in the morning... (checking event viewer in Windows just comes up with a System has rebooted without properly shutting down first and that unfortunately doesn't tell me much )

I like the machine and I want to keep using it - I have ditched Intel after a lot of years and hoped AMD would be a good choice - and on paper, it still is, cheaper and quite powerful. But the above issues, and the fact that there were more errors/restarts in the last 2-3 months than in 5 years of having the previous Intel machine is making me quite worried. I haven't, fortunately, had these things causing me to lose work, funny enough the system appears to be very stable when I do graphics work that's quite intensive, but then fails on small things like browsing a web page or even doing nothing (will freeze after being idle for a while...)

I thought I'd post the issue here as chances are I'll get more feedback/advice and a lot quicker than contacting AMD directly (sorry to say this, but it's been very slow when I used it last and it has not helped me at all)

Cheers for your time and any advice that you might have - sincerely appreciated!

All best,


Message was edited by: Virgil Tanasa

17 Replies
Big Boss

virgil87, unfortunately, a number of users have a similar problem to yours.  Please search the forum.  Thanks for your system specifications but you need to specify the memory model.  Is your memory on the MB QVL (Qualified Vendor List)?  Ryzen is very sensitive to memory.  I assume you are running at the XMP 2.0 speed?  You can use CPU-Z to see the actual memory speed.  If you are using the XMP, it would be useful to set BIOS to Default and see if the hangs stop.  I had a hang problem on my 1800X which turned out to be two bad memory sockets requiring a MB RMA.   Like yours - mostly at idle.  The early morning hangs sound like cold sensitivity.  What are you using to measure temperature?  Please use Ryzen Master - it it the reference.  Please post a screenshot.  Thanks and enjoy, John


Hi John.

Thank you for your reply. I have indeed searched not only this forum, but I've been searching for some clues to this issue since it started (shortly after building the computer...) Many times I find that people acknowledge the issue but there isn't any fix I've been fiddling with computers for quite some time and I usuall have a bit of an idea what I can try before running out of options... which is where I am now

I have tried running the memory at both XMP speed and stock (default ) and it made no difference. The RAM has been also tested in pairs, with just 16 GB each time - installed in the correct sockets - again, it made no difference. The fact that a lot of people have this issue but there isn't a definite solution to it isn't reassuring unfortunately.

As to cold sensitivity - I'm not quite sure what that means? I never had this issue before with any of my builds?

I check temperatures with Ryzen Master and CoreTemp.

I was wondering - how can the system hang mostly at idle and rarely at full load, I can sometimes work for a full day using 3-4 apps simultaneously, switching back and forth between them -  and it's rock solid. Then I stop, close the apps, browse the web for a bit, or just leave it like that for a little while - and I find it frozen. If the RAM sockets are faulty, surely it should also happen at any time, not only at idle? Just guessing...

Like I said - if the hangs/random resets would stop, it would be a great machine to work with. But at the moment, I am starting to seriously regret buying it

virgil87,  I cannot answer your questions about hanging at idle - makes no sense to me, but again say I had the same problem.  Here is how I closed in on that it.  With one memory stick in A1, I let the system idle (usually overnight).  If no hang, I used another stick in A1.  I continued until I saw a hang.  I tested all sticks and all sockets.  Testing continued till I could determine that it was a certain stick or two; or it a certain slot or two.  In a couple of days it was clear to me that all sticks were OK and two slots (A1 and A2) were bad.  I RMAed the MB and all was OK.  Some electronics have a problem when cold, so leaving it powered on often cures that problem.  My 1800X and my current 1950X sleep really well, so that may work.  I am testing a fix (stop Windows Update) for a wake problem when W10 decided to do updates when Sleeping.  I still want to know your memory model and please post your UEFI and AGESA versions - latest CPU-Z will tell you.  Here is my system specifications:

ASRock Fatal1ty X399 Pro Gaming, Threadripper 1950X, 2xSamsung SSD 960 EVO RAID0, 4xSSD

960 EVO on ASRock Ultra Quad, 1TB & 500 GB WD Black, G.SKILL [Flare X (for AMD)] F4-

3200C14Q-32GFX, Windows 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler,

Radeon RX580, BIOS 2.0, AGESA ThreadRipperPI-SP3r2-

Enjoy, John.


hi John, thanks again for your time and help with this. I'll probably try what you suggested, when I get a bit of time, I didn't think of testing it like that.

Memory model is: Corsair CMK16GX4M2B3000C15 Vengeance LPX 16 GB (2 x 8 GB) DDR4 3000 MHz C15 XMP 2.0

2 of those kits.

Here is a screenshot of Cpu-z - hopefully this is what you were looking for?





virgil87, please tell me the sockets for each kit you are using, eg, kit #1 is in A1 and A2 ; kit 2 is in B1 and B2.  The ASUS memory QVL is very confusing to me but I read it as saying 4 DIMM is not supported.  Have you tried running just one 16 GB kit?  If not try that before my long tests.  Enjoy, John.

Journeyman III

Hi Virgil,

I think the problem is with gskill ram. Let me describe you my situation.

I am also facing the same issue of ryzen 2700x freezing randomly while pc is idle or working. I bought the machine in August 4th week with specifications;

Ryzen 2700x with stock cooler

X370 mb msi

3000mhz gskill

250gb Samsung Evo

Gtx 1060

Barracuda 2tb

600w psu

After reading several threads i landed on gskill website where they say ram with serial number ending with X supports Ryzen series.

Mine does not end with X so i believe its the ram which is creating the random freezing issue.

Let me know if you find ram with the X factor which solves the issue.



hi Vivek, thanks for your reply - but my RAM is Corsair?


shahivivek, if you would like some help, please list the model of your RAM and a more complete description of your problem(s).  In general Ryzen runs best with G.Skill memory, I use it and have no problems.  Mine is F4-3200C14Q-32GFX (with X).  It contains Samsung B-die chips which Ryzen seems to like the best.  You can use a free DL from Thaiphoon Burner that will tell you everything about your memory.  I do not have enough information, but at first blush, I would say your power supply is too low power.  I used a 750 Watt supply on my 1800X and I recommend the same for your setup.  I would suggest you hold on to your memory until you address your PS.  Enjoy, John.


I use G.Skill NT series and I have a R5 2400G and I was able POST it immediately. My RAM is the cheap DDR4-2400 but I overclocked it to DDR4-2800 and fiddled the timing as tight as I could.

My Motherboard is the MSI B350M Bazooka which is a basic AM4 board and I have never had a freeze or crash.

MSI Live update has often found new drivers for the AMD chipset, the audio and even my Intel 9260 WiFi card.

I have a pair of 4GB sticks with XMP and a pair of 8GB sticks with JEDEC only. Not a problem. The BIOS seems to be able to figure out the memory as the large number of JEDEC tables are easily checked.

Adept I

Hi everyone,

I know it's been a while, between then and now here's how things have gone...

The PC kept doing the bad bits, unfortunately, I've put up with it for as long as I could, until one day when the CPU basically died. It started with BSOD's, one every day, then one after another within minutes from restarts... I initially thought it was the motherboard, so I replaced that one first, but the PC was still pretty much dead... so I bought a different CPU (still a Ryzen 8-core) and returned the old one (thankfully I was able to!) and yet - I still get random freezing and have to do a hard reset.

I've read another thread in here about setting some BIOS CPU Vcore (SOC Vcore) to very high values, but I'm not feeling very comfortable with that, as in my mind that's overclocking, in some way? (and also reading around on the net, I hear it's not really recommended to do it, best to leave it on Auto) - and to be absolutely fair, I do feel my patience has come to a limit, in regards to this type of system based on Ryzen. I really need a stable PC which I can do my work on, fortunately I've not lost anything major yet, but I had to reboot whilst having quite a few graphics apps opened and I was very worried I've lost the work.

Honestly, for me, this computer just doesn't seem to be the right choice, I have tried swapping everything I could swap (video card/PSU, ran with less memory sticks, ran with the memory at the default speed instead of the one specified on the chips...) and I lost an immense amount of time reading everywhere about what I could do to make it more stable. All of that time unfortunately translates in work time lost... and for a freelance guy, that's pretty bad

I just don't feel it's worth it anymore, sorry if this sounds a bit downbeat, but I now feel it's been a huge mistake switching to AMD. I have previously had a i7 3930k which was probably the sweetest machine possible. Fast, stable, responsive - everything. I just wanted to get an 8-core and newer tech and didn't have the cash to invest in Intel's badly designed CPU (the ones without solder)

I will however think about keeping Ryzen as a rendering machine - for which I feel it's perfectly suitable, very low cost but mighty powerful. For a day-to-day workhorse, where stability is key, it has let me down massively so I'm probably going back to Intel.

Cheers for all the support - until I get the $$$ to replace the system, which will take a few good months, I'm very happy to hear any more thoughts/suggestions on what I could do to make it at least more stable if not 100% stable

All the very best,


Journeyman III

Im having  a similar issue with my  new ( less than 1 month  old) Ryzen 7 2700x

I thought it was Windows related, so I switched to Ubuntu 16.04, then to  18.04 . All three always fail.

The Guaranteed way ( for me) to cause the freeze/fail is by compiling LLVM source code 8.0 &/or  9.0 with ninja as the compiler on all platforms. Im assuming( in my case scenario ) that this is due to the default amount of threads utilized.

Also when compiling the AMDSEV source code on Ubuntu 18.04 , I experienced the same failure/ indefinite freeze.

When I initially set up my rig with a regular (non solid state) hardrive, I didn't experience as many failures when compiling source code.

My specs are attached.

CPU: AMD RYZEN 7 2700X ( Pinnacle Ridge)


RAM: 32 GB CORSAIR ( 2 sticks of 16 GB) (  A -die)


PSU : Rosewell Hercules 1600

GPU : AMD RX 580  (Polaris)

HD : Crucial MX500 SSD




iweed, please post a screenshot of Ryzen Master (RM) and please do not stick anything on top of it.  Please do a Clear CMOS using the instructions in your user manual and try running with one stick of memory then the other.  In each case use a different channel.  Thanks and enjoy, John.


iweed, I have the exact same memory and BIOS with the same AGESA (on a Gigabyte B450 Aorus Pro). I can only get the memory to run at JEDEC standard 2133 Mhz, anything else and boot will fail. I have found a lot of references to issues with Corsair memory, and many with this exact model - maybe that is at fault. I have previously used Kingston HyperX in various builds and they have been rock solid. If there is no fix, it will be my last Corsair set (and I shall read the QVL better next time).


If you get on the forum for memory vendors, most details can be obtained from them easy enough


Really Win10 system freezing or just input device freezing (mouse/keyboard)?

If it is input device freezing then you still can touch the power button (when frozen) and the system shuts down normally.

Many Ryzen users seem to be affected by this but still no reliable fix


I use a MSI motherboard for my R5 2400G and I see more problems with Asus so I wonder if they need to fix their ROM so that memory is more stable

AMD provides the CPU tables so that is easy to integrate into a BIOS

Journeyman III

iweed‌ Hey i checked your RAM and its not Listed in the MSI QVL List. I think thats the Problem