cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

tomnel
Journeyman III

Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

I have two Ryzen based systems.

a 1700 Ryzen with 32GB of ram with a Gigabyte M-ATX motherboard

a Threadripper 1950X with 64GB of ram with a ASROCK ATX motherboard

about a month after I built the 1700 system it would bluescreen after the first start up then after I restart it would operate fine.

about 6-8 months my Threadripper 1950X developed the same behavior, blue screen at first start then fine after restarting.

Blue screen error is  "Driver Power State Failure" on both systems.

I've updates BIOS, installed latest windows 10 updates and AMD driver packages from motherboard manufacturers and when that didn't work update from AMD's driver packages.

But the blue screens persist.

Anyone have any ideas? all my google searches prove fuitless, mostly talking about updates and BIOS updates but none have fixed the problem.

0 Likes
1 Solution

Accepted Solutions
misterj
Exemplar

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

Thanks, tomnel.  The minidump says "A device object has been blocking an IRP for too long a time."  I do not know what this means, but it would seem to me that a piece of your HW is talking too long to power up.  Do you have any HW common between the two systems?  I would suggest you try disconnecting any HW you do not need and see if you still get the BSOD.  Do you have your systems activated with a valid MS license?  Enjoy, John.

View solution in original post

6 Replies
misterj
Exemplar

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

tomnel, with so little information, can only venture a guess.  Please post specifications of maybe one and we'll see if we can make progress on it.

My ventured guess is insufficient power supply.  I would guess the 1700 would need 650-750 Watts and the 1950X needs 850 Watts to 1000 Watts.  Enjoy, John.

0 Likes
tomnel
Journeyman III

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

Thanks for the input. I don’t believe power supplies are the problem.

A. it only happens on first boot then the systems are fine for the rest of the day Indicating this isn’t a hardware issue.

B. The TR system has a 1000w and the 1700 has a 850w.

TR system - Asrock Tai Chi X399, G.SKILL TridentZ RGB Series 64GB (4 x 16GB) DDR4 3600

EVGA 1060, EVGA 1000w PS

1700 system - GIGABYTE GA-AB350N-Gaming WIFI, CORSAIR Vengeance LPX 32GB (2 x 16GB) DDR4 3200

EVGA 1070, thermaltake 850w PS

both systems have samsung ssd’s

0 Likes
misterj
Exemplar

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

tomnel, I agree on the power.  What version of W10?  Are you running the latest UEFI in both? Please attach at least on minidump file.  Be sure you have the latest AMD drivers from only the AMD Driver DL site.  other drivers should come from part vendors not MSI.  Enjoy, John.

0 Likes
tomnel
Journeyman III

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

I am on W10 1803 but it happened on previous builds. Latest UEFI yes and latest drivers from AMD, and part vendors installed. After I installed the latest AMD drivers it didn't bluescreen after the first boot but then the next day it started bluescreening on first boot again.

heres a minidump

https://drive.google.com/open?id=1IpMxIrVPQfZWeQ-1B1XlgFvfmPlyNOdAMINIDUMP.FILE

0 Likes
misterj
Exemplar

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

Thanks, tomnel.  The minidump says "A device object has been blocking an IRP for too long a time."  I do not know what this means, but it would seem to me that a piece of your HW is talking too long to power up.  Do you have any HW common between the two systems?  I would suggest you try disconnecting any HW you do not need and see if you still get the BSOD.  Do you have your systems activated with a valid MS license?  Enjoy, John.

View solution in original post

tomnel
Journeyman III

Re: Ryzen 1700 and Threadripper 1950X both buescreen on first boot then fine after restart

Jump to solution

Thanks, it turned out to be an Nvidia shield game controller. I still need to test it on the Ryzen 1700 system but that may have had a controller hooked up when I was using it at work.

0 Likes