cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Esteemed Contributor III

ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

Information here:
 "https://rog.asus.com/us/motherboards/rog-crosshair/rog-crosshair-vii-hero-wi-fi-model/helpdesk_downl..."

Version 4001 Beta Version
2020/11/24 15.23 MBytes

ROG CROSSHAIR VII HERO (WI-FI) BIOS 4001
1. Update AMD AM4 AGESA V2 PI 1.1.8.0 for new CPU support
2. It’s highly recommended not to update this beta BIOS when using AMD AM4 Socket for AMD Ryzen™ 3000 Series/ 2000 Series/ 1000 Series/ A-Series Desktop Processors.
3. This beta BIOS can only be reversed by BIOS Flashback.

Before running the USB BIOS Flashback tool, please rename the BIOS file (C7HWIFI.CAP) using BIOSRenamer.

 
0 Kudos
4 Replies
Esteemed Contributor III

Re: ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

I just recently purchased a Asus Gaming X570 Pro WiFi (released date September 2020) and it also has a BETA BIOS. But the only difference I see between the latest Non-BETA and BETA is that the Non-BETA it mentions it has a PATCH "B" while in the BETA it mentions it has a PATCH "C".

I will be "Chatting" with Asus about the BETA BIOS and whether I should update my BIOS from the latest Non-BIOS to the BETA.

Esteemed Contributor III

Re: ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

Thanks @elstaci 

I will try asking ASUS for more information for the X470 boards.
I do not think I will be upgrading X470 from Ryzen 2700X though.
I am happy enough.

Will look to see if there are any good deals on ASRock Creator or ASUS X570 boards for next Ryzen build.

Thank you.

0 Kudos
Esteemed Contributor III

Re: ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

Small endorsement for Asus Motherboard:

I purchase two ROG Crosshair VIII Hero Wifi and Non-Wifi and both I needed to return. The first one from Amazon was definitely DOA but second one from Best Buy may have been good.  

But in the end I found this new Motherboard That has 8 Sata ports and 4 PCIe slots and up to 128 GB of RAM, the Asus TUF  Gaming X570 Pro Wifi.  It costs about 50% less than the Crosshair at $220.00. 

Both the Crosshair and X570 Pro have 8 Sata ports and 4 PCIe slots and both have Wifi/Bluetooth features and BIOS FLASHBACK buttons in the rear.

Reviews indicated this Motherboard may not be the best for Ryzen Processors with 16 core or more but for Ryzens with 12 core or less it was fine due to the motherboard's VRM.

It has a Flashback button like the more expensive ROG Crosshair motherboards. I finally was able to get my new Rzyen build working with a Rzyen 7 3700X and G-Skill Trident-Z Neo RAM (32 GB).

I ended up replacing my original Amazon Ryzen and RAM just in case they were defective in causing my PC from booting up.

But finally it turned out to be my 4K monitor was the issue. Somehow Asus BIOS was saying no VGA Detected when my Monitor was incompatible with the Resolution for the BIOS (720x440). My GPU card, Asus GTX1070, was working normally outputting a signal it was just my 4K monitor was not seeing it. I had the exact same VGA & BOOT TROUBLE LED lights on all 3 motherboards plus the BEEPS indicated no VGA installed or Detected.

This is something I am going to bring up when I chat with Asus Technical Support about their BIOS. To me it seems to be a huge bug or badly written BIOS.  BIOS should never have indicated NO VGA Detected or Installed because the Monitor wasn't compatible with the BIOS Resolution. 

This gave me the wrong impression that my GPU card or Motherboard were defective. But I found a Computer Repair shop that tested my GPU card for free and it worked as advertised.  Then I took my entire Tower PC to the same computer Repair shop to be tested and it booted up normally on his 2K VGA monitor using a HDMI-VGA active adapter.

After resetting my Monitor's Setting to factory default the first time I was able to finally get video output and was able to boot up and do a clean Windows Installation.  

Then I did something stupid. I decided to disable CSM and enable UEFI mode in BIOS since Windows was saying it was compatible with UEFI Mode.  UEFI mode has the Secure BOOT feature and suppose to boot up faster than CSM Mode. 

As soon as I enable UEFI Mode I lost all video Output during POST until Windows was about to start in which case I had video output. So I did a CMOS CLEAR with the same results except this time I was getting again the NO VGA DETECTED BEEPS and VGA Trouble LED light all the time. Using the Asus BIOS FLASHBACK button I reinstalled the BIOS twice with no change. I tried both HDMI and DP and reset my Monitor's Setting again to default. no change. Finally I remembered I had my 2K SAMSUNG Smart TV hooked up to my GPU card. So I removed the power cord to my 4K LG Monitor and started my computer again. This time it booted up and had video output to my TV set.  I was able to enter BIOS and enable CSM again and disable UEFI mode. 

Powered up my 4K monitor again and bingo I had video output again and everything is working great so far. I had some glitches in Windows in that all many of my Serial Numbers to my 3rd party Apps weren't recognized including passwords to website on the internet.

I guess the passwords and Serial numbers were somehow connected to my old Asus Sabertooth 990 FX Motherboard and FX8350 CPU and when I changed to Ryzen CPU and Motherboard it wasn't recognized.

But in the end finally got my new build working and running stably with 32GB of RAM at 3600Mhz speed and the CPU running at 4.2 GHz when needed.

 

EDIT: When I asked Amazon to replace my DOA Motherboard they sent me a replacement the same day. The box wasn't sealed and the Motherboard was almost 2 years old with less than 2 1/2 years of Warranty according to Asus Tech Support. Sent it back for a full refund.

Amazon did send my fully sealed new CPU and RAM though for their credit.

I was going to purchase an ASRock X570 Motherboard which all have 8 SATA ports and at least 4 PCIe slots and 128 GB RAM. But also noticed that ASRock's QVL list for RAM is fairly limited to certain RAM companies and some with little compatibility. But then I started looking at ASRock's Warranty and it seemed to be rather complicated and expensive for the User so I decided to go with Asus again instead.

 

0 Kudos
Journeyman III
Journeyman III

Re: ROG CROSSHAIR VII HERO (WI-FI) Beta BIOS Update available for new CPU support. Anyone tried it?

I tried to update my bios using this and it constantly gives me a "Not a proper BIOS" error  ( it has been unzipped and renamed for the flash back version as well. still nothing. ):  )

0 Kudos