cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

mjeccs
Journeyman III

Require Help 5800x no post

Hi guys

Looking for some expert advice here. I am absolutely out of ideas and losing all hope.

Current system
X570 Tomahawk
3400g Ryzen APU
RTX 3080
2x 8GB G.Skill Neo 3600

Ok so my system in the above configuration is working fine. I updated my bios from the MSI website to v15 which is said to support the 5000 series processors. I did this while to 3400g was installed and launched from Bios.

When I install the 5800x I get a solid white CPU led on the motherboard. There is no display to my monitor, which I have tried connecting both via HDMI and Display port to HDMI adapter. I have also tried booting with one stick of RAM (Slot 2) and changed the timings to a stock profile of DDR4 3200.

I am absolutely out of ideas and to be quite honest don't even know where to start.

Is there likely to be any difference if I flash my motherboard from the motherboard switch at the back?

 

To confirm, when I put my old processor in the system continues to work fine.

Thank you for your time in reading this.

0 Likes
2 Replies
fyrel
Miniboss

Re: Require Help 5800x no post

Can you confirm that the monitor is connected to the graphics card and not the motherboard?

 

Try doing a cmos clear see if it helps.

If it still doesn't work you should maybe try installing v14 bios.

Then try MSI support if you don't have any luck.

0 Likes
tatane
Adept III

Re: Require Help 5800x no post

CPU led error on a Tomahawk sound like a CPU failure, especially if it works well with a 3000 series and have the bios to support 5000 series ... Try a cmos reset first (you never know, it may help indeed), but I wouldn't hold my breath on that 

Had the same led lighting up on mine (x570 Tomahawk and 5950x) ... CPU is now under RMA 

If you got it from a reseller, try getting him to change it (might be faster then AMD's RMA), else you should open a ticket with AMD to start your RMA process ...

0 Likes