Showing results for 
Search instead for 
Did you mean: 


Adept I

Red cpu led after upgrade

I recently upgraded from a Ryzen 5 5600g to a Ryzen 7 5700x and I knew that it needed a bios update after the display didn’t show and that the cpu led was on. So I tried the Qflash bios update that the motherboard has. I put the right bios version on a usb drive and when I tried it, the orange light showing it working was blinking. So I tried turning my pc on and the cpu led was still on. And I dont know how to solve it. I’ve make a support claim with Gigabyte for the motherboard but they have not answered yet.

10 Replies

Do you mind if I ask what the Make & Model of your Gigabyte Motherboard?


Gigabyte b550 Aorus pro AC V1.0. It says it supports the 5000series so it should support it. I did update bios like I said previously.


Okay as long as you flashed BIOS version F14 or newer it should recognize the new processor and boot up the computer.

Remove all the RAM from your Motherboard and power up and see if the CPU Trouble LED goes off and the DRAM Trouble LED lights up?

If the CPU Trouble LED light does goes off and the DRAM Trouble LED did light up and stay lit that indicates that the RAM you have may not be compatible with the new processor. What happens is that BIOS tested your CPU and it passed POST but found no RAM installed so the DRAM Trouble LED lit up. So you need to look in Gigabyte's QVL list for RAM for the "VEMEER" processors and see if your RAM is listed or not or listed at the RAM manufacturer's QVL list for your motherboard.

You can install one RAM stick in A2 DIMM Slot on the motherboard and see if it boots up or not.

If the CPU Trouble LED still stays lit after removing all the RAM Sticks from your Motherboard I suggest you install your APU 5600G and make sure the BIOS F14 or newer did install using Q-Flash or use Q-Flash BIOS again to make sure.

If it didn't then update the BIOS from BIOS itself. Then remove the 5600G and install the 5700X and do a CLEAR CMOS with the new Processor installed.

This is just to eliminate a bad BIOS update since you don't know if F14 or newer actually is installed or not.

If you verify that you have the correct BIOS version installed and the DRAM Trouble LED doesn't light up but the CPU Trouble LED still stays lit then you either have a defective Processor or Motherboard.


I’ve unplugged everything except the 6pin and 24 pin connectors on the motherboard and did qflash f15 cause that was the only version that did something. And it’s only the cpu lee that turns on. And could the motherboard be bad if it turns on everything plugged into it? Like my fans and RGB work


If you removed all hardware connected to your Motherboard except the PSU, CPU, and had all the motherboard and CPU power cables connected on the motherboard and the CPU LED came on and stayed on that could be a defective CPU or Motherboard. 

what should have happened was BIOS would test the CPU. If it passes the POST test then the CPU LED should go off and the DRAM LED should come on since you have no RAM installed.

But since the CPU LED light stayed lit indicates that BIOS found something wrong with the CPU and stopped booting up.

Only way to really test the CPU is by installing the new processor in another compatible Motherboard and see if it boot up or you install again the 5600G APU processor and it boots up normally than the problem is with your CPU and not your motherboard.

Remove the 5700X and install the 5600G with everything still disconnected and see if the DRAM LED goes on. If it does reconnect all the hardware again and see if the computer boots up. If it does then your motherboard is probably good and the new CPU is bad.

I would then open on January 05, 2023 a AMD SUPPORT - Warranty ticket and let them know what you did to isolate the problem to the CPU. See if they believe you need to RMA the processor to be checked or not by AMD.

NOTE: After removing the new CPU physically check it for damaged pins (Bent or Broken).


before installing the old CPU install just one stick of RAM in A2 DIMM Slot just to see if the CPU LED light goes off.


I don’t have the old cpu cause I sold it for this new one. But I’m taking it to a tech place that I’ve been to before.

I tried doing a bios update with nothing but ram and taking out the cpu and this time it showed the dram led. But when I do the cpu plus the ram, it shows the cpu led. Does that mean anything?

Journeyman III

Hi mine did the same thing, before you install the new cpu, keep the old cpu in and update your bios on the motherboard.


That’s dumb. Then what’s the point of flashback or qflash if I still need the old cpu? 🫤