Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Random reboots and WHEA Cache Hierarchy Error

Computer Type: Desktop

GPU: GTX 1050 Ti

CPU: Ryzen 5 5600x

Motherboard: MSI B550 Tomahawk

BIOS Version: 7C91vA72(Beta version), previously 7C91vA6

RAM: 2x8gb (16gb) Crucial Ballistix Sport LT 3200Mhz CL16 BL2K8G32C16U4R

PSU: Corsair CX650 80+ Bronze Non-Modular (The newer model with black/yellow packaging, not the old green one)

Operating System & Version: WINDOWS 10 PRO 21H1 19043.1110

GPU Drivers: Game ready driver 471.41

Storage: XPG Gammix S11 Pro 1tb SSD, Seagate ST1000DM003 HDD and Seagate ST2000DM008 HDD

Description of Original Problem: System reboots randomly and gives me a WHEA "Cache Hierarchy Error" coming from the processor's core on Windows Event Viewer, with the following APIC IDs, although I only have the record of the last few times it happened: 3, 5, 8, 9, 11, 9.
There's almost no pattern to the rebooting at all, and I can't replicate it no matter what stress test I do (Prime95, CineBench, Ryzen Master stress test, stress test the cpu while playing a gpu-intensive game). In the last few days it has happened when I first turn the pc on after it's been turned off for a while and enter the Windows login screen. Then it only happens again once after a few hours and it doesn't matter if it's a light or heavy load, or it just straight up doesn't happen again for the rest of the day.
My PC rebooted sometimes since I built it (8 months ago), but it was like once a month and I always thought it was because of a brief energy outage or something, I only realised it wasn't because the problem began to worsen last week or so.

Troubleshooting: As I stated before, I tried stress-testing on everything and tried to make the system work with everything on its maximum capacity at the same time. If the problem was the power supply, I believe it would've stopped working there.
I also tried updating the bios, but it didn't work.
I disabled C-States, it didn't work.
I ran Windows's Memory Diagnostic on my RAM sticks with XMP turned on and turned off, no problem was detected.
I set Precision Boost Overdrive (PBO) from Auto (the default option) to Off, and it didn't work.
I tried to turn the RAM XMP off, it didn't work.
I tried stress-testing the CPU cache, memory controller and RAM, it was all working perfect fine.
I tried updating my graphics card drivers, it didn't work.
I tried updating the AMD system and chipset drivers, it didn't work.
Hwmonitor shows that voltages and stuff are fine throughout all of the benchmarks and tests, and the system is working perfectly stable.
I also tested my power supply with a multimeter a few months before building the PC, and everything was perfectly fine.
I never overclocked my CPU.

I tried disabling Core Performance Boost on the bios, which prevents the CPU from going past 3.7Mhz, but it didn't work.

I'm almost sure the problem is with the CPU, that's why I'm posting it in this section of the forum, but it might be something else, even the MOBO. I'm desperate and I don't quite know what to do.

6 Replies

You might also want to try posting on msi support forum, someone there may suggest stable bios settings for the board model ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

what cooling sir?


I'm using a Cooler Master H410R. I've never seen temperatures go above 62ºc (143ºF), even though I live in a very hot country. Most of the time it sits at 30-38ºc on idle and 55-60ºc under heavy load.


I'm using the default settings, and I don't want to mess with voltages.


You have weird issue and saw this post maybe can help you


hope you figure it out...


Don't see your ram model on the msi qualified list ?

Who said anything about messing with voltages.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..