cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

bash64
Adept I

qemu upgraded from intel to amd...all file accesses result in 80% cpu usage

Hello,

I used an msi gt 70 laptop with i7 4940mx cpu and intel/nvidia integrated graphics for over 5 years.

QEMU ran like a champ. Long story on how I got gpu passthru to run on an optimus board.

At one point I switched to using a 1TB intel ssd to speed up gaming a bit. It worked.

Just last month I began building my dream machine.

I am in $3000.

I wanted to render with opencl and cuda and and do gpu passthrough without rebooting into a special ramdisk.

AMD promised me a lot.

My specs:

amd threadripper gen 2 12 core, 32gb of ram

msi x399 carbon pro

amd radeon pro duo r9 fury X liquid cooled.

nvidia 980 ti oc.

The issues:

I could not passthru the nvidia card so i swapped video cards and passed thru the radeon.

It worked. Installed w7 drivers.

The test games are fallout 4 and fallout 76.

They run fine until the game must 'zone' and load more 3d objects and more textures.

That's when the fun begins.

On the linux side my threadripper cpus jump from 20->40% cpu usage to 80% cpu usage and the game lags till I cant even move anymore.

This all worked on my old system no issues.

Same qemu. Same virtual hd. Same SSD, but only 4 cores and not 12.

I did change my script to remove kvm=off which is for nvidia only.

I was also told that my cpu did not support hyperthreading.

So I changed the -smp line to compensate with 1 socket and so many cores.

(I do not use a gui/libvirt ,etc....I have always used a script.)

I hope someone out here has some insight as to what is wrong.

I do use redhat virtio drivers (scsi and nic). I hope they are not for intel only.

I removed the scsi driver and installed Microsofts driver and it got worse so I put it back in.

I am using the last bios made available for my board.

I also use the 'rcu_nocbs=0-23 process.max_cstate=5' kernel boot options to prevent constant crashing in linux.

and, yes, it works quite well.

All help appreciated.

Tags (3)
0 Likes
2 Replies
bash64
Adept I

Re: qemu upgraded from intel to amd...all file accesses result in 80% cpu usage

Hello,

I answered my own question with the title 'upgrade intel to amd'.

Windows 7 is getting old. It can't handle modern hardware or ryzen cpus properly.

I had a windows 10 virtual machine but never used it for gaming.

It works perfectly. Flawless.

I think it all has to do with modern timers and cpu drivers.

Sorry windows 7, but I have to move on.

New hardware requires a new OS.

Being pure linux I always assume the issue is a linux issue.

Never occurs to me that when using windows 7/10 in a virtual machine that you still have to consider what the hardware and software limits are of the copy of windows are that you are running.

This build is perfect.

Things to remember:

1) Nasty hardware bug in ryzen cpus crashes linux constantly. Use 'rcu_nocbs=0-{xx} processor.max_cstate=5' on your kernel boot line where XX= the number of threads you have minus 1. I have 12 core with 24 threads so I use 23.

2) Windows 7 is old. Move on to windows 10 for qemu with gpu passthru and windows gaming if you have modern amd hardware.

waltc
Miniboss

Re: qemu upgraded from intel to amd...all file accesses result in 80% cpu usage

bash64 wrote:

Hello,

I answered my own question with the title 'upgrade intel to amd'.

Windows 7 is getting old. It can't handle modern hardware or ryzen cpus properly.

I had a windows 10 virtual machine but never used it for gaming.

It works perfectly. Flawless.

I think it all has to do with modern timers and cpu drivers.

Sorry windows 7, but I have to move on.

New hardware requires a new OS.

Being pure linux I always assume the issue is a linux issue.

Never occurs to me that when using windows 7/10 in a virtual machine that you still have to consider what the hardware and software limits are of the copy of windows are that you are running.

 

This build is perfect.

 

Things to remember:

1) Nasty hardware bug in ryzen cpus crashes linux constantly. Use 'rcu_nocbs=0-{xx} processor.max_cstate=5' on your kernel boot line where XX= the number of threads you have minus 1. I have 12 core with 24 threads so I use 23.

2) Windows 7 is old. Move on to windows 10 for qemu with gpu passthru and windows gaming if you have modern amd hardware.

 

 

 

 

 What a great post bash 64!  I only wish that most folks were as honest and smart as you obviously are....;)  Yes, Win7 is very long in the tooth and is in its last year of support by Microsoft--you would think people would be more savvy about Win10 supporting much newer hardware and doing it better than Win7...! It's hard to understand the people who say, "It isn't fair that Win7 didn't support hardwaer that hadn't been invented when Win 7 shipped, eh? 

0 Likes