Showing results for 
Search instead for 
Did you mean: 


Adept I

Problems with my Ryzen 9 3900X (Brand New)


I just bought a Ryzen 9 3900X processor. I've read online at the following site: )

that it is ECC Ram Compatible, but the AMD website doesn't make it clear if it is ECC compatible.

I also have a question about the compatibility of a Asus 570-P Motherboard. I bought a Refurbished Motherboard and it won't boot BIOS , no Post LEDS. I bought a Apevia 1000W Power Supply and I notice that it doesn't have a -5v plug, and the Motherboard pinout labels a -5v port. I hooked up a Old PSU with a -5v plug but the Motherboard still will not boot to BIOS.

If anybody has had these problems, please let me know what I need to do to fix my problem.

Thank you for your time.

1 Solution

That memory is not compatible.  It is a form of buffered memory which Ryzen does not support, regardless of whether you get error beeps or not.

Additionally, even for unbuffered ECC RAM which Ryzen (unofficially) supports, the motherboard must also support it.


View solution in original post

19 Replies
Adept I

My RAM is A-Tech 128GB Kit DDR4 2133MHZ PC4-17000ECC

Motherboard : Asus Prime X570-P ( "Refurbished" )

Brand new Apevia ATX PR1000W Gold

Volunteer Moderator

Looking at your motherboard manual, I do not see a -5V port.  I see two 12V ports at the top of the motherboard.  Please remove your second PSU connection and stick with just the one PSU.  If you have the EATX motherboard power connectors powered at the top and right side (two connectors at the top, one big connector on the right side, and the CPU installed, the motherboard should power up into the BIOS.  The ECC memory should work too; at least the BIOS should come up.  Do you have any LEDs illuminated at all when powering up?

Does your PSU have both plugs?Does your PSU have both plugs?

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

Yes my power supply has both plugs.

Now I've just read a forum post where they say a motherboard will fail POST if you don't have compatible RAM installed. I did not have a buzzer installed during my first test, and I'll be installing a buzzer to see if my motherboard is trying to tell me anything. Also, it's still unclear if my RAM, which is Registered, is going to work or not....

"Wait for them to ask you who you know." Tyler Joseph.

You should also clear the CMOS, so when it is powered off, remove the CMOS battery for 10-15 minutes and then put it back in.  As an suggestion, I always replace the CMOS battery when working on a motherboard where the age of the current CMOS battery is unknown.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

I tried to powerup my 570-P with my processor and one stick of Registered RAM with a old piezo buzzer. It does not light up any LEDs other than the MoBo Fan. No beeps. No screen.

My Piezo is old and I was going to buy a new one just in case...

But will the MoBo light up at all with wrong RAM? Because I'm still uncertain of my compatibility with Registered RAM.

I also took out the MoBo battery and waited 15 minutes.

I think I'm going to buy Non-Ecc RAM. But I'm kind of sad this build has taken so long...


Maybe you can borrow a few sticks of non-ECC RAM (regular DDR4 stuff) from another build and test the motherboard that way.  It could be that you have a bad motherboard.

By saying 'Registered RAM' that you tried one stick of, are we talking ECC RAM?

I saw this on another site:

ECC and Registered are two different things.

Registered memory is buffered and is slower than regular memory and is usually only used on machines that have a ton of RAM for added stability.

ECC is error correcting memory - the module itself will correct single bit errors.

Usually, you see modules that are both ECC and registered, but they can be either or as well.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
Adept II

i know the 3900x is new, but it may be worth while checking for bent pins on the CPU or checking there is nothing untoward with the socket.  I have heard of issues like this where some thermal paste had got into the socket which can stop the pin or pins from the CPU making contact

Also, in addition to trying different ram, if you have the option, it could well be worth trying a different CPU if you can just to confirm the MB isnt actually dead given its a refurb

All Ryzen Processors UNOFFICIALLY support ECC. Depends on your Motherboard and Specific RAM Number.

You need to look at your Motherboard's QVL List for RAM for the 3000 series AMD Processors. In that list it will show, if any, ECC compatible RAM numbers.

Unfortunately, Asus QVL List doesn't indicate which RAM is ECC or not like in other Motherboard QVL Lists.

I suggest you open a Asus Support and ask them which specific RAM Number support ECC on their Motherboard.

Your Asus Memory Specs:

Screenshot 2022-06-11 234746.png


Your Motherboard doesn't come with the standard Boot TROUBLE LEDs (CPU, RAM, GPU, SYSTEM) So you need to attach a PC Speaker to hear the Trouble BEEPS to determine what general area is failing during the Boot Process.

From your Asus Motherboard:

Screenshot 2022-06-11 234746.png

Also make sure you have the Motherboard CPU Power plug connected - 8 Pin Power otherwise it won't boot up.

Once you have the PC Speaker connected boot up and hear the sequence of Beeps while booting up.

Best way is to remove all hardware from your Motherboard except PSU and CPU. The beeps should indicate missing or bad RAM which means the CPU passed the BIOS test.

Add one stick of RAM and see if the Beep sequence changes now to GPU trouble beeps. That means both the CPU and RAM passed the BIOS test and so forth.



My apologies. I swear I read somewhere on the following ad-link that it said Registered RAM. But its ECC Load Reduced.

Now I tried powering up the MoBo with an old Piezo Buzzer I had, but either my Piezo is bad, or my MoBo isn't beeping. I'll try again real quick with a different old Piezo and report back...

I also will need to order Regular DDR4 RAM as I don't have a pc built with DDR4...

You may have a defective "Refurbished" Motherboard. Depends on what was done to the Motherboard to get it Refurbished. Sometimes a User returns a good Motherboard and the manufacturer tests the board out and if it passes it sells it as "Refurbished".

Or by "Refurbished" the motherboard was actually defective and the Manufacturer repaired it.

With just your PSU and CPU installed you should get a RAM Error Beep from your PC Speaker. If no beeps possibly a bad motherboard.

Yes if you have incompatible RAM installed it might prevent the PC from booting up or BIOS will beep with RAM error.

If you need to use ECC Ram Memory the best Consumer Motherboards are the ThreadRipper that does list ECC RAM in its QVL Lists.

I just tried a Piezo I know works. And with no RAM installed I'm getting: one continuous beep, followed by 2 short beeps, uncontinuous.

I installed one stick of RAM and now its not beeping to tell me I dont have either a VGA or a Keyboard installed...

Now I'm really confused...


At least you know your CPU passed the BIOS POST Test.

Are you using the ECC Ram or a regular RAM stick?  IF the RAM is not working you should still get the RAM Beep error.

Try different RAM DIMM Slots and see if you get the same issue. If you do it is possible you have a defective Asus Motherboard and would open a Support ticket either with Asus or the Retailer you purchased the used Motherboard with.

What should have happened when you installed a compatible RAM with no VGA (GPU) installed you should have heard a VGA Beep error. Meaning that BIOS POST tests passed both the CPU and RAM Stick installed.

Try installing a GPU card and see if you get any video output into BIOS. I believe you need at least one Stick of RAM to get video Output into BIOS.

That memory is not compatible.  It is a form of buffered memory which Ryzen does not support, regardless of whether you get error beeps or not.

Additionally, even for unbuffered ECC RAM which Ryzen (unofficially) supports, the motherboard must also support it.


The motherboard says ECC compatibility dependant on Processor.

Thank you for your help. I will be returning this Buffered ECC Ram and purchasing regular RAM. I thought this cheap ECC RAM was too good to be true...

I'll send y'all reports as the RAM comes in.

Yes, I believe the Ryzen APU's don't support ECC at all whereas the non-APU Ryzen's do, so that's why they say 'dependant on processor'.

If you need the extra reliability of ECC, just make sure it's unbuffered (unregistered) ECC, and check with Asus for compataility.  Ryzen's are picky enough as it is about non-ECC RAM.



Some key notes

Apevia is not exactly known for Quality

Ryzen only works with Unbuffered ECC DIMM's .. aka .. UDIMM's 

You need a video card of some sort to boot properly

I run my 3900x with mismatched ECC UDIMM's , 2 x 16GB 3200 ECC UDIMM's and 2 x 16GB 2666 low profile ECC UDIMM's .. all at 2666 without issue on an ASRock X470D4U

I ran the 2 x 16GB 3200 ECC UDIMM's for a short time with a 3700x on my wife's B550m Phantom Gaming 4 without issue

ThreeDee PC specs

I've got a Amd 580 Devil Gpu to put in this build. And it seems like the best idea is to just buy regular UDIMMs.

Does anyone have anything to say about these?



For a regular desktop setup .. go for regular non-ECC memory

Check out reviews on  your 1k Apevia PSU and decide whether or not you want to keep running it

IF you value your hardware .. you might want to go with a quality unit. Never skimp on the power supply


ThreeDee PC specs