cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

alexfigini
Journeyman III

Poor Performance 1950x Threadripper

Hi all,

I'm pretty desperate for some help and advice. I have had my threadripper for about a year now and have had issues from the get go. Poor/erratic performance, stuttering, freezing etc. I have a laptop with much lower specs and an intel chipset and it runs all the 'problem' programs and files just fine.

I work primarily with zbrush, keyshot and marvelous designer. All 3 pieces of software are quite CPU intensive, hence why I bought a threadripper. Unfortunately all seems to run pretty badly and has made my desktop pc pretty redundant.

Specs are as follows:

Win 10 -  64bit

MSI X399 Gaming Pro Carbon/AC Motherboard

AMD Threadripper 1950x

64GB (4x16) RAM G.SKILL RIPJAW V

NVIDIA GeForce GTX 1080 Ti

NVIDIA TITAN X (Pascal)

Can you see any potential issues with this hardware arrangement?

Any help much appreciated.

Cheers

Alex

0 Likes
7 Replies
misterj
Exemplar

Re: Poor Performance 1950x Threadripper

alexfigini, please post your power supply, versions of OS and UEFI.  Also post a screenshot of Ryzen Master (RM).  Also search here for threads on 1950X performance issues.  What applications are you running showing poor performance?  Thanks and enjoy, John.

EDIT:  Please see this - specifically the Leve1 link.

alexfigini
Journeyman III

Re: Poor Performance 1950x Threadripper

Hi Misterj,

Power supply is a corsair AX1500i

OS is Win 10 Pro

Ver 1803

OS build 17134.345

MSI X399 Carbon AC

BIOS ver 7B09v1B (latest version)

I am getting crashing and stalling/freezing in Marvelous Designer, slow performance and doesnt seem to use all the cores even when you stipulate no of cores to use in settings, I have had horrible stuttering/lagging in zbrush when navigating models (rotating/zooming) this gets worse the more subtools I have. When working on a single mesh it runs ok. Keyshot seems to run ok but not to the performance I'd expect from the 1950x. Some issues with photoshop but that maybe because the latest edition is garbage :-/

Hope that helps you identify a potential issue.

Cheers!

Alex

0 Likes
misterj
Exemplar

Re: Poor Performance 1950x Threadripper

alexfigini, please look into this Beta UEFI - 7B09AMS.1C6.  It contains AGESA!V9.SummitPI-SP3r2-1.1.0.2, so newer than yours and the latest, I think.  I found it in the MSI AMD Boards Forum.  Svet posted it - good person.  Search the UEFI name and see what you can learn.  Please post the Ryzen Master (RM) screenshot.  Here is mine when I was running a 1950X:

MyRyzenMaster.jpg

Enjoy, John.

misterj
Exemplar

Re: Poor Performance 1950x Threadripper

alexfigini, I am running what I think is an equivalent UEFI on my MSI X399 MEG Creation with a 2990WX.  I am running E7B92AMS.127 and it has corrected a number of problems for me and others.  I do not like and seldom use Beta UEFIs, but please do not let the paranoia of elstaci effect your decision about trying it.  MSI seems to be very slow on releasing fresh UEFIs and often releases Beta ones on the forum.  The currently released UEFI does not even contain the latest AMD AGESA version.  I think, but do not know, that Svet is a support person and I had a Beta UEFI sent directly to me via e-mail by another support person and I am waiting for a new one to allow me to get RAID working again for me.  Please see this thread and others discussing Beta UEFIs.  I wish MSI managed UEFIs better, but that is the environment we are operating in at the time.  Please ask any questions.  Enjoy, John.

0 Likes
misterj
Exemplar

Re: Poor Performance 1950x Threadripper

To be clear, I did not say to install this Beta UEFI.  It is strictly alexfigini's choice.  I know some, including me, do not like running Betas.  Since MSI seems to operate in this mode, I find I have to use Betas.  What is usual for some MB vendors is not normal for MSI.  So far, it has worked fine for me.  alexfigini's board, as mine, has FLASHBACK+ which allows flashing the UEFI even if the system will not boot and even if there is no processor present.  It is easy to use, has never failed me through several uses on two different MBs (including different vendors).  Once I see the Ryzen Master screenshot, perhaps I'll have a hint.  Enjoy, John.

0 Likes
alexfigini
Journeyman III

Re: Poor Performance 1950x Threadripper

Hey John,

Here is a grab of my Ryzen Master

RM_GRAB.jpg

0 Likes
misterj
Exemplar

Re: Poor Performance 1950x Threadripper

alexfigini, comparing our two screenshots, what stands out is CPU voltage.  Yours is 1.25 and mine is 1.475.  That can make a large difference.  I am not  OCing, so wonder why yours is so low.  If you do not have the latest AMD Chip Set installed, please go here and get a copy.  The Ryzen Balanced Power Plan comes with it.  Be sure you are running it.  Have you run a Clear CMOS lately?  If not please, do.  After these steps, please post a new screenshot of RM.  Hope this helps.  Thanks and enjoy, John.

0 Likes