Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Performance periodically drops all cores to 600mhz while under heavy load, 2990wx


Screenshot says it all - any indication to what/why? I'm running BIONC as my method of hammering the CPU to test cooling, etc. Runs fine, stays under 68C, but then will drop to very low levels (600mhz, all cores) every so often - well below base clock; enough where my cooling system will drop 10C.

Relevant Specs

2990wx; everything on auto/defautls in BIOS
G.SKILL RAM for AMD; 2933, the 14 CAS version; running at 2933 / XMP profile
Gigabyte Aorus xTreme F5c BIOS
Coolermaster ML360 RGB TR4 Ed.

Thermal paste used is what was included with the ML360

5 Replies
Big Boss

jenksdrummer, I have not seen CPU temperatures this high, even under load.  I suspect something is wrong with your cooling system.  Right now my CPU temperature is 26 C with no load.  My specifications:

MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on

MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,

Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,

Radeon RX580, UEFI E7B92AMS.127, AGESA SummitPI-SP3r2-1.1.0

I do not think I have ever seen temperatures close to 60C.  I am running my pump and CPU fans on 12 volts and connect the CPU Fan & Pump speed sensors to the MB headers.  Please do something similar and let us know what RPMs they are turning.  If the water block is in good contact with the CPU, the TIM makes little difference.  Good luck and enjoy, John.

Those temps aren't idle, that's with all 64 threads running 100% for more than a few a 10*12 bedroom with the door closed so not the most ideal airflow or ambient temps.

Idle, it sits around 30C, ambient is probably around 75F.

Case venting is mainly out the back, again not ideal, sits under a desk with about 6" above and only 4" behind. Plenty of room for it to inhale through the front, where the radiator sits behind a door (fractal R6); fans are set to pull cool air through the radiator, so maybe that's not ideal...

Could be too much TIM, but, also why I'm running it hot so ideally that will melt what might be overkill.

Before water, it was a noctura HSF, the recommended one...and it did similar, just took less time.

As for RPM, at this temp, they scale to between 90-100%. It doesn't tap the 68c throttling temp. It just bulk-throttles for about 10 sec to 600. I didn't see that before with the HSF. Maybe it's the PWM reaching a temp threshold and choking the CPU?


To run the same test...install BOINC, runnas service option for install...use Einstein@home. Let it download and run on all'll have 64 threads running 95+% for around 8 hours per job file.

I've not found a more strenuous test than it's for science!


Thanks, jenksdrummer.  I will look into running a test but am really busy right now.  In my experience, TIM makes little difference unless there are blank spaces or it is squeezing out the sides.  I think I would suggest you place your machine in the open, remove the sides, aim a box fan, connect your CPU fans and pump directly to 12 volts and connect the speed sensors to MB headers so you can monitor the RPM.  I hear many users complaining about MB PWM controls not working correctly.  If your cooler has an application, crank the speeds to a maximum.  Please post you current RPMs for fans and pump.  Enjoy, John.

EDIT:  I DLed BOINC and tried to get going, but kept getting failures.  I need to do an install on this machine, so will retry later.  Sorry.

Journeyman III

A bit of an update. I applied new TIM and no change. I swapped systemboards from a Gigabyte Aorus 7 to an MSI MEG; temps now won't go over 62C under 64 threads of load. Awesome.

To that, I believe I may have had a bad board. Came in a sealed box, but it would do some whacko stuff like revert to a previously saved setting. maybe 1 out of 5 reboots; such as it would disable the onboard RAID function if that was the last change made; but not flush out all the settings. Maybe 1 out of 20 times, a reboot of the machine would result in BIOS getting reset to factory defaults. Tried different firmware (F3 came loaded; tried F4, F5c), no change. Minimal hardware...nothing I did would make this stable. Running - it was great. But reboot it; it was a coin flip. I could at least tell it was going to act up as it would about twice as long to get the BIOS splash screen.

Anyhow, flipped to an MSI board and it's working fine / much cooler / no quirks that I can see.