cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

kinggeorgeGPU
Journeyman III
Journeyman III

PCIe 16x slot not working 5600x RTX 3070/Vega 64/R9 390

Top PCIe slot does not work, my best guess is the CPU but I want to try everything before I RMA it.

Current parts:

5600x
RTX 3070
MSI MAG b550 Tomahawk

Old parts:

Ryzen 2600
RX Vega 64
ASUS Rog Swift B450-f

So I bought the 5600x first, updated my b450 bios the correct way, and went to start it up. Had no display in the top PCI slot with the vega 64. VGA light was on on the motherboard. I tried an R9 390 and it also did not work. Both cards, the Vega 64 and 390 worked in the bottom slot. I put back in my 2600 and both cards worked in all slots. I thought maybe my Motherboard just didn't like the new CPU so I bought the b550.

Same problem with this brand new board. Top slot didn't work for the vega with the 5600x (updated bios first thing). All slots worked with the 2600.

Bought the 3070 because I wanted to upgrade anyway, put it in tonight and no top slot display, VGA light on.

So, my conclusion is either some funky complication between the bios and parts OR the CPU has a bad PCI lane. I was going to RMA the CPU but i've seen a few others with the same issue.

The most likely problem is the CPU in my opinion but I know it's very rare.

0 Kudos
1 Reply
elstaci
Esteemed Contributor III

Re: PCIe 16x slot not working 5600x RTX 3070/Vega 64/R9 390

In BIOS Settings have you tried to set the first PCIe lane as 3.0 instead of 4.0 to see if it works?

It is possible BIOS set the first PCIe lane as 4.0 and is not compatible with the GPUs you have installed. which may explain why it works in the second PCIe lane since that one is 3.0 and not 4.0 supported.

0 Kudos