Showing results for 
Search instead for 
Did you mean: 


PC Stuck in a Cycle of Turning Off and On After Installing New CPU

My PC gets stuck continually turning on and then off again after a few seconds after I installed the Ryzen 7 3700 CPU. I cannot even get into the BIOS. I am able to get my PC running again fine when I reinstall the old CPU (Ryzen 1400)

Any idea what is going on? What other things can I do to try and fix this?


What I've tried so far

-flashed BIOS v6.00

-reseated the RAM

-cleared cmos by unplugging all PC cables and removing the MOBO battery for half an hour

-pulled out my hair



Motherboard: ASRock X370 Killer SLI/ac

Original CPU: AMD RYZEN 5 1400

CPU that makes my computer continually reboot: AMD RYZEN 7 3700x

more info from previous reddit post

20 Replies

I went to your Motherboard's CPU SUPPORT LIST and BIOS Download page:

The Ryzen 5 1400 is a Summit Ridge processor and according to ASRock's BIOS Notes on version 6.0 this is what is says as a warning in yellow:

Screenshot 2022-01-20 180433.png

Also if you upgraded from the Ryzen 1400 to the Ryzen 7 3700X the current RAM you are using may not be compatible with the new processor but compatible with the 1400 processor.

Also when you update the BIOS you need to update FIRST the motherboard's ALL IN ONE CHIPSET/GRaphics driver:

Screenshot 2022-01-20 180433.png

I think elstaci may be right about the RAM being incompatible. The RAM I had install does not appear under the list of compatible ram from amd.

 I purchased new RAM that did appear on the list so I will try it when it arrives tomorrow.

For installing the ALL IN ONE CHIPSET, I messed up the order and have already flashed to BIOS v 6.00. Can I flash to earlier BIOS versions safely in order to correctly install the graphic drivers? 


I'm running an X370 MOBO.

It will not support any AMD CPU beyond a GEN 2 Ryzen 7 series.

If that new CPU is a GEN 3 Ryzen 7 or higher that could be the problem.

If that is the case then the R7 3700 will not work on your MOBO. 

RE: ThunderBeaver 

"If that new CPU is a GEN 3 Ryzen 7 or higher that could be the problem.

If that is the case then the R7 3700 will not work on your MOBO. "

This must be the issue then. This is the CPU I purchased. It says it is a 3rd Gen


Hold onto that CPU for a future upgrade.

You didn't waste money you just made an early investment on your next core system component upgrade. 


Even if the Motherboard's VRM is not powerful enough for the 3700x it should, at least in my opinion, still boot up into Windows.

Plus the 3700x is listed on the Motherboard's CPU SUPPORT LIST so I know the manufacturer has tested that processor on the motherboard before adding it to the CPU Support list.

But it is possible that it depends on which Model 300 series motherboard you have. Since some Users have had issues with the 3000 series CPUs on the 300 series motherboards.

Plus I have read that the 300 series VRM may not be powerful enough to properly run a 3000 series CPU but it still should boot up and not go through a Boot Cycle.


Your MOBO show support for the Pro 3700 65 watt with BIOS version P5.50 and 3700X 65 watt with BIOS version P5.40.

You may just need to download the Bios that corresponds with the specific 3700 CPU you bought. 

Ok you have the 3700X so you will need BIOS version P5.40. 

Wow my MOBO CPU support list changed the last time I checked it would only support up to the Ryzen 7 2700x. Now I can use up to the Ryzen 9 3900XT or 3950 CPU. Though I must admit its been about 8 months since I last checked my support list. We both learned some new things today.

Oh thanks again Elstaci your post made me realize I needed to search a little deeper to help with this issue. Though I had to wait due to the 10 minute post flooding thing to pass this info on to this thread.

I agree with elstaci..
My 370 board would at least boot and was listed as working with 3700x..
It was a good quality Asus which had no problems from the day I purchased it, but the VRM's were not man enough...
AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.

My Asus Prime x370 pro would not run my 3700x...

I had the latest drivers and everything else up to date..

The VRM's on x370 are not sufficient to give stable power..

I got my new mobo x570 and it has been perfect..

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.

Theoretically it should work but it wouldn't surprise me if you need a 450 or higher board.  


Here is the Display Recovery SOP




/sig Fun guy.

What BIOS were you on? Does it say 6.00 in your BIOS currently? (with old CPU)

IF you were on an older than P3.50 ..then you'd have to update to THAT version before updating to P5.10 .. THEN AFTER updating to P5.10 .. you can update to P6.00

There is an order that needs to be followed IF you didn't follow the flashing order, THAT could be your issue. The 65wt TDP 3700x should run just fine on your motherboard if the BIOS is properly flashed/updated


With your old CPU installed .. Make sure to install the latest AM4 Chipset driver from and THEN start flashing

Make sure your RAM is installed in slots A2/B2 (2nd and 4th slots away from the CPU socket) IF you are running only 2 sticks of matching RAM

ThreeDee PC specs

RE: ThreeDee
 It does say v6.00 with my old CPU when I load into bios. I think I missed one of the Chipset drivers. Can I temporarily downgrade my BIOS in order to download the drivers I need?


Yes, on page 6 of the ASRock Display Recovery SOP you can see Method 2

<Method 2>
Downgrade the BIOS
temporarily and install a new driver from ASRock website
1. Please check the BIOS download page
Download a BIOS version that is older than a BIOS with PinnaclePI AM4_1.0.0.5/
Use Instant Flash to downgrade the BIOS.
(*Please refer to the ASRock website and make sure the CPU is supported by the old BIOS version)
2. After downgrad ing the BIOS the system should be able to get d isplay output under the OS.
Please start the system to boot into the OS.
3. D ownload and install AMD all in 1 with VGA driver ver:18.10.20_NHDA_WHQL or later
version from ASRock website:
4. After the driver installation please make sure that device manager show s graphics driver
version 24.20.11020.2 (or newer

So follow these steps -

1. It says (*Please refer to the ASRock website and make sure the CPU is supported by the old BIOS version) so make sure you start with your original Ryzen 5 1400.

2. Download BIOS v4.80 for your MB @ Extract and copy X370KLA4.80 to USB flash drive. Restart, go into BIOS and use Instant Flash to downgrade to v4.80

3. Now, download and install your chipset and VGA drivers. I don't see an All in One package, so download both and

*Above links are for Windows 10 64bit

4. Reboot to Windows and confirm.

5. Your chipset and VGA drivers are now updated for the new CPU, so download the latest BIOS extract and copy to flash drive.

6. Swap the Ryzen 5 1400 with the new Ryzen 7 3700X

7. Insert your USB flash drive with the new BIOS v6.00 and use Instant Flash to update

I hope this helps and works for you!



/sig Fun guy.

FINALLY FOUND A FIX!! I was helped in this post

I removed both sticks of RAM and then installed only one. The PC booted up as it normally does but now with a new CPU! Not sure why this happened, both sticks of RAM worked with the old CPU. Now I need to figure out how to get the machine to run with both sticks of RAM!

Interesting, are they in the right slots? Maybe a ram training thing, is xmp off?

3700X, Aorus X570 Pro WIFI, XFX MERC 6700XT, 32GB CL16 3600.

If you are able to boot with one RAM Stick but not two does indicate that RAM is not compatible with your new processor.


to get it to run on both sticks manually set the RAM voltage to 1.350 or....1.400 should boot two sticks up just fine ....i have the same issue with my 1800x system any ram i try and it dont matter the clock speed seems to like the ram at 1.35 for anything up to 3000 mhz and 1.4 volts up to 3600 mhz....even got some running 1.4 volts at 3822 in my 3950x rig

I was able to get the PC to boot and run with both sticks when I enabled an XMP profile (1.35v, 3200)  in BIOS! I think they needed a higher voltage to run properly. So I can get 16Gb(2x8Gb) of RAM running on my PC now.

I also purchased 32Gb(2x16Gb) of the same brand and speed of the ones that work. However when I try and replace the 8Gb sticks with the 16Gb sticks, it goes back to turning on and off. I think it is resetting the XMP profile because when I reinstalled just an 8Gb stick, I boot into bios and it has been reset.

How can I ensure the correct XMP profile for the 32Gb of RAM when I can't get to the BIOS with them installed?


16(2x8Gb) RAM: G.Skill Trident Z RGB Series 16GB (2 x 8GB) 288-Pin SDRAM (PC4-25600) DDR4 3200 CL16-18-18-38 1.35V Dual Channel Desktop Memory Model F4-3200C16D-16GTZR 

32Gb(2x16Gb) RAM: G.Skill Trident Z RGB Series 32GB (2 x 16GB) 288-Pin SDRAM (PC4-25600) DDR4 3200 CL16-18-18-38 1.35V Dual Channel Desktop Memory Model F4-3200C16D-32GTZR 


sometimes these Ryzen systems will reboot when new ram is installed ... its a memory learning thing going on ...i think some motherboards are factory set to reboot at the least up to five times before its happy with the settings its trying to use before it just gives a memory or a cpu error ....Ryzen can be very picky with what ram you use also ...and like i said most all ram in my experience with Ryzen likes 1.35 to 1.4 volts ....ive built over 8 of these rigs and tunned them....some ram will not even work with xmp enabled even at 1.35 volts ....enable xmp if you still get the reboots none stop bump it up to 1.4 i wouldn't take it over that...ryzen rigs really love any ram with Samsung die's mostly b and e die but seems to like all that Samsung ...i dont know who uses what i always buy and use corsair vengeance or the pro versions of it for the systems ive built ...its always worked might also try reseating your cpu in the socket firmly ...not massively hard but firmly pushing down with your thumb when you lock the bar in its place you will have to go into bios and turn the xmp off and just set it to default ....reinstall the others and reenter bios and go back to xmp....i do not know about gskill ram in ryzen never used it is a great company with some good ram though .....dont know what they use for ram dies either long as your running just the 32 gig kite you should be golden ....if it wont boot on 1.35 volts go 1.4 ...all you can do is try it man ..makes sure you got no other overclocks going on ..return every thing in bios to default and start with ram before doing anything else