Showing results for 
Search instead for 
Did you mean: 


Journeyman III

PC is randomly slowing down after switching CPU from 3900x to 5950x

Hi everyone. Two days ago I replaced my 3900x with 5950x and looks like there's something wrong because sometimes - after using PC for some time - it is slowing down a lot, everything is very laggy and I have to turn my PC off and then back on to bring it back to the full speed. And I have to switch my PSU to 0 and then again to 1 to make it work with full speed, simply restarting PC doesn't help. I'm a 3D artist so I have checked Corona Renderer benchmark 1.3 and when everything is fine it reaches about 10000 rays/s and when this issue happens it only reaches about 1000 rays/s so 10x less. I have updated bios to the latest version so I guess that's not the problem. Does anybody have any idea what might cause this problem? I've never experienced anything like this with 3900x or before that with Ryzen 1700 etc. I'd be very thankful for help

8 Replies

I don't understand what you're talking about when you refer to the PSU. Are you saying you literally have to turn the Power Supply off using the power supplies power button? Anyway the problem itself sounds like the CPU is throttling. Which is usually the result of heat.

So a few questions;

What heatsink are you using on the CPU? Is it mounted firmly? And did you properly apply thermal paste to the CPU before attaching the heatsink?

What temperature is the CPU at idle in windows and when running a render? If you don't already have a way to check that there are a ton of utils, HWInfo is a good choice but you can google for alternatives.

What speed is the CPU running at , again when idle in windows and when running a render? You can check that just by using the Performance tab in task manager.

It could be another problem but lets rule overheating out first.


Thank you for your answer. What I wanted to say regarding PSU is that I had to disconnect my PC from the power supply (either by switching off PSU or by unplugging my extension cord plug from the socket) to make it work fast again, simply restarting didn't bring the full speed back but looks like if I shut my PC down and then turn it back on (so no restarting) then it works with full speed as well.  

And now regarding my heatsink: it's Noctua NH-D15s and of course I applied thermal paste. 

Regarding temperatures: right now at idle it's 47°C (or 116°F) and during rendering it was 81°C and 117°F. With 3900x it sometimes reached much more and everything worked fine. 


A few minutes ago that issue happend again and my PC wasn't doing any heavy tasks so I'm not sure that it's something about it's heavy usage and high temperatures. And when it was slow I used Corona Benchmark too see what HWMonitor is showing and it looked like this:

Voltages: it was 0.831V for all cores and normally when rendering it's 1.413V

Temparatures: it showed only 40°C (104°F) which is weird because even at idle it's a few degrees more

Powers: it showed 140.86W for the package and 0.50-0.68W for particular cores. When everything is fine it's even 200W for the package and 9-12W for particular cores. 

Currents: it was 135.10 A

Clock: only 547MHz for all cores except for Core 1 which worked at 533MHz and when everything is fine it's 4xxx MHz when rendering

Utilization: 100% for all cores


Then I turned my PC off and on and now it's fast again.  


Is there anything else that I could check?






Is there some sort of overclock at play here?


"Voltages: it was 0.831V for all cores and normally when rendering it's 1.413V"


That seems incredibly high for a 16 core load as far as voltage is concerned.  What cooler/mother board are you using?


I only tested Ryzen Master with some default OC options, didn't do any OC in BIOS.

Mobo - MSI MAG B550M Mortar and the cooler - Noctua NH-D15s.


The first thing I would do is set everything back to defaults in Ryzen master.  Make sure you don't see the slow down issue with the default settings enabled.


Thanks again for all your answers!

So regarding Ryzen Master - at first I set everything back to default settings but a few hours later that issue happend again - first my PC/CPU lost half of its power (5000 ray/s in Corona Benchmark instead of 10000) and after a while it was 10x slower (1000 rays/s). Now I have completely uninstalled it so maybe that will help. 

As far as HWInfo: it showed there was no Thermal Throttling but Power Reporting Deviation (accuracy) that's right above it showed max 5000% and min 57% so I guess that's not normal?

Regarding mobo, BIOS, chipset etc. - it's MSI MAG B550M Mortar, I downloaded the latest AMD chipset this morning (and that issue happened 2 or 3 times after that) and I also have the latest BIOS (there's only beta version that is newer than my version). 



A little update: after a few hours of working my PC lost over time 50% of its power - this time it reached around 5000 rays/s in Corona Benchmark and in HWMonitor it looked like this (while rendering):

Voltages: 0.875V

Temperatures: 44°C

Powers: 148W for package and 1.91-2.13W for particular cores

Currents: 130.94 A

Utilization: 100%

Clocks: for some cores 2224MHZ, for some 2249MHZ, for other 2274MHZ


47 degrees at idle with the Noctua cooler does seem high to me. At idle my 5800x with an NH-D15 I'm currently seeing 29 degrees. Of course it'll vary a bit based on ambient temperature where you are, and you're running a 5950 not a 5800 but it does seem high. That said, I'm not sure that's the cause.

Like @ajlueke asked, I'd be interested to know what Mobo you're running and whether you're overclocking. 1.4v is also quite high. Please tell me it's not MSI and you're not using Game Boost to overclock.

Maybe it heats up enough to kick in thermal throttling but it's not removing it once the CPU cools down. When you see it throttle down again can you look at the Thermal Throttling section in HWInfo? It's not far below the CPU Temps and voltages as you scroll down.

Another thought, have you updated the AMD chipset drivers recently? And similarly, have you checked the motherboard support page to see if there are new bios' available? Maybe there are issues with the existing bios?