Showing results for 
Search instead for 
Did you mean: 


Adept II

New Ryzen 5 2400g build crashes after video playback post waking from sleep

Hello all,

Firstly let me say that I love my new build (my second Ryzen 5 and personally/individually my 37th new AMD CPU - 6th running in my house ATM)!

I have an issue, though, and am not finding anything like it here, ASRock's forum or elsewhere via the Google machine...

Twice now after the system has come out of sleep I have had video/audio playback begin to stutter then the screen fills with snow/static and I have no choice but to reboot.  This happened to me with an NHL game stream last night and my wife watching a x264 video played back in VLC tonight.  From a reboot or cold boot the system plays everything fine.

Specs of the system:

Lian Li PC-A05FN

Corsair AX850 and RM650i

ASRock B350 Pro4 (latest BIOS - 4.70)

AMD Ryzen 5 2400G using the Wraith Spire (w/Noctua NT-H1 paste) from my R5 1600 box

CORSAIR Vengeance LPX 8GB (2 x 4GB) DDR4 3000 CMK8GX4M2B3000C15

Toshiba OCZ ARC 100 240GB SSD

Seagate BarraCuda 7200.12 ST31000528AS 1TB HDD


The OS installation was an upgrade from 64-bit 8.1 Pro to 10 Pro Build 16299 and has all the latest updates through April.  Formerly I had an ASRock A770DE+ and Phenom 1090T setup in this case with an XFX R9 280X.  Before upgrading the OS I uninstalled all AMD drivers from Programs and Features as well as ran the latest DDU.

After Ryzen'ing up the machine I installed the latest chipset driver (18.10_feb) and video driver for the 2400G (17.40.3701-feb12).

Things I've done thus far:

     After the first encounter (after the Sharks game mind you!) I removed the AX850 in favor of a new Corsair RM650i.

At this point I'd like see if I can get any feedback from the community before I start hacking and whacking.  The system is 100% stable running the following CPU/GPU benchmarks:


Prime95 (Blend)

S.T.A.L.K.E.R. - Call Of Pripyat Benchmark (Ultra Preset @ 1080P)

Unigine Heaven 4.0 (can't remember the settings I settled with - will update here if anyone wants to know)

Unigine Valley 1.0 (can't remember the settings I settled with - will update here if anyone wants to know)

Ideas anyone?

Message was edited by: Robert Elmore
Reason: forgot to list storage under the system specs.

36 Replies
Adept II

FYI did the following and will report back if this problem arises a third time:

  1. From an elevated CMD prompt executed "powercfg -restoredefaultschemes".
  2. Uninstalled the RyzenPPM via the exe in the latest chipset driver build.
  3. Reinstalled the RyzenPPM via the exe in the latest chipset driver build.

Above step didn't resolve the issue.  Happened again while wife was watching a video via VLC.


Disable "Fast Startup" & Disable "Hibernation"


Thanks for the reply.  I was actually able to get this to happen from a cold boot for the first time.  I let Heaven run for nearly three hours without issue, stopped it and left the system on.  Came back to it hours later and started Heaven up again.  Somewhere around 30-45 minutes into the loop the issue happened...

I went into the BIOS, set the RAM back to Auto, saved/rebooted back into the BIOS and changed it to the XMP profile BUT set it to DDR4-2933.  Since doing that so far no problem.

While I wish Corsair made a DDR4-3200 8GB (2 x 4GB) Vengeance kit I can live with this as I wanted something low power but capable enough to play the litany of Steam games my son and his friends like + I expect Vulkan to take over here soon.


Ram can definitely cause problems. One of the most overlooked things people do is not buying ram off the motherboard supported ram list. Even then XMP is still an overclock and stability can vary. However since the manufacturer says it runs at that speed. You may wish to contact them. They might swap the ram for you with stuff that will work. Never hurts to ask.


Oh I know.  Corsair listed it as compatible with "select motherboards" here: AMD Ryzen DDR4 Compatibility - The Corsair User Forums

In my Workstation Ryzen system I got the CMK16GX4M2Z3200C16 kit and it has been terrific.  In this APU build I didn't need any more than 8GB of memory and I have no plans to OC since it's meant to be a purely media and mostly Steam gaming system so I went with see what happens.  While running at DDR4-3000 the anomaly occurred but that was a possibility thus I am just fine with this machine running at DDR4-2933 given the $130 dollar difference between the two kits.

Adept II

Welp same thing yet again.  Wife was watching a video via VLC.

Interestingly, this morning, I saw a graphics anomaly adjacent my mouse cursor as it changed to the spinning wheel as I cleared Firefox's browsing history.  Looked like a row of pixels 10-15 high/2-3 wide flickering.  I cleared again and didn't see it but I tried to launch Heaven and it crashed immediately.  Thereafter it ran fine and I was able to also run Prime95 (current build) for about an hour without issue each...

Somehow I feel like this will be resolved via a driver update but I am almost at the return window...  I filed a bug with AMD and asked them to look at this thread but have yet to hear back...


If you did a issue report that is like a suggestion box they don't answer you. If you open a support ticket with the following link they will respond: Email Form


That's the form I used ten days ago...  Aside from an auto-reply I've heard nothing since.

Anyhow since yesterdays occurrence I have switched the "OC Mode Change Switch" from "ASRock Setting" to "AMD CBS Setting".  Next I guess I'll try turning off CPB.

Would be nice if ASRock was up to the latest AGESA (I've seen rumblings that is out) but to be fair to them I had an issue a while back with a since pulled update in which I had no video with a Sapphire RX 480 immediately after successfully flashing/rebooting the system so if they are double-checking such before release I am good with that answer.


Guess I should have said they will be more likely to respond then they will. I have only had success with them answering me about half the time. Which is much better than any other way I have tried to contact. I don't know why they can't at least say we don't have a solution but we are looking into it. Just something to acknowledge situations would be nice for people that are affected by any number of current issues that go unanswered. A little communication would go a long way.

Adept II

Didn't get to posting these details last night but this issue happened twice again yesterday. 

One thing to note since the last time this happened --> I have updated the Chipset drivers to the latest release (Revision Number: 18.10.0418).

On the first occasion I was not home and again it happened while my wife was watching a video played back via VLC (3.0.1).  She recalled that it happened after she paused what she was watching and came back to continue to play it.

I had the same thing happen (also while watching a video played back via VLC which I had now updated to 3.0.2) a few hours after I got home.  I watched one video and a few minutes later started another and shortly into the second video the snow/static occurred.  This time I RDP'd into the system and everything was fine.  A/V was still playing back on the system but the physical screen was snow/static...  I use HWMonitor (v1.35) to monitor temps and noticed that it showed the CPU had all four Cores reporting that a minimum of 99MHz had been reached.

After rebooting the system via the remote session I was able to reproduce this 99MHz issue when pausing a video for a few minutes then clicking play.  Interestingly there was a brief stutter to the A/V when this happened.

After seeing that behavior I decided to remove the RyzenPPM and reset the Power Config defaults.  Rebooted and was able to again reproduce the 99MHz reported minimum Core clock as I did above...

To see if the snow/static issue would occur again I queued up dozens of hours of video playback and let the system run overnight which it did just fine...

That all being said I have not turned off CPB yet but now I don't see that as the problem.  I know memory compatibility is a potential to throw under the bus here but according to Corsair the 16GB variant of the 8GB kit I have is compatible with Ryzen (  Plus both Cinebench and Prime95 run just fine with this CPU and RAM.

Anyhow I spoke with a TSR this morning at AMD and hopefully will have some suggestions today to run with.

The HDMI cable is the same that this display has had for years now with the before mentioned R9 280X.  It can be replaced but I can't see how it is responsible for this.


Unless you are now running at higher resolution or refresh rate or have damaged the cable. I too doubt it is the cable.

You might try another media player such as media player classic. It is an open source project too and plays just about everything like VLC does. It would be curious to see if the issue is or is not application specific.


Oddly enough it appears the existing cable WAS the problem.  After work on the 24th I replaced the cable with a cable from a cable only retail store across the street from my work and thus far I have not seen the issue nor has my wife.  I've had the system queued up to play several hours of video every night since from 9-10 PM and come 6-7 AM in the morning no static/snow .

Crossing my fingers that we won't see this ever again.  This is my 7th APU and I am loving it!


dilacerated, I hope your system is good to go, but if the problem crops up again:  Unless I misread your earlier posts, you have taken a Win 8.1 OS with other HW and updated it to W10, removed drivers and installed drivers.  If this is true, please get a fresh copy of the latest W10, here, format your C-disk and installed the latest.  My W10 is 1709.16299.371.  You should get update level 402.  Good luck and enjoy, John.


Correction to your understanding: I uninstalled all AMD drivers/software before the OS upgrade (ran the uninstaller in Programs and Features and then the latest DDU in Safe Mode).

Anyhow I am on 1709 (Version 10.0.16299.371).  Last night I setup a new LG UHD TV on the system and everything was running fine until about 5-6 hours ago while I was out running errands...  Wife was watching a DVD via VLC and with her description and the photo she took the screen looked like this:

Having some trouble with the Ryzen 5 2400G. Anyone else experiencing problems like this? - Imgur

Same as before --> I RDP'd in and everything was fine.  After rebooting from the remote session I have had the system looping UNIGINE's Valley benchmark without issue for over four hours now.

I am going to hold on and see what happens with whenever ASRock provides it.  If after that I see an issue again I'll format/reinstall and go from there.


Valley crashed not long after this post.  0xc0000005...  I'm guessing RAM and integrated Vega volatility maybe...  I noticed that going from the "ASRock Setting" to "AMD CBS Setting" causes the CAS Latency to go from 15 to 16 so perhaps there's something glitching there with the XMP Profile.

Anyhow am going to weigh requesting a refund for this RAM and concurrently buying the Corsair 3200 16GB kit that I have in my Workstation that has generated zero issues (CMK16GX4M2Z3200C16).


I'd say it's time for an RMA either that board or processor has an issue.


I see that 402 (KB4093105) is in MS's Update Catalog so I'll download and install that right now.


dilacerated,  I still think you need a fresh install of the latest W10, the order of removing the drivers makes no difference.  If you get a new board, you will have to reinstall.  At this point, I certainty cannot say that it would correct your issues.  I would also suggest you look into G.Skill memory with Samsung B-die chips (Ryzen and B-dies seem copacetic).  Please do go to factory default settings before more testing.  Enjoy, John.


Cool! Glad you are going. I had a weird cable issue where I the metal on the plug was just touching the case slot and it caused an issue. Had to dremel the case back a bit and it fixed. There is never any telling sometimes what will cause an issue. Maybe your old cable got a kink or something, heck even oxidation happens in some climates. Just always happy when people can just get back to gaming!


Previous cable, when it was unplugged from the previous setup, was just laid down behind where the case sits.  No signs of kinking/damage of any kind and I wouldn't expect there to be considering I practically white glove everything I own.  Maddening issue but with new tech there's always a possibility of oddity.  It seems fixed but then my wife saw an issue today described in my most recent update to the other response above.

Adept II

BSOD at 6:27AM this morning while playing back video in VLC overnight:

Bug Check 0x116 VIDEO_TDR_ERROR

Temperature has never been an issue as my house is kept at 65F and the Spire cooler kept the chip under 70C when running Prime95.

Am down to the final 48 hours before returning everything.  I'm not fond of G.Skill RAM as they can't seem to keep their sinks LOW to work with many air coolers which I may or may not someday want to put in this machine.

Anyhow will put a different disk in and install the latest 16299 build on that and see if the same problem occurs before beginning the fun of RMA'ing...  Wheeeee!!!


Did you try Windows 10 1803 yet?


No am sticking with 1709 (10.0.16299.402) for now.  Have video playing and enough to run for the next 24 hours.  Going to call Corsair at 7 and get their take.


I think I asked this before sorry if you already answered and I missed it. Does this only happen with VLC? Have you had this issue with other media players? Have you mentioned this issue in any VLC forums. I know I have had issues in the past and some of those guys know exactly what to tweak in VLC to fix stuff. Not saying its not a driver issue one way or the other, just maybe someone already found a workaround and that would be a good place to find it.


The glitches mentioned have happened when watching streaming video via NHL's GameCenter as well as just when clearning Firefox's cache and when running UNIGINE's Valley benchmark so it's not just a VLC thing.  This is a purely stock setup.


I sure think that you might benefit from moving to Windows 1803, you can certainly still do anything you want, but also you still can roll back easy enough if the new Windows isn't helping, but ultimately you have to move forward eventually anyway. Just thinking that this new Windows likely has better support for that processor. I don't however know that for a fact, but have seen several posts form others with chips like yours being happier with the new Windows. Just throwing that out there again.


Not sure but the return decision needed to be decided yesterday so I bought a new 2400g, Motherboard (ASRock X370 Pro4) and Corsair 16GB RAM kit listed on the Raven Ridge QVL and had it all shipped overnight while opting to RMA back this 2400g, ASRock AB350 Pro4 and the Corsair 8GB RAM kit for a full refund.  Thankfully I have a terrific purchasing history with Newegg and have returned less than 1% of anything I've ever bought there since 2001 so their Customer Service took care of me.

Honestly this hasn't been fun but as far as my cred goes I spend my days troubleshooting network equipment for yet to be released 40/100GbE products in Dell/EMC, HPE, Supermicro and Lenovo Servers with switches that all cost tens of thousands of dollars each.  Plus I have been working with the Server 2016 RS4 releases for the last two months through to and including build 17134.  Additionally I run RHEL, SLES, CentOS, Ubuntu Server and FreeBSD at work and at home I've got Windows, FreeBSD, a Sophos UTM (SLES based Firewall), an Ubuntu Server, OS X in VMware Workstation and a handful of Android devices to maintain, so I feel comfortable saying I'm capable of troubleshooting.

That being said I have gone to war with this trying ideas left and right and while I appreciate the "fresh Windows" idea uninstalling all AMD drivers/software and DDU'ing prior to the upgrade should have been good.

Plus this past weekend I (forgot to mention this) uninstalled, DDU'd and reinstalled all AMD drivers/software only to see that Bug Check 0x116 VIDEO_TDR_ERROR occur Tuesday morning.

Anyhow all of the issues mentioned here have very rarely been reproducible and there have been days between events so if it was a Windows OS issue necessitating a clean install you'd think it'd be more consistent/easily reproducible.


I don't think any of your issues are you and you are not alone in your issues. I hope that the new stuff you get will fix things. If not and you can exchange again I would recommend a real course change so you can go back to gaming, video or working without having to worry about the computer itself. You should be able to put this stuff together and it just works.  Did Newegg charge you the restocking fee? That is what drove me away from them. I buy mostly from Amazon and MicroCenter now. As when I have problem equipment Amazon pays to take it back and with MicroCenter I have them here locally. I was a huge user of Newegg for 20 years and when the Chinese company bought them out boy did it go down hill, IMHO.  Let me know if the new build is better. Good Luck!


Well the goal here all along was the present best APU in existence which is the 2400g.  Something low power but with the muscle to game at pretty decent quality settings vs. the electricity guzzling setup I previously had just so that anytime my sons friends come over they can play L4D2, TF2 and so on.

Anyhow bad run with only my second Ryzen but it could have been any of the three main components to blame so I'll chalk this up to ____ happens.

As for the restocking fee --> Newegg has it down as a full refund back to my Preferred account and they paid for shipping.  Package is in the hands of FedEx so they'll get it likely Tuesday.

I know there's a lot of commentary swirling around with Newegg and the Chinese ownership but I've never had a problem with them and both personally and professionally have a lifetime tab in the six figures.  Their site navigation, filters and search are leaps and bounds better than Amazon's.  Plus as a company I really appreciate their efforts against patent trolls.

New setup is looping UNIGINE's Valley now and ran video in VLC (3.0.2) overnight without issue.  For the record I have the system running off the OS installation that I started this thread with.


That's cool to know that you are using the same OS too as many would suspect the OS no matter what. With as many issues as I have seen with these things both board and cpu I have suspected hardware issues myself more than anything mostly because if it were all of them you would hear about it in the news, the issue is really just a bit bigger than what you see hear normally. I would say that it is probably some lax QC going on in the early manufacturing. It will likely get much better as the work the kinks out in the fab. 

Enjoy your new system!


72 hours in and the new hardware has yet to glitch in any way.  Since my last post I have had the system scripted to loop/run eight hours of continual x264 video playback in VLC, six hours of Valley, two hours of video, four hours of Prime95 and then four hours of Heaven.  Have intervened twice to put the system to sleep (once manually and the second time I stopped everything and let the system sleep on its own according to the Ryzen Balanced Power Config Profile).  Let the system cool down for a while then woke it up and restarted the script.

Tonight I also spent a few hours playing Portal 2 with my son, after shutting down the script, and it is smooooooooooth at 1080P 2xAA and everything set to "Very High" or "High".  It's back running the script now.

Can't stress enough that this is the exact same upgraded (8.1 to 10) OS environment so it wasn't anything software and definitely was hardware.  Unfortunately it could have been any of the three main components to blame so it all had to go .


So happy you can put this behind you!

Happy Gaming! .....oh and video.....


Thank you !

I have to say this is a great chip now that I have everything functioning stable.  My lone gripe is on the decision to do TIM on the Ryzen APU's between the die and heat spreader vs. soldering.  In the past some APU's were soldered and while this thing doesn't necessarily require such it would certainly benefit from it as seen by the thermal decrease obtained from delidding/using liquid metal instead of TIM.

I'm not interested in delidding this chip but am on the fence with keeping the Wraith Spire in use vs. getting a Noctua NH-U12S.  Can almost certainly see a decision on that front coming in the next couple of months as ambient temps go into the 90's.

first thing, check for a BIOS update for your motherboard

windows 10 v 1803 still has many festerring issues to fix and many will be fixed next week on tuesday


1803 actually made things interesting today...

I upgraded to it last night, wife called me today saying that everything she was playing was turning blue.  People looked like they were in Avatar.  I'm creating a new thread for that issue.