Showing results for 
Search instead for 
Did you mean: 


Adept II

New Ryzen 3900x x570 random restarts, WHEA-logger error ID17, PCI Express Endpoint, no bsod, no log, no dump

3900x w x570 mobo is crashing, new build, random freeze but (way more frequently) restarts with no events in the evenviewer present before the crash happens. It just looks like someone pushed the restart button. I've read about the WHEA-Logger events in the eventviewer and intdeed it seems to be my 2080Ti is causing some issue with the PCI Express slot.
Whether or not this is the reason why my PC restarts is not definitive tho as I have literally no way of determining which component causes the crash. I have an 850W gold rated EVGA power supply so that should not be an issue. Also I was able to play metro exodus with all the fancy raytracing turned up all the way with no issues whatsoever. Then I just checked the windows app store and it suddenly restarted. I have no clue what to do about it. 

157 Replies
Adept II

Small update:

I’m still having similar issues on 3900X with AMD chipset driver /Asus ROG CROSSHAIR VIII HERO (WI-FI), BIOS 0803 AMD Agesa Combo-AM4 / ASUS ROG STRIX GeForce RTX 2080 O8G, 436.20 DCH driver / G.Skill F4-3600C16D-16GTZNC on DCOP 3602 profile CL16-19-19-39 at 1.35V – DCOP enabled or disabled makes no difference. BIOS is stock (optimized defaults). OS Drive: Samsung 970 EVO NVMe M.2 1TB, Win 10 Pro 1903.


My Ryzen Master application is now completely broken, and I cannot reinstall it (treated in a different support ticket), so I have to rely on HWiNFO64 for temp readings now.

Could a anyone have a look at these values and see if they are normal?


This was during idling/low usage of CPU, normal usage (light browsing, working in Word), with more than adequate cooling (CPU: Noctua NH-U12S, with 2 Noctua NF-F12 industrial PPC 2000 PWM fans / for NZXT H700i Case: 3 x be quiet! Silent Wings3 120mm PWM High-Speed, BL070 (front), 3 x be quiet! Silent Wings 3 140mm PWM High-Speed, BL071 (2 top, 1 exhaust).

Logging is over 60 minutes with mobo “CPU package” temp an average of 56C, cpu median 56.8C under completely normal load (3-4% load). The average core voltage is 1.443V, again on normal usage. The latest chipset driver seems to have done nothing for me.

I have tried all suggestions listed in this thread; I've also disable services one by one to see if a specific program was the culprit, but I'm still getting these high readings.

This is on Ryzen balanced; the windows balanced power plan gives similar results.

I've 'only' had one random restart this week, which is an 'improvement' I guess…

HWinfo64 log temps voltages 2019-09-13 101329.jpg

Adept III


I had a random restart while playing DooM with 3600 CL OC'd RAM after I installed latest

Reverted back to and 3000 CL16 RAM, not occured again, will troubleshoot more to determine he culprit, possible bad RAM timings&OC

BiOS is 1003 ABB, which again may be the responsible, didnt have same problem on 1003 A BiOS

Update: I changed my RAM to Trident Z Neo which is "designed" for Ryzen x570. So far I have not had any crashes. It has only been 1 day however so we will see how it goes as I test further.

I also have C-State disabled. With C-State disabled before, I had less crashes but it still crashed during idle. Maybe it was a combination of C-State and RAM. 

If it was the RAM, I am really surprised. I ran Memtest with 0 errors. And if I use this RAM on my Ryzen 1700x, I have zero problems.



I am running trident z-neo as well now. 32gb.

On Mon, Sep 16, 2019, 10:51 PM disappointedamdcustomer <

Adept I

Update: also found out that sometimes the system freezes while I am doing something in BIOS. Kinda scared to update it now.

Adept II

Turns out it was my PSU after all... I realise someone suggested it here already, but I just found it hard to believe and did not have the time to test with a different PSU.

So, over the weekend, to rule out my PSU as cause for this issue, I decided to go ahead and order a different PSU thinking that I’d always be able to return it to Amazon within 30 days anyway, with full refund.

I had taken screenshots and reports from voltage and power readings in HWiNFO64, to compare both PSUs.

Well, seems like my original unit, the Seasonic Prime Ultra Titanium 1000W, was way off. Just some significant values, from logging of 2 hours per PSU: 
- CPU core current: average: 20.89 A
- Core power: core 1 power average 1.12 W / core 2: 0.94 W / core 3: 4.34 W / core 6: 1.80 W / core 9: 1.34 W etc.
- CPU core power average: 30.12 W
CPU die/package average temps from 55-62, with a minimum of 48C.

Compare this to the (temporary?) replacement PSU, a Corsair AX850:
- CPU core current: average: 9.34 A
- Core power: core 1 power average 0.50 W / core 2: 0.27 W / core 3: 2.22 W / core 6: 0.13 W / core 9: 0.10 W etc.
- CPU core power average: 13.08 W
CPU die/package temps from 45-50 on average load, 40-45 when idling/low load.

If you are seeing anything like the readings from the Seasonic above, it will most likely be a faulty PSU.

I invested quite a bit in the Seasonic, and I am rather disappointed. This is a 6-month old unit purchased brand new. I know anything is possible even with brands with a great reputation, but I cannot help wondering if the unit was already faulty when I first got it and used it in my previous Intel i7-6700k build. Maybe I never thought anything was wrong since I never got exorbitant temps, and since the core count is exponentially lower? Who knows... 

Anyhow, I’m relieved as this seems the solution; still waiting to hear back from Seasonic to see what they can do; RMA at least. 

As the temps/voltages have gone down, so has my blood pressure. Let’s hope it stays like this.

Anyhow, thanks everyone for the help - If anything, it’s been highly educational.


I thought I had fixed the issue with a new set of RAM (Trident Z Neo) but I got another crash today.

Saw your post and ran HW Monitor and see really high CPU Core Currents and Powers similar to your old PSU.

I am now going to purchase a new PSU and test. 

Please let us know if you still do not run into any issues going forward.


Whats your current PSU?


EVGA G3 650W



Well, I thought the issue was fixed with the new PSU, but it just reappeared. I'm getting unusually high temps again when idling.

This is on the latest Asus BIOS 1001 with AM4 combo PI patch ABBA, as well as latest chipset driver.

The voltages seem perfectly fine, but the temps are again high; 55C in idling/low load (per HWiNFO64), whereas initially it was around 40C (also per HWiNFO64).

An additional problem is that HWiNFO64 is reporting much higher values now than Ryzen Master; according to RM everything is running fine (40-45 idling), but my fans revving up per my fan xpert profiles on the mobo tell me otherwise.

I guess that’s RMA for me as well now.

Derridada, sorry to hear that you are still having issues.

Is your issue only the high temps or is your computer still randomly restarting?



I have not experienced any random restarts, but I have been refraining from heavy workloads (data loss is a real concern whenever this happens), since those restarts seemed temp related.

And it does seem to be high temps only. It's really strange; I'm basically getting the same voltage readings under the same cpu loads, but the temps are now 10C higher than before in HWiNFO64. 

However, Ryzen Master, when it works, reports healthy temps, but HWiNFO64 and my fans spinning up indicate much higher temps. If it's a sensor reading issue/software, then that's really strange, since I have not changed a thing since I switched PSU, and HWiNFO64 and Ryzen Master reported very similar temps until now. 



I have the same PSU Seasonic Prime Ultra Titanium 1000W and i have the same issue, random restart without any bsod or error, often when the pc is in idle by doing literraly NOTHING, even in the bios lol, meanwhile I can run memtest or prime95 for few hours and have no problem (at least on the MSI board, see below)

3900X (no oc/ no pbo)

Gigabyte X570 Xtreme (reboot can happen in 20min or after 8h+ and randomly, already passed 2h of memtest)

Before I had a MSI Prestige X570 Creation and reboot were random started ~2-3 weeks after purchase, hard reboot without error/bsod or any log happen after 25h+ or 2h.

32Gb Gskill royal Z 3200C14 oc to 3800C16@1.45V (already passed 20h+ of memtest with MSI Prestige X570 Creation so it's not the problem)

PSU Seasonic Prime Ultra Titanium 1000W (1year old)

- CPU core current: average: 12 A
- CPU core power average: 17W
CPU die/package average temps from 53-63, with a minimum of 46C.

+12V were ~12.3V with the msi, now it's ~12.456-12.528V with my new Gigabyte X570 Xtreme oO (tried to swap cables from my PSU, no change)
The only things that i have changed it's the motherboard and added a new Samsung 970 Evo Plus 2TB (nvme ssd), 4 NEW Corsair SP 140 RGB fan and a NZXT internal USB hub who use a molex connector to connect both Corsair lightning node pro and controller pro. (so yes, more load for the PSU)

Maybe my PSU is faulty ? (also noticed that one of my PSU-CPU cables was a little damaged because of the watercooling radiator when the problem started with my MSI, my fault, swapped cable but no change)

~12.528V on the +12V is not very good I think ? (anything higher than a 2% diff is not good with high end psu like this normally)

derridada Did you have any restart since you changed your PSU ?

Since I know that it's not my GPU, not my RAM, not the motherboard and not the all other parts from my PC, it can be either the PSU or the CPU.

Thinking to replace msy PSU since it's easy, replace a 3900X, not so easy :/


Hi goforce,

Sorry to hear you're having these issues.

I'm inserting an HWiNFO64 screen of some of the readings from my faulty PRIME Ultra SSR-1000TR. You can see minimum package power was 51 W, so really high -- the new PSU's minimum is half that, averaging about 30 W. The real issue was the core current though, with a 22 A average , while now I get 9.3 A; individual core power is much better now too. CPU core power averaged 30 W, now I get an average of 13 on similar loads (not gaming; just DTP work and multitasking).

Comparing your readings with the faulty PSU I had, I doubt there's anything wrong with your PSU, though I have no idea about what's normal with +12V; the average on the new unit is 12.250V, but the Seasonic was about the same (even lower). 

I only seriously considered a faulty PSU after sending this screen to Asus (the mobo manufacturer), who immediately told me those voltages were way off. So I got the new PSU and the system has been stable. I had one recent random reboot, but since I re-flashed my BIOS and did an old-school CMOS, taking out the battery and replacing it (instead of just pushing the Mobo button), and unplugging everything overnight for a real cold boot, I have not had any major issues (fingers crossed). Temps were a problem, but now things seem to have dropped to normal levels as well.

You should contact your mobo manufacturer with some of your readings, and see what they say. You should also contact Seasonic, and send them a screen of the power readings. I've found Seasonic really responsive - usually they get back to me within a few hours, with useful info. 

Seasonic HWinfo642019-09-13+101329.jpg

Journeyman III

Hello guys. 

So after a week or so now. My computer has sorted its self out. 

So what I did to fix this was;

-brought a NVME drive with a fresh windows 10 install 

-brought the G skill trident 3600hz (64GB but defo don’t need that) 

-replaced ALL custom cables, 24pin, 4, etc etc 

-down volted the voltage on the cpu, and Overclocked it a smidge. 

-enabled XMP 

I know this is a lot of steps. But unfortunately I just had enough and just went all out one last time to solve it. For all I know, it was just the cables which were bad, or the fact XMP wasn’t on..but there’s were the steps I had done which has given me an entire week of no crash, or bad boots or any problems. 

Hope you guys get this sorted soon. 

Wish you the best luck. 

Adept I

Hey guys, finally good news that Gigabyte released few minutes ago new BIOS F42d for X470 AORUS ULTRA GAMING  with AGESA ABBA and all WHEA errors are gone now, finally!!!


I have Aorus Elite x570 and I installed the ABBA bios yesterday, for me no change, I still get random restarts with XMP on 3200mhz

tho VCORE voltage seems to be lower which was being reported ridiculously high before (temps didn't change so it was probably a displaying bug)

anyway I'm still pissed that I have to run my memory 200mhz slower to run the PC stable

Adept II

Okay guys, so I updated my bios to F5b AGESA ABBA on my x570 Aorus Elite motherboard, and it didn't fix anything at first BUT, up until today I only updated the chipset ONCE from the Gigabyte's motherboard support website where there is only one chipset driver. So poked around the AMD site a bit and LO AND BEHOLD there were two new chipset drivers. Installed the newest one, performed reboot straight into the new and pristine bios, turned on XMP 3200mhz on my dual channel dual rank Corsair Vengeance RGB PRO 32gb, booted into windows aaaaaand... no reboots so far! Been running for 9 hours playing games watching videos, running idle doing whatever and it seems to be finally stable. I think the problem were the old chipset drivers. As a bonus my ridiculous VCORE voltage that used to run close to 1.5 at all all times, seem to be now much lower at idle and rarely goes over 1.4 volts. Good luck guys!


Replaced my PSU and am still running to random crashes.

Before the crashes would only happen during idle/desktop browsing but now the crashes happen anytime.

I have had enough of this computer. Worst experience I have ever had with a new PC. I have spent over a month troubleshooting this computer. I have changed ever single piece of hardware (besides CPU). I have installed all the latest drivers. I have tried all settings. Nothing is working. This is 100% the last time I ever go with AMD. Horrible product.

I had my CPU RMA'ed and replaced my PSU with a Corsair RM650i. So far so good, no reboots or WHEA errors, and my workers are no longer failing in 16K Small FFTs in Prime95. Try to get an RMA to your CPU as well.


I am in the process of RMA'ing the CPU. The simple fact I have to RMA a brand new $500 CPU is ridiculous. Beyond that, I have spent 5 weeks troubleshooting and AMD customer support has been nonexistent. They don't provide any solutions or help.

No matter how well the new CPU (the replaced one) performs, I will no longer be buying AMD products. 

Journeyman III

I had these issues with a Gigabyte x570 Aorus Ultra. They told me the memory wasn't on their QVL. I replaced the mobo with an Asus Crosshair VIII Hero Wifi  with the same memory that is not on the QVL either at D.O.C.P. with infinity fabric @ 1867 and the issues are gone. I am sure it was memory related but I don't exactly what the issue is.

Memory is G.Skill F4-3733C17D-16GTZKW

The Gigabyte board would not run right at any voltage or timings @ 3200 Mhz and above with infinty fabric left to auto or reduce to optimized default speed. It would run fine with optimized defaults on a fresh bios. The F5 and F6 bios got rid of the WHEA errors and it would run for a few hours fine but then it would hard reset playing games or watching netflix.


CPU  3900X

MB  Gigabyte x570 Aorus Ultra (BAD)  Asus Crosshair VIII Hero Wifi  (GOOD)

Memory  G.Skill F4-3733C17D-16GTZKW

GPU  MSI 1080ti Gaming X Trio

SSD  Samsung 860 EVO

PSU  Seasonic 850 Prime Titanium

Journeyman III

Hi Folks,

got the same Problem with a MSI x570-a pro and a 3700X: Crashing when installing drivers and random restarts. 

I tried different RAM, a different graphic card, returned the mainboard,... Same problem with a new one. 

And now the unbeliveable solution for my problem:

Disconnecting my SATA-DVD-RW!

After that, everything is fine. 

Hope, that will help.


So AMD expects you to use your computer without SATA? I think you found a band-aid solution. Something is wrong with your CPU if after all the new parts, it was crashing.

When I spend $500 on a CPU, I expect everything to work holistically. 


Hey, i‘m disappointed too, no question. I spend a lot of time in testing and that‘s not what i expected. (I don‘t like to be a beta-tester while paying the full price.)

I only thought it was helpfull.  

I will test the System with other SATA devices and report the results to AMD and MSI. 

Perhaps someone else can confirm the solution...

best regards!


It has been over 5 weeks with this computer and no solution.

I need some help here... $1000+ spent and the computer doesn't work.


In appeared to be a faulty memory controller in my case. Doing RMA now. Does anybody know how long does it usually take with AMD?


What kind of cpu do you have? If it's a 3900x you will be very lucky lf they give you a new one because they are short on supply. My guess is it'll take at least 2 weeks minimum. 


No, It's 3600X, those they should have in stock. The thing is, they haven't even sent me the "further instructions".


How did you find out it was a faulty memory controller? That sounds like something wrong with my CPU but was wondering if maybe you had it tested via a third party.

I am also trying to RMA the CPU but they are not responding to me. Horrible customer service. It is bad in the first place that you spend this money and get a faulty product. It is even worse that they are slow to respond and get you a functioning product.

100% will NEVER buy AMD again. I don't care if their CPU's are great on paper. They always have issues when releasing new products. Just go look at their new video cards and having a bunch of BSODs. I had issues with 1700x and RAM compatibility. AMD does not know how to release a stable product. 

Journeyman III

Hi all,

Sorry for my english, I am french.
I post here after searching on the internet why my PC has random shut down.

First, my PC :

-Gigabyte X570 Aorus Ultra with F6a bios

-AMD 3900X (no overclock)
-Samsung SSD 970 EVO Plus M.2 PCIe NVMe 1 To
-G.Skill Trident Z RGB 32 Go (4x 8 Go) DDR4 3600 MHz CL17
-Corsair AX860 (6 years old but she was OK witk my last CPU)

-RTX 2080 TI FE

I have random shut down. The PC don't restart, it is like someone cut the electrical power of my house. I have to power on the PC with the button. The shut down comes after 15 minutes or 5 hours, in game or on the web, idle.

I test my PSU, CPU, graphic card with OCCT, I test my RAM and all are OK (0 errors). With my old PC, I had no problem with my PSU and graphic card.

I use in the bios a function that restard PC after electrical shutdown, so thats confirm no problem on electrical power of the house.

I use XMP profil and that seems to be OK with RAM test.

I have read all posts and I am disappointed of this. Nobody in this case have a solution.


Finally I changed 6 weeks ago my PSU (a new corsair ax1000). 100 hours of gaming and others softwares without shut down. My CPU and my motherboard are finally OK. My old ax860 is perhaps dead.

Journeyman III

Hi, I also have the same issue. random restarts no error codes in the event viewer except Event 41 Kernel-Power task 63. I replaced the mobo with no success. Currently have a replacement CPU on the way I will report back if it fixes the issue.

AMD 3800x

Asus Strix X570-E Gaming

Corsair Vengeance LPX 16GB 3200

Evga 1000 G+ PSU

Zotac 2080 Super


Did the new CPU fix your issue?

I sent in my CPU and am now waiting to receive a new one. I don't know how long this will take.


My new build works flawless. I just didn't bother with the 'reset' switch from the case...just plugged in my power switch. Also, I did NOT flash the bios. I haven't had a black screen or crash at all since. 


It did for me.


Good to know. I am now just waiting to receive my replacement CPU. 

Will report back once I receive the new CPU, install it, and have some time to test it out.


Yet, when I open the event viewer, I see that sometimes apps crash with the "memory access violation" error. It doesn't reboot now, though, and no WHEA and stuff.


I have had the replacement CPU installed for over a week. Not one single crash or random reboot since then.

It was 100% a defected CPU. If anyone out there sees this forum posting and is having similar issues, please request an RMA immediately.

These 3000s CPUs seems to have weak IMC and lots of people are running into these issues. 

I am very disappointed it took 7 weeks to have a functioning computer. At least the computer nightmare is finally over.

Same here.