Showing results for 
Search instead for 
Did you mean: 


Journeyman III

New Ryzen 2400G MSI B450 Tomahawk build fails to post.

Ryzen 2400G,
MSI B450 Tomahawk,
Corsair CX450,
Corsair Vengeance LPX DDR4 3000mhz (8GB x 2) - this is non QVL,
Corsair Spec 04.

I've connected everything properly but still don't get any post, cant access or see BIOS. Monitor shows 'No signal detected'.
I tried ram in single slot (in all 4 slots), tried dual channel in both dual slots. even tried without any RAM. Still no post. I tried updating the BIOS to latest stable version which had added more memory support. It wasn't posting even before updating the BIOS and still isn't even after the BIOS update. Also the red CPU debug light stays on for like 5 seconds before it goes off (rest of them go off in less than a second). I tried re-seating the CPU again but it still didn't fix it. There were no broken/bent pins on it either. I tried resetting CMOS jumper. And I don't hear any error beep codes either (even after removing all ram sticks. I just get a red ram led but no beeps). I do not have any discrete graphics card. So I'm relying on the iGPU of 2400G. Please help me out. Thank you!

1 Reply

Re: New Ryzen 2400G MSI B450 Tomahawk build fails to post.

See if this website helps by configuring the RAM to see if it will POST thru BIOS: