Showing results for 
Search instead for 
Did you mean: 


Journeyman III

New Build (3700x, Asus x570) having random freezes


Asus ROG x570i

* 3700x

* EVGA 2070S XC Ultra

* Corsair LPX 2x16 3200MHz 16-18-18, Nanya Manufactured Detailed View

* Sabrent Rocket 4 1TB SSD (With fresh Windows 2004) + Samsung 860 (Backup game drive, brought over from last PC)

Issue I have been having

I got my new build set up with a fresh Windows install, and everything seemed to be working fine. The next day after setting up I was waking the PC up from sleep and the PC was frozen when I woke up it. Figured it was a weird sleep issue, and restarted and disabled sleep.

The next day I went to go on in the AM and realized it had frozen again (this time no sleep involved). 7-8 hours it froze again when I was out of the room.

I would like to point out, these aren't 'normal' freezes. There is no BSOD. And it's not like EVERYTHING is locked down. For instance, I am able to click on other tabs in chrome, and the tab switches. But I can't refresh anything. I was able to open a new tab, and Gmail loaded (so not an internet problem) but I wasn't able to do anything on that tab. I tried to get into task manager (to see if there was a weird program using too much CPU or something) but task manager wouldn't load either. Start menu wouldn't open, and I wasn't able to restart or shut down. Had to use power button to force restart.

I thought maybe it was a bios issue, so I updated the bios from 2407 -> 2606. Left it overnight and when I came back this morning there was no freezes! However, a few hours later they started popping up again.

- Also worth noting that all of the freezes have come while the PC is idling (outside of the memtest64 crash) and I'm afk. I've played probably 20 hours worth of games and it's never crashed during that time

- Also worth noting that I have been using Ryzen Balanced Power Plan + DOCP Profile

Things I have tried so far

* Updated Bios from 2407 -> 2606

* Updated chipset drivers through AMD software. 

* I ran Memtest64 and within 2 minutes everything got really slow/bogged down. Tried to pull up task manager and I the PC froze with a spinning blue screen (not BSOD, but there was a blue screen trying to do stuff). 

* Just before this post someone suggested that it might be one of the 'Ryzen' power plans - so I switched from 'Ryzen Balanced' to default Windows balanced.

Things I am thinking about

* Is the Ram an issue? It ran fine on my Intel machine for a few months, so the ram isn't defective. Maybe it's not AMD optimized though? The Amazon page says that it is supposed to work with AMD though, so I am not certain.

* Is the DOCP profile not stable? If that is the case, then would that be an issue of the chipset/mobo or the Ram being the issue?

What things should I be trying out to diagnose this properly? Should I start looking into a return of the mobo/CPU (have 2-3 more days under the return window)? Or should I look to buy some more 'AMD optimized' Ram?

Thank you for your help!

1 Reply
Journeyman III

If anyone is having similar issues and finds this thread in the future I wanted to post what helped me.

The ram I was using was a recent Corsair 32gb 3200MHz 16-18-18, manufactured by Nanya. Looks like Nanya doesn't make great chips (or maybe just not binned well) compared to Samsung/Hynix/Micron. 

I upped the voltage to 1.4 in the bios, and no crashes for 48 hours. If it does start crashing again I think lowering the MHz to 3000 should work as well. 

I should have done more research on the ram, but looks like some of the cheaper ram may have trouble hitting XMP/DOCP profiles. It also ran fine on my Intel machine for a while, so it must be right on the edge.