cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

papazil
Newcomer

My Ryzen 5 3600 is stuck at base clock

I have a newly bought Ryzen 5 3600 with an Aorus b450 pro running latest bios and installed ryzen master and also motherboard drivers. I cant manage to push the processor beyond the base clock of 3.6Ghz. I have tried running cinebench R20 on which I only achieve 3150 points. Also tried running various games. The max frequency of all cores is 3618Mhz. I have also enabled PBO in Ryzen Master in the Gaming Profile and it does nothing at all. The ram xmp seems to be working fine. Also in the bios the frequency settings seem to be locked I think, but not sure about that. I dont know what to try. The processor is underperfoming a lot because of that. The temperatures are maxing at 57 Celcius and the stock cooler is somewhat quiet. Ive tried running Cinebench r20 before and after installing the ryzen master and enabling PBO(also restarted my computer several times) and the score is the same. I just opened the Ryzen Master while writing this and it was unresponsive. The 2nd try it asked me to reinstall it.

0 Likes
2 Replies
cosmicdance
Elite

Re: My Ryzen 5 3600 is stuck at base clock

Try enabling PBO in your BIOS as that is the usual procedure.  

Also ensure your AMD chipset drivers are up to date.  

What are your temperatures like whilst running Cinebench?

Andy

0 Likes
misterj
Exemplar

Re: My Ryzen 5 3600 is stuck at base clock

papazil, the problem may well lie in bum applications.  Please open Settings-Apps and uninstall any and all applications you do not know especially ASUS and that thing you posted.   Reboot, do a Clear CMOS and try again with all factory settings.  Run the latest Ryzen Master (RM) 2.1.0.1424 and post a screenshot.  Thanks and enjoy, John.

0 Likes