Showing results for 
Search instead for 
Did you mean: 


Adept I

My Ryzen 5 2600 doesn't work with my Asus GTX 780 DirectCU 2

I bought a 2600 upgrading my 1500x, i was going to use it on a x370 killer sli and a gtx780 DirectCU2, didn't work at all. I tought it was the motherboard so i bought a x470 ultra gaming, using it with the 780, didn't work. So i borrowed a gtx 1060 from a friend and it works fine. How is that possible? A cpu that is incompatible with a specific video card? never heard before

25 Replies
Adept I

BTW, the gtx 780 works fine, it worked fine with my 1500x and now works with a 4790k, so not the GPU fault


I have the same dilemma.

I wanted to pair a GTX Titan Gen1 (6GB) (OEM Design) with an MSI X370 Pro Carbon (updated via APU to recent BIOS) and a Ryzen 5 2600. It was not working.

So I thought, let's take an X470 Board (in my case ASRock X470 Master SLI) as it should rule out incompatibility to Pinnacle Ridge (Ryzen 2600, 2700).

Again, it doesn't work.


The GPU is now back on the old AM3 setup with FX CPU and working fine.

Raven Ridge and Summit Ridge (Ryzen 1000 series and Ryzen 2200/2400g CPUs) are working fine.

Pinnacle Ridge in combination with nVidia Generation 800 series and before does not boot (VGA undedetected as per the board beep or led)

The reseller of the hardware pieces was doing a test run today and as a matter of fact they tried with several components (different ram, different Ryzen 1000 and 2000 series on several boards (B350, X370, X470) and the results were clear:

All older generations of Nvidia GPUs (800 downwards), which they tried did not work, 900 series and 1000series GPUs do work though.

As I don't have the money to also buy a new GPU nowadays I am considering of cancelling my purchase in its entirety, as I would not shift to intel, nor buy a new GPU.

It's interesting, how this could not have been tested? There will be plenty of people with such older generations GPU, which would like to swap it over to a nice 2000 series Ryzen config.

Hope it helps and that there is a fix soon!




Glad i'm not the only one!


I was "down-upgrading" to a Ryzen 5 1600 (not even X) now, as I wanted to get it working finally. Just writing this from the fresh install...

Compensation for my efforts to waste 100€ on fuel (as there are no local retailers anymore) for the exchange and testing purposes to proof that it is an incompatibility to figure out a solution was not really given. It's a shame, that this has obviously not done properly by Q&A. Hopefully they gonna fix in one of the next AGESA updates!!!


Adept I

Description of ASRock AB350M Pro4  current BETA BIOS:

"2.Improve NVIDIA VGA card compatibility when CSM is disabled."

Maybe you try to enable CSM? I cannot test anymore....

Hope it helps


My x470 ultra gaming comes with that option enabled, and it still doesn't work

Adept I

EN (translate): Hello I just purchased a Ryzen 5 2600 processor and I have the same problem with my GTX 780 gainward that does not want to work.

I have a GTX 560ti gainward that works very well with ! so it's not compared to the old Nvidia series...

I'm looking forward to a solution or I'd have to go back to intel...

at least I'm glad to see I'm not an isolated case !

ps: I installed all this on an "Asus Prime x370-pro"

FR : Bonjour je viens de faire l’acquisition d'un processeur Ryzen 5 2600 et j'ai le même problème avec ma GTX 780 gainward qui ne veux pas fonctionner.
j'ai une GTX 560ti gainward qui fonctionne très bien avec ! donc ce n'est pas par rapport au anciennes séries de Nvidia...
J'attends avec impatience une solution sinon je serais obliger de repartir sur de l'intel ...
en tout cas je suis content de voir que je ne suis pas un cas isolé !
ps: j'ai installé tout ça sur une "Asus Prime x370-pro"



EN: here is the answer I got... I've been waiting for 6 days now...
FR: voici la réponse que j'ai eu ... j’attends maintenant depuis 6 Jours ...



It's not the motherboard fault, it's the CPU. I've tested the same motherboard with a 1500x and a 2600, with the 1500x the 780 works fine, with the 2600 it does not work.

Inviato da smartphone Samsung Galaxy.


Good luck...In 30 years plus of gaming and through many systems and configurations, I've never owned a cpu that would not support my gpu--no matter what it was.  Or heard of it happening to someone else.  My R5 1600 runs perfectly in my x370 mobo my AMD RX-480.  But then, I've been with ATi/AMD since 2002, so that may well be why...;)


Me neither. I've had multiple AMD/Nvidia/Intel CPUs/GPUs never, and i mean NEVER a compatibility issue, this is the first time.

Journeyman III

Jumping in this as well...

I have a GTX 780 card that does not work with Ryzen 2700x. Testing other cards, before and after the 700 series work fine.

Does anyone have a solution to this? I tried to contact AMD, but they do not answer.

Never even heard of a capability issue with GPU and CPU either. It took me hours upon hours of troubleshooting and researching to come to this strange conclusion.

I'm curious why this isn't a more largely known issue. It's taken quite a bit of effort to find any information on this and every thread is either deleted by AMD or there just is no answer across the internet. I haven't found anyone that has gotten a resolution, besides getting another graphics card. However, I do not want to buy a new graphics card until the next generation, as my GTX 780 is plenty fine for now.

Thanks in advance for any help/discussion!


No solution man,
I think that ryzen 2 is not compatible with the GK110 (GTX 780 and Titan's GPU) in particular, i think that it's a widespread problem but few people use a gk110 based gpu with a ryzen 2.

We're too few for AMD to care, that's a reality check.
I changed gpu but next time i have to upgrade the CPU, i think i will not pickup another AMD processor.

Best way for AMD to acknowledge a problem is by Users reporting the problem via AMD Support Tickets.

AMD EMAIL SUPPORT: Email Form​ . (will get an answer back from AMD Support)

AMD REPORT ISSUE : AMD Issue Reporting Form  (Will not get an answer back but will alert AMD Support of an issue).

Unfortunately, it seems AMD does not answer these support tickets or even acknowledge they are looking into the reports... It's really making me reconsider my choice to switch to AMD, to be honest.

I think syriochan is right, though. There really is not many of us still on this old GPU with a new Ryzen 2nd Generation. On top of deleting threads and support not answering, there really does seem to be no recourse for us.

I even reached out to Nvidia, just because I was curious to see if they have gotten any reports. The rep claims they have not gotten any reports of the 780 not working with the Ryzen 2nd generation. However, they claimed the 780 Ti certainly worked, but could not confirm on the standard 780.

I am debating returning my Ram, CPU, and Mobo because of this and just going back to intel. But it's honestly such a hassle, even if there was just an acknowledgement of AMD looking into it/working on a fix, I'd be happy enough. I could suffer another few weeks/months to finish my system, figuring I've been using the same build for 5 years now.

Adept I

If AMD does not care, we can try reaching out to a techtuber with this thread, if they make a video about it, maybe amd will be obliged to look into it.

Journeyman III

I had the same problem.

Ryzen 2600

Asus ROG Strix B450-F (latest BIOS)

Gigabyte GTX 780

The GPU is NOT recognised in either of the PCIe16 slots driven by the CPU (white LED indicating VGA problem)

The GPU WORKS in the 3rd PCIe16 slot which is driven by the chipset.

I have tried other GPU cards and they all work fine.

Obvious incompatibility between GTX 780 and Ryzen 2nd gen.

Hopefully will soon be fixed by mobo BIOS update.

Journeyman III

I can confirm the Problem.

My Setup: Ryzen 5 2600 @ Gigabyte Aorus B450 Pro Gaming Mainboard.

Got the Asus GTX 780 with DirectCU II and it doesn't work on the first (mainly) PCIE Slot, only on the second or third one which is driven by the chipset. Sadly, the second PCIE Slot is only version 2 and runs at 4x Speed, so the GPU is significant slower compared to my old Setup (i5 2500k @ ASUS Sabertooth P67).

I hope there will be a fix soon.


Got the same problem. Just bought a Ryzen 2700x and installed on an Asus ROG Strix x470-F Gaming (3 pcie slots). Owning already a Gigabyte GTX 780 Windforce 3X, thought why not use it as it still kicks really well for a 2013 card.

But of course i get POST vga errors as long as the card is installed in the 1st or 2nd slot. In the 3rd slot it works fine but it's slow as hell and also it messes up my usb connectors on MB and also the front audio headers as the video card is kind of big and forces things being all the way down there.

Now, for sure Gigabyte has no interest to update the bios of a 2013 video card so all hopes are in AMD maybe doing some sort of miracle on the next bios update (btw just updated today the bios with the latest version hoping that something got fixed since yesterday night when i started building up this system, but nothing changed).

I spent quite a bit on these components (cpu, mb, ram and ssd) so for sure i cannot afford spending more on a new video card. (Thinking also to contact the MB manufacturer Asus but i have a feeling they'll send me either to AMD or Gigabyte).

Hoping for the best!




Signed up to post here because I'm relieve I'm not alone! Spent hours going over error codes and combinations.

I had retired my functional first gen Titan to use a GTX 1060 instead. But last night I fired up the Titan only to encounter display issues. There is zero display (can't see BIOS either). However, it appears as Windows loads because I can hear the OS sounds (USB plugging in and out).

I'm using a Ryzen 2700 with an ASRock x470 Taichi board.

If I use the last PCIe slot, will the performance of the card suffer?

Adept I

Just got a response from AMD which I will post here:

Thank you for reporting your issue to us, we have had other similar reports and have reproduced it in our labs.

We have narrowed down the problem to be a compatibility issue between new and old technology, the GTX 780 is over 5 years old.

That being said, we were able to work around the bootup issue by setting the PCIe option in the motherboard BIOS to Gen 1.

If you can access your motherboard BIOS and it supports this option, then this may be a feasible workaround for you.

If not, then you may want to consider contacting Nvidia support for further assistance with your GTX 780 issue.

So in other words, buy a new video card. Merry Christmas everyone!


I'm also facing this issue with a GTX Titan, I will try this fix later tonight and report back.


After trying various things including ensuring the power supply was fine and reseating the card I can confirm that changing the BIOs setting for PCI-e from AUTO to Gen-1 helped get it working. I also tried setting to Gen-2 and this worked also. Gen-3 and Auto both failed.

My setup is:

AMD Ryzen 2700X

GTX Titan

Asus B450-i


I believe syriochan's observation on GK110 based GPUs is correct. I have tried two older GPUs, a GTX 750 ti and HD 5670 and these both work but aren't GK110 based.

Despite setting to Gen-2 I haven't seen much reduced performance, I did a userbench score which can be seen here :

Good luck and I hope this is fixed soon for others, it was lucky I had some spare GPUs so I could change the settings, not sure everyone would be in the same position.

I just bought a second hand 980Ti G1 Gaming made by gigabyte at 220$ and this one works as expected. I do not have the option in bios to change pcie gen so I was stucked. Not anymore now.

Happy New year everyone!